SNI with ISPconfig 3 and Ubuntu Server 10.10

Discussion in 'Server Operation' started by swehes, May 6, 2011.

  1. swehes

    swehes New Member

    So I have installed the Perfect Server for Ubuntu 10.10 with mulitple server setup. I have been researching about TLS and SNI and been looking around in the forums here as well. I haven't found anything satisfactory however about how to get SNI to work properly. I use Comodo as my certified certificate verifier. But everytime I try to enter one of my domains, I get a warning message. Looking at the certificate it is good and it shows the correct domain name. I try this with Firefox 4, IE7 and Google Chrome webbrowsers. And I am running Windows XP so that explains IE7.

    What information is needed from me to help me understand my issue? log files, configuration files, etc.

    The three domains are swehes.com, geeksphone2usa.com, and freefromcontract.com
    I don't have anything on the domains yet, but if you put https://domainname you will see what I mean. The ssl used is positivessl

    Thanks in advanced.

    UPDATE: I found what my issue was. I was told that I would get a bundle file from Comodo but it never showed up so it really confused me. Going back to Comodo website and help for installing the bundle file they had a link do download the file manually. Installed the bundle file and now my three websites are coming up with individual certificates. :)
     
    Last edited: May 6, 2011
  2. Pasco

    Pasco Member

    How did you enable SNI on your config? I have the same config but I don't get how to get it work.

    Thanks! [email protected]
     
  3. cbj4074

    cbj4074 Member

Share This Page