sneding Postfix to qmail unknown user error

Discussion in 'Installation/Configuration' started by dexjul, Jan 9, 2009.

  1. dexjul

    dexjul New Member

    Hi,

    I install postfix by defaut in our local server and if I send in our mail server (qmail) it bounce back <[email protected]>: unknown user: "dexter.a" , but this account is valid.

    And I install postfix by default again in my pc via vmware machnie and I was received the email without any problem.

    I dont know what is a problem our local server is same with my pc vmware configs.

    Regards,
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Make sure that the MX record for your domain is pointing to the right server. Is there anything in the Postfix mail log when you send an email to that server?

    How did you create the email account? What's in your main.cf?
     
  3. dexjul

    dexjul New Member

    Here's the mail log
    Here's the con

    The account is on other server and using qmail. I dont know why not sending in same network.

    Regards,
     
  4. dexjul

    dexjul New Member

    Here's the mail log
    Here's the con

    The account is on other server and using qmail. I dont know why not sending in same network.

    Regards,
     
  5. falko

    falko Super Moderator ISPConfig Developer

  6. dexjul

    dexjul New Member

    Thank for your reply,

    But I already an email account on the other server using qmail.

    Regards,
     
  7. falko

    falko Super Moderator ISPConfig Developer

    But if the account is on the other server, then you must modify the MX record so that it points to the other server.
     
  8. dexjul

    dexjul New Member

    This problem has been fixed.

    Here's my main.cf

    [email protected]


    Postfix config

    [[email protected] ~]# postconf -n
    alias_database = hash:/etc/aliases
    alias_maps = hash:/etc/aliases
    command_directory = /usr/sbin
    config_directory = /etc/postfix
    daemon_directory = /usr/libexec/postfix
    debug_peer_level = 2
    html_directory = no
    inet_interfaces = all
    local_recipient_maps =
    mail_owner = postfix
    mail_spool_directory = /var/spool/mail
    mailq_path = /usr/bin/mailq.postfix
    manpage_directory = /usr/share/man
    mydomain = electronicscience.com
    myhostname = neoserver.com
    mynetworks = 192.168.0.0/24, 127.0.0.0/8, 202.124.146.32/27
    newaliases_path = /usr/bin/newaliases.postfix
    queue_directory = /var/spool/postfix
    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    relay_domains = 192.168.0.16, electronicscience.com
    relayhost = 192.168.0.16
    sample_directory = /usr/share/doc/postfix-2.3.3/samples
    sendmail_path = /usr/sbin/sendmail.postfix
    setgid_group = postdrop
    unknown_local_recipient_reject_code = 550


    Thank you for your reply...

    Regards,
    Dexter
     

Share This Page