smtpd pid 16212 killed by signal 11 - smtpd: bad command startup -- throttling

Discussion in 'HOWTO-Related Questions' started by HerrHorst, Jan 20, 2008.

  1. HerrHorst

    HerrHorst New Member

    Hello,

    I'm using a vserver and followed the Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch) Guide. That worked fine for over nine months.

    Since a few days I've got the following log entries when a smtp connection is established to the server:

    Code:
    Jan 20 22:26:23 h1276728 postfix/master[29940]: warning: process /usr/lib/postfix/smtpd pid 29947 killed by signal 11
    Jan 20 22:26:23 h1276728 postfix/master[29940]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    The server doesn't response with a 220. The telnet window is just empty

    I checked the memory of the server with memtest while it was booted with a recovery linux provided by my server hoster. All tests passed.

    Here are my postfix config files:
    main.cf
    Code:
    #
    # general
    #
    myhostname = mail.cuimat.net
    mydomain = cuimat.net
    myorigin = $mydomain
    mydestination = mail.cuimat.net, localhost, localhost.localdomain
    mynetworks = 127.0.0.0/8
    relay_domains =
    mailbox_transport = cyrus
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    #sender_canonical_maps = mysql:/etc/postfix/mysql-canonical.cf
    alias_maps = $alias_database
    #
    # sasl auth
    # for clients
    #
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_delay_reject = yes
    smtpd_helo_required = yes
    disable_vrfy_command = yes
    strict_rfc821_envelopes = yes
    smtpd_sender_restrictions =
            permit_sasl_authenticated,
            permit_mynetworks,
            reject_non_fqdn_sender,
            reject_unknown_sender_domain,
            permit
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    smtpd_data_restrictions =
            reject_unauth_pipelining,
            permit
    #
    # SASL TLS
    # for server
    #
    smtp_use_tls = yes
    #
    # SASL TLS
    # for clients
    #
    smtpd_use_tls = yes
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_only = yes
    smtpd_tls_note_starttls_offer = yes
    smtpd_tls_cert_file = /etc/ssl/certs/cuimat-net/cert/mailcuimatnet.pem
    smtpd_tls_key_file = /etc/ssl/certs/cuimat-net/key/mailcuimatnet.key
    smtpd_tls_CAfile = /etc/ssl/certs/cuimat-net/ca_cert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandom
    virtual_alias_domains =
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /home/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    virtual_create_maildirsize = yes
    virtual_mailbox_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    
    and here the master.cf
    Code:
    #
    # Postfix master process configuration file.  For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    smtp      inet  n       -       -       -       -       smtpd
    #submission inet n       -       -       -       -       smtpd
    #  -o smtpd_enforce_tls=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    smtps     inet  n       -       -       -       -       smtpd
      -o smtpd_tls_wrappermode=yes
      -o smtpd_sasl_auth_enable=yes
      -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    amavis  unix    -       -       -       -       2       smtp #amavis deaktiviert wegen mail problemen
            -o smtp_data_done_timeout=1200
            -o smtp_send_xforward_command=yes
    
    127.0.0.1:10025 inet n - - - - smtpd #amavĂ­s deaktiviert wegen mail problemem
            -o content_filter=
            -o local_recipient_maps=
            -o relay_recipient_maps=
            -o smtpd_restriction_classes=
            -o smtpd_client_restrictions=
            -o smtpd_helo_restrictions=
            -o smtpd_sender_restrictions=
            -o smtpd_recipient_restrictions=permit_mynetworks,reject
            -o mynetworks=127.0.0.0/8
            -o strict_rfc821_envelopes=yes
            -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
            -o smtpd_bind_address=127.0.0.1
    
    #628      inet  n       -       -       -       -       qmqpd
    pickup    fifo  n       -       -       60      1       pickup
    cleanup   unix  n       -       -       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    #qmgr     fifo  n       -       -       300     1       oqmgr
    tlsmgr    unix  -       -       -       1000?   1       tlsmgr
    rewrite   unix  -       -       -       -       -       trivial-rewrite
    bounce    unix  -       -       -       -       0       bounce
    defer     unix  -       -       -       -       0       bounce
    trace     unix  -       -       -       -       0       bounce
    verify    unix  -       -       -       -       1       verify
    flush     unix  n       -       -       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    smtp      unix  -       -       -       -       -       smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay     unix  -       -       -       -       -       smtp
            -o fallback_relay=
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq     unix  n       -       -       -       -       showq
    error     unix  -       -       -       -       -       error
    discard   unix  -       -       -       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       -       -       -       lmtp
    anvil     unix  -       -       -       -       1       anvil
    scache    unix  -       -       -       -       1       scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent.  See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail    unix  -       n       n       -       -       pipe
      flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp     unix  -       n       n       -       -       pipe
      flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix  -       n       n       -       2       pipe
      flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman   unix  -       n       n       -       -       pipe
      flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
      ${nexthop} ${user} #
    #cyrus unix     -       n       n       -       -       pipe
    #       flags= user=cyrus argv=/usr/sbin/cyrdeliver -r ${sender} -m ${extension} ${user}
    
    Any ideas whats going wrong? I know everybody says that, but i didn't change the config*g*
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any other errors in your mail log? What's the output of
    Code:
    df -h
    ?
     
  3. HerrHorst

    HerrHorst New Member

    Hey

    here is the result of df -h
    Code:
    h1276728:/# df -h
    Filesystem            Size  Used Avail Use% Mounted on
    /dev/vzfs              10G  2.6G  7.5G  26% /
    tmpfs                1007M     0 1007M   0% /lib/init/rw
    tmpfs                1007M  4.0K 1007M   1% /dev/shm
    h1276728:/#
    
    mail.warn
    Code:
    Jan 21 19:15:04 h1276728 postfix/master[29940]: warning: process /usr/lib/postfix/smtpd pid 26543 killed by signal 11
    Jan 21 19:15:04 h1276728 postfix/master[29940]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    
    mail.info
    Code:
    Jan 21 19:15:04 h1276728 postfix/master[29940]: warning: process /usr/lib/postfix/smtpd pid 26543 killed by signal 11
    Jan 21 19:15:04 h1276728 postfix/master[29940]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    
    mail.err has just old entries. Syslog looks like mail.log
     
  4. jamesloker

    jamesloker New Member

    Im having a similar issue

    Hi,
    Newbie here, followed the Perfect Server and Virtual Domain setup to the letter (almost).

    I can
    Code:
    telnet localhost 110
    and get the response
    Code:
    [email protected]:~# telnet localhost 110
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    +OK Hello there.
    but when i do
    Code:
    telnet localhost 25
    i get this
    Code:
    [email protected]:~# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    Now, i checked to make sure the response worked in between setting up Perfect Server Ubuntu 7.10 and Virtual Users and Domains Postfix.... and all worked fine. But when i got to saslauthd stuff, i think thats when it went pear shaped.

    here is my main.cf
    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    myhostname = aladdin.glemsfordschool.local
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = aladdin.glemsfordschool.local, localhost, localhost.localdomain, aladdin.glemsfordschool.co.uk
    relayhost = 
    mynetworks = 127.0.0.1/8
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    inet_protocols = all
    smtpd_sasl_local_domain = 
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    tls_random_source = dev:/dev/urandomvirtual_alias_domains = 
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /home/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    virtual_create_maildirsize = yes
    virtual_mailbox_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_mailbox_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    and master.cf
    Code:
    #
    # Postfix master process configuration file.  For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    smtp      inet  n       -       -       -       -       smtpd
    #submission inet n       -       -       -       -       smtpd
    #  -o smtpd_enforce_tls=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #smtps     inet  n       -       -       -       -       smtpd
    #  -o smtpd_tls_wrappermode=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #628      inet  n       -       -       -       -       qmqpd
    pickup    fifo  n       -       -       60      1       pickup
    cleanup   unix  n       -       -       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    #qmgr     fifo  n       -       -       300     1       oqmgr
    tlsmgr    unix  -       -       -       1000?   1       tlsmgr
    rewrite   unix  -       -       -       -       -       trivial-rewrite
    bounce    unix  -       -       -       -       0       bounce
    defer     unix  -       -       -       -       0       bounce
    trace     unix  -       -       -       -       0       bounce
    verify    unix  -       -       -       -       1       verify
    flush     unix  n       -       -       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    smtp      unix  -       -       -       -       -       smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay     unix  -       -       -       -       -       smtp
    	-o smtp_fallback_relay=
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq     unix  n       -       -       -       -       showq
    error     unix  -       -       -       -       -       error
    retry     unix  -       -       -       -       -       error
    discard   unix  -       -       -       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       -       -       -       lmtp
    anvil     unix  -       -       -       -       1       anvil
    scache	  unix	-	-	-	-	1	scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent.  See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail    unix  -       n       n       -       -       pipe
      flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp     unix  -       n       n       -       -       pipe
      flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix	-	n	n	-	2	pipe
      flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman   unix  -       n       n       -       -       pipe
      flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
      ${nexthop} ${user}
    amavis    unix  -       -       -       -       2       smtp
     	  -o smtp_data_done_timeout=1200
    	  -o smtp_send_xforward_command=yes
    
    127.0.0.1:10025 inet n - - - - smtpd
    	  -o content_filter=
    	  -o local_recipient_maps=
    	  -o smtpd_restriction_classes=
    	  -o smtpd_client_restrictions=
    	  -o smtpd_helo_restrictions=
    	  -o smtpd_sender_restrictions=
    	  -o smtpd_recipient_restrictions=
    	  -o mynetworks=127.0.0.0/8
    	  -o strict_rfc821_envelopes=yes
    	  -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    	  -o smtpd_bind_address=127.0.0.1

    Any help would be appreciated, i work for a school and we are using this ubuntu box as a intranet server and as a primary mail filter for our Exchange Server

    Kind Regards
    James
     
  5. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Please open a new thread for this.
     
  7. HerrHorst

    HerrHorst New Member

    hi,

    netstat -tap
    Code:
    h1276728:/# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 mail.cuimat.net:domain  *:*                     LISTEN     21620/named
    tcp        0      0 mail.cuimat.net:domain  *:*                     LISTEN     21620/named
    tcp        0      0 *:ssh                   *:*                     LISTEN     11909/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN     29903/master
    tcp        0      0 mail.cuimat.net:953     *:*                     LISTEN     21620/named
    tcp        0      0 mail.cuimat.net:https   *:*                     LISTEN     21678/apache2
    tcp        0      0 *:imaps                 *:*                     LISTEN     11738/couriertcpd
    tcp        0      0 mail.cuimat.net:10024   *:*                     LISTEN     28375/amavisd (mast
    tcp        0      0 mail.cuimat.net:10025   *:*                     LISTEN     29903/master
    tcp        0      0 mail.cuimat.net:mysql   *:*                     LISTEN     11550/mysqld
    tcp        0      0 *:finger                *:*                     LISTEN     11791/inetd
    tcp        0      0 *:imap2                 *:*                     LISTEN     11726/couriertcpd
    tcp        0      0 *:www                   *:*                     LISTEN     21678/apache2
    tcp        0      0 *:ssmtp                 *:*                     LISTEN     29903/master
    tcp        0      0 *:auth                  *:*                     LISTEN     11791/inetd
    tcp        0   1816 mail.cuimat.net:ssh     d030202.adsl.hanse:1554 ESTABLISHED28321/sshd: channap
    
    
    I followed the howto again on a fresh System at home. The machine works fine, i imported the vservers mail database. I'm using it as a backup mx at the monent, so i dont lose any mail. So if you want to make so compairisons just tell me. I compared the system to my vserver, but i didn't find any differences except of the passwords.

    thanks
     
    Last edited: Jan 23, 2008
  8. falko

    falko Super Moderator ISPConfig Developer

    I think the problem is that amavisd and Psotfix are listening on mail.cuimat.net instead of localhost...
    What's in /etc/hosts?
     
  9. HerrHorst

    HerrHorst New Member

    Hey,

    my etc/hosts
    Code:
    h1276728:/# cat /etc/hosts
    127.0.0.1 mail.cuimat.net mail h1276728.stratoserver.net h1276728 localhost localhost.localdomain
    
    # The following lines are desirable for IPv6 capable hosts
    # (added automatically by netbase upgrade)
    
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    
    I compaired that to my home mailserver and it got the following /etc/hosts/
    Code:
    cuimat-mail2:~# cat /etc/hosts
    127.0.0.1       localhost
    127.0.1.1       cuimat-mail2.dyndns.org cuimat-mail2
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    
    After i changed my vserver netstat looks right but its still not working
    Code:
    h1276728:/home/channappel# cat /etc/hosts
    127.0.0.1 localhost
    127.0.1.1 mail.cuimat.net mail h1276728.stratoserver.net h1276728
    
    # The following lines are desirable for IPv6 capable hosts
    # (added automatically by netbase upgrade)
    
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    
    here the new netstat -tap
    Code:
    h1276728:/home/channappel# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 mail.cuimat.net:domain  *:*                     LISTEN     5654/named
    tcp        0      0 localhost:domain        *:*                     LISTEN     5654/named
    tcp        0      0 *:ssh                   *:*                     LISTEN     6093/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN     6059/master
    tcp        0      0 localhost:953           *:*                     LISTEN     5654/named
    tcp        0      0 mail.cuimat.net:https   *:*                     LISTEN     7217/apache2
    tcp        0      0 *:imaps                 *:*                     LISTEN     5934/couriertcpd
    tcp        0      0 *:pop3s                 *:*                     LISTEN     5953/couriertcpd
    tcp        0      0 localhost:10024         *:*                     LISTEN     5693/amavisd (maste
    tcp        0      0 localhost:10025         *:*                     LISTEN     6059/master
    tcp        0      0 localhost:mysql         *:*                     LISTEN     5755/mysqld
    tcp        0      0 *:pop3                  *:*                     LISTEN     5939/couriertcpd
    tcp        0      0 *:finger                *:*                     LISTEN     5982/inetd
    tcp        0      0 *:imap2                 *:*                     LISTEN     5922/couriertcpd
    tcp        0      0 *:www                   *:*                     LISTEN     7217/apache2
    tcp        0      0 *:ssmtp                 *:*                     LISTEN     6059/master
    tcp        0      0 *:auth                  *:*                     LISTEN     5982/inetd
    tcp        0      0 mail.cuimat.net:ssh     pool-68-163-175-1:57886 TIME_WAIT  -
    tcp        0      0 mail.cuimat.net:ssh     pool-68-163-175-1:57689 TIME_WAIT  -
    tcp        0   2076 mail.cuimat.net:ssh     d030202.adsl.hanse:1438 ESTABLISHED7550/sshd: channapp
    tcp       21      0 mail.cuimat.net:smtp    d030202.adsl.hanse:1440 ESTABLISHED-
    tcp        0      0 mail.cuimat.net:ssh     pool-68-163-175-1:57985 TIME_WAIT  -
    tcp        0      0 mail.cuimat.net:ssh     pool-68-163-175-1:57012 TIME_WAIT  -
    tcp        0    704 mail.cuimat.net:ssh     pool-68-163-175-1:58290 ESTABLISHED7827/sshd: [accepte
    
    i'm still getting the same logs :(
     
  10. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ifconfig
    ?
     
  11. HerrHorst

    HerrHorst New Member

    Code:
    ifconfig
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:20 errors:0 dropped:0 overruns:0 frame:0
              TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:1738 (1.6 KiB)  TX bytes:1738 (1.6 KiB)
    
    venet0    Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
              inet addr:127.0.0.1  P-t-P:127.0.0.1  Bcast:0.0.0.0  Mask:255.255.255.255
              UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
              RX packets:28872 errors:0 dropped:0 overruns:0 frame:0
              TX packets:29947 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:6750339 (6.4 MiB)  TX bytes:8756533 (8.3 MiB)
    
    venet0:0  Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
              inet addr:81.169.140.243  P-t-P:81.169.140.243  Bcast:0.0.0.0  Mask:255.255.255.255
              UP BROADCAST POINTOPOINT RUNNING NOARP  MTU:1500  Metric:1
    
    Shouldn't my interfaces have a mac address? Or is that normal on a vserver?
    I'm just familiar with VMWare ESX and there every VM has got it's own MAC.
     
    Last edited: Jan 26, 2008
  12. falko

    falko Super Moderator ISPConfig Developer

    Try this in /etc/hosts:

    Code:
    127.0.0.1  localhost localhost.localdomain
    81.169.140.243 mail.cuimat.net mail h1276728.stratoserver.net h1276728
    
    
    # The following lines are desirable for IPv6 capable hosts
    # (added automatically by netbase upgrade)
    
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    It depends on the virtualization technique. I'm not sure which one Strato is using...
     
  13. HerrHorst

    HerrHorst New Member

    i changed my hosts, but the issue is still there.

    Netstat -tap
    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 mail.cuimat.net:domain  *:*                     LISTEN     13978/named
    tcp        0      0 localhost:domain        *:*                     LISTEN     13978/named
    tcp        0      0 *:ssh                   *:*                     LISTEN     15444/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN     16242/master
    tcp        0      0 localhost:953           *:*                     LISTEN     13978/named
    tcp        0      0 mail.cuimat.net:https   *:*                     LISTEN     16292/apache2
    tcp        0      0 *:imaps                 *:*                     LISTEN     14264/couriertcpd
    tcp        0      0 *:pop3s                 *:*                     LISTEN     14283/couriertcpd
    tcp        0      0 localhost:10024         *:*                     LISTEN     14017/amavisd (mast
    tcp        0      0 localhost:10025         *:*                     LISTEN     16242/master
    tcp        0      0 localhost:mysql         *:*                     LISTEN     14079/mysqld
    tcp        0      0 *:pop3                  *:*                     LISTEN     14269/couriertcpd
    tcp        0      0 *:finger                *:*                     LISTEN     14308/inetd
    tcp        0      0 *:imap2                 *:*                     LISTEN     14247/couriertcpd
    tcp        0      0 *:www                   *:*                     LISTEN     16292/apache2
    tcp        0      0 *:ssmtp                 *:*                     LISTEN     16242/master
    tcp        0      0 *:auth                  *:*                     LISTEN     14308/inetd
    tcp       21      0 mail.cuimat.net:smtp    c226212.adsl.h:ms-sql-m ESTABLISHED-
    tcp        0      0 mail.cuimat.net:imap2   c226212.adsl.hanse:1432 ESTABLISHED17597/couriertls
    
    I've deleted the two comments in my master.cf which where after amavis and 127.0.0.1:10024, because since today i had a log entry about amavis and that it couldnt read the cfg. But SMTP still doesnt work. The internal mailtraffic from the root user and system messages works.
     
  14. falko

    falko Super Moderator ISPConfig Developer

    What are the errors in your mail log now?
     
  15. HerrHorst

    HerrHorst New Member

    Hi

    Still the same. Mail.log
    Code:
    Feb 12 19:41:33 h1276728 postfix/master[3620]: daemon started -- version 2.3.8, configuration /etc/postfix
    Feb 12 19:43:48 h1276728 postfix/master[3620]: warning: process /usr/lib/postfix/smtpd pid 5127 killed by signal 11
    Feb 12 19:43:48 h1276728 postfix/master[3620]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
    
    The otherlogs show nothing new.
     
  16. HerrHorst

    HerrHorst New Member

    I solved the problem with reinstalling the whole postfix service.
    I think there went something wrong with the quota patch after an aptitude upgrade. So i didn't apply the quota patch this time.

    Thread can be closed.
     
  17. falko

    falko Super Moderator ISPConfig Developer

    Yes, if you upgrade Postfix, the quota patch is lost, unless you compile it back in.
     

Share This Page