SMTP Server Offline

Discussion in 'Installation/Configuration' started by zenny, Sep 7, 2011.

  1. zenny

    zenny Member

    [SOLVED]: SMTP Server Offline

    I have updated Centos 5.6 (updated with some perl-Compress-Raw-Bzip2 and perl-Compress-Raw-Zlib errors, but solved by downgrading and upgrading as stated and reinstalled all dependencies including amavisd-new and spamassasin and all other 5 dependencies). I still have ISPConfig

    It was a running ISPConfig server but went amok after CentOS update. with the SMTP Server always offline. So far, I tried:

    1) /etc/init.d/postfix restart
    (gives not error, but dies after a few seconds)

    2) The last 20 lines of maillog (tail -n 20 /var/log/maillog) shows this line repeatedly:

    Sep 7 09:56:35 server1 amavis[6165]: (!)Net::Server: 2011/09/07-09:56:35 Couldn't open lock file "/var/amavis/amavisd.lock"[Permission denied]\n at line 203 in file /usr/lib/perl5/vendor_perl/5.8.8/Net/Server/

    3) I checked with postfix -d | grep mynetworks which results:

    mynetworks = PUBLIC_IP_1/30 PUBLIC_IP_2/32
    mynetworks_style = subnet
    parent_domain_matches_subdomains = debug_peer_list,fast_flush_domains,mynetworks,permit_mx_backup_networks,qmqpd_authorized_clients,relay_domains,smtpd_access_maps
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks
    smtpd_client_event_limit_exceptions = ${smtpd_client_connection_limit_exceptions:$mynetworks}
    smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination

    4) I cheked with 'postfix -n | grep mynetworks' which results:

    mynetworks = [::1]/128
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/, reject_unauth_destination

    Could not figure out where did I go wrong? Thanks in advance for any inputs.

    Last edited: Sep 8, 2011
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Download the ispconfig 3 tar.gz and run the update.php script. Choose to reconfigure services during update.

    Such problems are commoin when you update Centos as YUM destroys the existing configuration during update. For that reason you should consider to use Debian in case that you install a new server in future as the Debian.
  3. zenny

    zenny Member


    But strange thing is that when I ran 'amavisd debug' command and it started working on it's own without reconfiguring anything.

    Thanks Till, do I need just to update or just update to is enough using script?
    Last edited: Sep 7, 2011
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    If you have not updated to yet, then its enough to run the script.
  5. zenny

    zenny Member

    update script halts

    Hi Till;

    Just wanted to inform you that halts in CentOS5.6 as follows:

    Just for your info.

    Update: This is because I changed my mysql root password. There were two options to solve it:
    1) Either I make changes in /usr/local/ispconfig/server/mysqlclient_db.conf and append the new password; But still configs the /usr/local/ispconfig/interface/ folder needed to be changed either.

    2) Therefore, I took an easy way: I changed the mysql root password to the old one.

    And the installation got completed with the following:

    Yet, the smtp server seems offline eventhough ISPConfig3 panel shows all servers are running alright :-(
    Last edited: Sep 8, 2011
  6. zenny

    zenny Member

    smtp error

    I am getting these errors at /var/log/maillog, when I connect to webmail and try to send an email:

  7. zenny

    zenny Member

    Last edited: Sep 8, 2011

Share This Page