smtp sasl authentification failure, no explanation

Discussion in 'Installation/Configuration' started by wck, Mar 24, 2013.

  1. wck

    wck New Member

    [Solved] smtp sasl authentication failure, no explanation


    Running ISPconfig 3 on Ubuntu Server 12.04 LTS (Perfect server guide Howto)
    ISPconfig is up to date and I allowed it to reconfigure services.

    I cannot send emails through my server. After trying to connect via Gmail, the logs show :

    Mar 24 13:14:07 servername postfix/submission/smtpd[16901]: connect from[]
    Mar 24 13:14:07 servername dovecot: auth-worker: mysql(localhost): Connected to database dbispconfig
    Mar 24 13:14:09 servername postfix/submission/smtpd[16901]: warning:[]: SASL PLAIN authentication failed: 
    Mar 24 13:14:09 servername postfix/submission/smtpd[16901]: disconnect from[]
    After a lot of Googling I see there is generally an explanation after "authentification failed: " but here, there is none.

    Something else I've tried to check saslauthd :

    testsaslauthd -u [email protected] -p password -s smtp
    0: NO "authentication failed"
    Any help would be greatly appreciated.
    Last edited: Mar 24, 2013
  2. wck

    wck New Member

    Well... problem solved.

    Most tutorials about this problem mention smtpd.conf (which didn't exist on my server...) but the authentication code is actually in /etc/dovecot/dovecot-sql.conf

    In this file, the SQL query has an extra "AND disable%Ls = 'n'" compared to what's usually in smtpd.conf and I realized `disablesmtp` was set to 'y' for the account I was trying to use (in dbispconfig.mail_user).

    So, two solutions :
    - manually set `disablesmtp` to 'n'
    - check "enable receiving" in the settings for this email mailbox (although I'm using it purely to send email, not receiving).

    testsaslauthd still tells me "authentication failed"... but eh, it works.
    Last edited: Mar 24, 2013

Share This Page