SMTP SASL authentication

Discussion in 'Server Operation' started by carlos1014, Nov 29, 2011.

  1. carlos1014

    carlos1014 New Member


    I followed the tutorial for Postfix on Ubuntu 11.10 as well as the workaround for the no mechanism found bug. Everything was working fine, and then...
    "New packages found... updating..." Apparently, SASL updated to the version that has the problem. Okay, so I followed the downgrade steps again, but now in my mail.log I simply see:

     warning: unknown[]: SASL LOGIN authentication failed: authentication failure
    Courier authenticates fine. I thought it might have been a firewall issue, so I temporarily disabled it. No luck... Anyone have any thoughts?
    Last edited: Nov 29, 2011
  2. carlos1014

    carlos1014 New Member


    Okay, don't know what happened, but it's working fine now. I don't know what fixed it:

    1. Verified /etc/default/saslauthd matched tutorial
    2. restarted saslauthd and postfix
    3. Rebooted machine after no resolution
    4. Still unable to login after reboot
    5. Edited /etc/postfix/ to "smtp inet - n - - smtp -v" to disable Postfix chroot and get a verbose log
    6. restarted saslauthd and postfix
    7. Stuff started working...
    8. Changed /etc/postfix/ back to original settings (smtp n - - - - smtp) and restarted services

    Everything is working fine... Mystery... if anyone can shed some light on this, I'd greatly appreciate it.
  3. DaleHutch

    DaleHutch Member

    I had the same problem.

    Just followed Falko's instructions on bring the version back down and I'm back in business.

    Need to get this corrected. Going to be a pain keeping the server up to date.
  4. Trunkles

    Trunkles Member

    Still didn't work

    I did a complete clean install of 11.10 earlier today.

    Lo and behold, mail sending not working. :(

    I did the workaround and that didn't work, so tried editing smtpd.conf to this...

    pwcheck_method: saslauthd
    mech_list: plain login pam
    allow_plaintext: true
    auxprop_plugin: sql
    sql_engine: mysql
    sql_user: root
    sql_passwd: <Not gonna tell ya>
    sql_database: database
    sql_select: select password from mail_user where login = '%u'
    Restarted postfix and saslauthd and nope. still can't send. :(

    The client is set to use a normal password and STARTTLS. Is that correct?


Share This Page