SMTP SASL Auth Erro

Discussion in 'Installation/Configuration' started by barney.parker, Aug 14, 2007.

  1. barney.parker

    barney.parker New Member

    Hi,

    I have tried to follow the Postfix / Courier / MySQL installation howto, and although i can recieve emails via my new server, i do not seem to be able to send!!!

    I have tried to follow the instructions as closely as i could, making the alteration for my IP and DNS info, but i still can't send any emails!

    in the /var/log/mail.log file i get...

    Code:
    Aug 14 15:02:15 starfleet pop3d-ssl: Connection, ip=[::ffff:81.133.139.108]
    Aug 14 15:02:17 starfleet pop3d-ssl: LOGIN, user=barney@theparkerwilmottproject.co.uk, ip=[::ffff:81.133.139.108]
    Aug 14 15:02:23 starfleet postfix/smtpd[4799]: warning: 81.133.139.108: hostname host81 verification failed: No address associated with hostname
    Aug 14 15:02:23 starfleet postfix/smtpd[4799]: connect from unknown[81.133.139.108]
    Aug 14 15:02:24 starfleet postfix/smtpd[4799]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Aug 14 15:02:24 starfleet postfix/smtpd[4799]: warning: unknown[81.133.139.108]: SASL LOGIN authentication failed: generic failure
    Aug 14 15:02:25 starfleet postfix/smtpd[4799]: warning: SASL authentication failure: cannot connect to saslauthd server: No such file or directory
    Aug 14 15:02:25 starfleet postfix/smtpd[4799]: warning: unknown[81.133.139.108]: SASL LOGIN authentication failed: generic failure
    Aug 14 15:02:25 starfleet postfix/smtpd[4799]: disconnect from unknown[81.133.139.108]
    Aug 14 15:02:26 starfleet pop3d-ssl: LOGOUT, user=barney@theparkerwilmottproject.co.uk, ip=[::ffff:81.133.139.108], top=0, retr=0, rcvd=18, sent=177, time=9
    can anyone shed any light on this?

    Thanks in advance for any ideas anyone may have!
     
  2. falko

    falko Super Moderator

    Do you get any errors when you restart saslauthd?
    What's in /etc/default/saslauthd?
     
  3. barney.parker

    barney.parker New Member

    Falko,

    Thanks for your reply, When i stop and start SASLAUTHD i get nothing, so i assume thats telling me there is no error as such.

    /etc/default/saslauthd contains the following settings

    Code:
    START=yes
    PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"
    PIDFILE="/var/spool/postfix/var/run/${NAME}/saslauthd.pid"
    MECHANISMS="pam"
    MECH_OPTIONS=""
    THREADS=5
    OPTIONS="-c"
    Intersetingly there is absolutely no problem when i receive mails, so authorisation does work to some degree.

    I am using POP3 to connect to the server. Although IMAP is available i am not currently using it.


    EDIT:
    as an interesting side note, i tried logging in to the SMTP server via telnet. This allowed me to send emails to anywhere!

    EDIT2:

    If i remove authentication in my mail client, i appear to be able to send mails, but i get a message telling me that the message had an invalid message recipient.

    When i check /var/log/mail.log again i get

    Code:
    Aug 16 11:22:11 starfleet pop3d-ssl: Connection, ip=[::ffff:81.133.139.108]
    Aug 16 11:22:12 starfleet pop3d-ssl: LOGIN, user=barney@theparkerwilmottproject.co.uk, ip=[::ffff:81.133.139.108]
    Aug 16 11:22:14 starfleet postfix/smtpd[21647]: connect from host81-133-139-108.in-addr.btopenworld.com[81.133.139.108]
    Aug 16 11:22:16 starfleet postfix/smtpd[21647]: NOQUEUE: reject: RCPT from host81-133-139-108.in-addr.btopenworld.com[81.133.139.108]: 554 5.7.1 <Sean_Bowle$
    Aug 16 11:22:16 starfleet postfix/smtpd[21647]: disconnect from host81-133-139-108.in-addr.btopenworld.com[81.133.139.108]
    Aug 16 11:22:22 starfleet pop3d-ssl: LOGOUT, user=barney@theparkerwilmottproject.co.uk, ip=[::ffff:81.133.139.108], top=3291, retr=39100, rcvd=92, sent=4389$


    Now i guess this is happening because you don't want unauthorised users (i.e. spammers) to be using the server as a mail relay, but on the other hand the log does say i had authenticated via pop3, so now i'm confused as to the exact process of whats happening here!!!


    I am also getting log messages in mail.info stating...

    Code:
    Aug 16 09:00:09 starfleet postfix/proxymap[4865]: warning: connect to mysql server 127.0.0.1: Access denied for user 'mail_admin'@'localhost' (using password: YES)
    Aug 16 09:00:09 starfleet postfix/proxymap[4865]: warning: connect to mysql server 127.0.0.1: Access denied for user 'mail_admin'@'localhost' (using password: YES)
    They always come in pairs, and always from postfix/proxymap

    i guess this could mean i have a password entered incorrectly somewhere, but i can't seem to find it.

    Also, i can log in to MySql as mail_admin, but not as mail_admin@localhost. Does that matter?
     
    Last edited: Aug 16, 2007
  4. barney.parker

    barney.parker New Member

    Done It!!!!

    Falko,

    I searched the forum and found the answer!!!

    In the HowTo it seems to miss a single line (maybe not everyone needs it....)

    in /etc/default/saslauthd i had the line

    Code:
    OPTIONS="-c"
    It should in fact read

    Code:
    OPTIONS="-c -m  /var/spool/postfix/var/run/saslauthd -r"
    To be honest i an mot sure why, but i am still learning!!!!!

    I restarted saslauthd (stop then start) with no error messages.

    All seems to work perfectly now!!!!

    Thanks for your help.
     

Share This Page