smtp relay authentication issue

Discussion in 'ISPConfig 3 Priority Support' started by jpcyrenne, Jan 6, 2016.

  1. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Good Day,

    Running ISPConfig 3.0.5.4p8 on CentOS6.7

    When I configure 'Server Config / host / Relayhost' with SendGrid, I can't send emails anymore. (the SendGrid account is good and works on another ISPConfig server with same configs).

    Jan 5 22:47:26 host postfix/smtpd[23474]: connect from MTRLPQ4613W-LP140-04-1242524457.dsl.bell.ca[74.15.107.41]
    Jan 5 22:47:26 host postfix/smtpd[23474]: B4736244BEF: client=MTRLPQ4613W-LP140-04-1242524457.dsl.bell.ca[74.15.107.41], sasl_method=PLAIN, sasl_username=[email protected]
    Jan 5 22:47:26 host postfix/cleanup[23479]: B4736244BEF: message-id=<[email protected]>
    Jan 5 22:47:26 host postfix/qmgr[23445]: B4736244BEF: from=<[email protected]>, size=1537, nrcpt=1 (queue active)
    Jan 5 22:47:27 host postfix/smtpd[23483]: connect from unknown[127.0.0.1]
    Jan 5 22:47:27 host postfix/smtpd[23483]: 1AEBF244C51: client=unknown[127.0.0.1]
    Jan 5 22:47:27 host postfix/cleanup[23479]: 1AEBF244C51: message-id=<[email protected]>
    Jan 5 22:47:27 host postfix/qmgr[23445]: 1AEBF244C51: from=<[email protected]>, size=1991, nrcpt=1 (queue active)
    Jan 5 22:47:27 host amavis[22639]: (22639-01) Passed CLEAN {RelayedOpenRelay}, [74.15.107.41]:60880 [74.15.107.41] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]>, mail_id: YTsZ7ZZpELo8, Hits: -0.999, size: 1535, queued_as: 1AEBF244C51, 342 ms
    Jan 5 22:47:27 host postfix/smtp[23480]: B4736244BEF: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.42, delays=0.07/0.01/0/0.34, dsn=2.0.0, status=sent (250 2.0.0 from MTA(smtp:[127.0.0.1]:10025): 250 2.0.0 Ok: queued as 1AEBF244C51)
    Jan 5 22:47:27 host postfix/qmgr[23445]: B4736244BEF: removed
    Jan 5 22:47:27 host postfix/smtp[23484]: certificate verification failed for smtp.sendgrid.net[108.168.190.108]:25: untrusted issuer /C=US/O=The Go Daddy Group, Inc./OU=Go Daddy Class 2 Certification Authority
    Jan 5 22:47:27 host postfix/smtp[23484]: warning: SASL authentication failure: No worthy mechs found
    Jan 5 22:47:27 host postfix/smtp[23484]: 1AEBF244C51: SASL authentication failed; cannot authenticate to server smtp.sendgrid.net[108.168.190.108]: no mechanism available
    Jan 5 22:47:27 host postfix/smtp[23484]: certificate verification failed for smtp.sendgrid.net[158.85.10.138]:25: untrusted issuer /C=US/O=The Go Daddy Group, Inc./OU=Go Daddy Class 2 Certification Authority
    Jan 5 22:47:27 host postfix/smtp[23484]: warning: SASL authentication failure: No worthy mechs found
    Jan 5 22:47:27 host postfix/smtp[23484]: 1AEBF244C51: to=<[email protected]>, relay=smtp.sendgrid.net[158.85.10.138]:25, delay=0.54, delays=0.01/0.01/0.52/0, dsn=4.7.0, status=deferred (SASL authentication failed; cannot authenticate to server smtp.sendgrid.net[158.85.10.138]: no mechanism available)

    SASL files are there /etc/postfix :
    -rw------- 1 root root 44 Jan 5 22:18 sasl_passwd
    -rw------- 1 root root 12288 Jan 5 22:18 sasl_passwd.db

    Thank You,

    JP
     
    Last edited: Jan 6, 2016
  2. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    FYI
    Google searches seem to say error msg usually shows up because theres no required sasl2 modules installed
    Package cyrus-sasl-2.1.23-15.el6_6.2.x86_64 already installed and latest version
    Also
    Package cyrus-sasl-lib-2.1.23-15.el6_6.2.x86_64 already installed and latest version

    tried main.cf:
    smtp_sasl_security_options = noanonymous
    with no success

    Solved with:
    yum install cyrus-sasl-plain
    service postfix restart
     
  3. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    Did you configure sasl?
    smtpd_sasl_path = smtpd in your main.cf
    Check also the settings for smtpd_tls_CApath, smtp_tls_CApath, smtpd_tls_CAfile, and smtp_tls_CAfile

    If you fixed your problem on another server: why donĀ“t you just copy-over the configs?
     
  4. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Thank you / Merci, Florian30 for your response. Installing the cyrus-sasl-plain on CentOS6.7 did it for me.
    I compared many things in the main.cf file with the one working and didn't nitoce any difference? Maybe the install fixed a path? Not an expert on SASL ? It works fine now.

    JP
     

Share This Page