smtp refusing localhost connection

Discussion in 'Installation/Configuration' started by korbynn, Apr 27, 2010.

  1. korbynn

    korbynn Member

    Does anyone know why the mail server is now rejecting all connects from localhost.

    My website extensively use the php mail() function.

    Mail is being rejected since I updated.

    Any thoughts please?

    line from the mail error log:

    Apr 27 17:40:41 ns0 postfix/smtp[16452]: 246F27349EB: to=, relay=none, delay=0.07, delays=0.06/0/0/0, dsn=4.4.1, status=deferred (connect to 127.0.0.1[127.0.0.1]: Connection refused)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ?
     
  3. korbynn

    korbynn Member

    Last edited: Apr 30, 2010
  4. korbynn

    korbynn Member

    found possible fix
     
    Last edited: Apr 30, 2010
  5. korbynn

    korbynn Member

    I am now getting:

    amavis[11808]: (11808-01-12) (!!)WARN: all primary virus scanners failed, considering backups

    Any thoughts?
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Clamav daemon is not running. Please start clamd.
     
  7. korbynn

    korbynn Member

    mail() does not work to localhost

    Fixing the error with postfix and amavisd allowed clamd to properly start.

    Mail is now coming in and the backlog of mail is being processed.

    Now mail() does not work to localhost.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    What exactly did you change in postfix?
     
  9. korbynn

    korbynn Member

    if you look at this link:
    http://www.howtoforge.com/forums/showthread.php?t=34455&page=3
    and go to post 22,
    I changed in main.cf of postfix:
    maildrop unix - n n - - pipe
    flags=R user=vmail argv=/usr/bin/maildrop -d ${recipient} ${extension} ${recipient} ${user} ${nexthop} ${sender}
    to:
    maildrop unix - n n - - pipe
    flags=R user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}

    Also I ran as-update (an error in /var/log/maillog postfix startup suggested that I run it)

    Once run then the error disappeared and the server started processing the back logged mail.

    This is good but I cannot seem to mail() to localhost. This is the next problem that I need to resolve.

    This appears to be the message that is sitting in the /var/spool/mail for the domain. Does anyone know why this is messed up?

    From MAILER-DAEMON Fri Apr 30 23:22:07 2010
    Return-Path: <>
    X-Original-To: [email protected]
    Delivered-To: [email protected]
    Received: by ns0.korbynn.net (Postfix)
    id B474D734153; Fri, 30 Apr 2010 23:22:07 -0700 (PDT)
    Date: Fri, 30 Apr 2010 23:22:07 -0700 (PDT)
    From: [email protected] (Mail Delivery System)
    Subject: Undelivered Mail Returned to Sender
    To: [email protected]
    Auto-Submitted: auto-replied
    MIME-Version: 1.0
    Content-Type: multipart/report; report-type=delivery-status;
    boundary="9BAFC734150.1272694927/ns0.korbynn.net"
    Content-Transfer-Encoding: 7bit
    Message-Id: <[email protected]>

    This is a MIME-encapsulated message.

    --9BAFC734150.1272694927/ns0.korbynn.net
    Content-Description: Notification
    Content-Type: text/plain; charset=us-ascii

    I can mail() to external emails but not on localhost.
     

Share This Page