smtp problem

Discussion in 'Installation/Configuration' started by lolo, Dec 31, 2020.

  1. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Ensure the inet_socket_port line has a dollar sign ($inet_socket_port); other than that, perhaps it's the wrong path - what's in /etc/amavis/conf.d/50-user ?
     
  3. lolo

    lolo Member

    Last edited: Jan 7, 2021
  4. lolo

    lolo Member

    Before I had not this line $inet_socket_port, Ii add it and no result, put in a comment
     
  5. lolo

    lolo Member

    I have this message it can help

    Code:
    This is the mail system at host nsxxxxx.ip-94-23-7.eu.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to postmaster.
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                       The mail system
    
    <[email protected]>: connect to 127.0.0.1[127.0.0.1]:10026: Connection
        refused
    
    
    Reporting-MTA: dns; ns320556.ip-94-23-7.eu
    X-Postfix-Queue-ID: 283E74C013D0
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Sat,  2 Jan 2021 09:01:44 +0000 (UTC)
    
    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822;[email protected]
    Action: failed
    Status: 4.4.1
    Diagnostic-Code: X-Postfix; connect to 127.0.0.1[127.0.0.1]:10026: Connection
        refused
    
    
    test.eml
    Sujet :
    test
    De :
    Infos Figure SHop <[email protected]>
    Date :
    02/01/2021 à 10:01
    Pour :
    Loïc Richard <[email protected]>
    
    test
    <<<<<<<<<<
    
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    That just says nothing is listening on port 10026, which is the issue you're working in troubleshooting.
     
  7. lolo

    lolo Member

    Ok, could help me to resolve that, how to open the port 10026 ? Do you know the command to do ?
    Tk;
     
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    On localhost the firewall is not between the user and server. To open port, you start an application that offers a service using that port.
     
  9. lolo

    lolo Member

    If I do that is it correct

    sudo ufw allow 10026
    sudo ufw enable
     
  10. lolo

    lolo Member

    I change the idea
    I update /etc/postfix/master.cf and insert this.

    Is it correct ? need to do more ?

    Code:
    127.0.0.1:10026 inet n - n - - smtpd
            -o content_filter=
            -o local_recipient_maps=
            -o relay_recipient_maps=
            -o smtpd_restriction_classes=
            -o smtpd_client_restrictions=
            -o smtpd_helo_restrictions=
            -o smtpd_sender_restrictions=
            -o smtpd_recipient_restrictions=permit_mynetworks,reject
            -o smtpd_end_of_data_restrictions=
            -o mynetworks=127.0.0.0/8
            -o strict_rfc821_envelopes=yes
            -o receive_override_options=no_unknown_recipient_checks,no_header_body_>
            -o smtp_send_xforward_command=yes
                -o milter_default_action=accept
            -o milter_macro_daemon_name=ORIGINATING
            -o disable_dns_lookups=yes
    
    
    Now I can see 10026
    Code:
    sudo netstat -tulpn | grep LISTEN
    tcp        0      0 0.0.0.0:993             0.0.0.0:*               LISTEN      25658/dovecot       
    tcp        0      0 0.0.0.0:995             0.0.0.0:*               LISTEN      25658/dovecot       
    tcp        0      0 127.0.0.1:10023         0.0.0.0:*               LISTEN      1223/postgrey --pid 
    tcp        0      0 127.0.0.1:10024         0.0.0.0:*               LISTEN      25636/amavisd-new ( 
    tcp        0      0 127.0.0.1:10025         0.0.0.0:*               LISTEN      474442/master       
    tcp        1      0 127.0.0.1:10026         0.0.0.0:*               LISTEN      474442/master       
    tcp        0      0 127.0.0.1:10027         0.0.0.0:*               LISTEN      474442/master       
    tcp        0      0 0.0.0.0:587             0.0.0.0:*               LISTEN      474442/master       
    tcp        0      0 127.0.0.1:11211         0.0.0.0:*               LISTEN      739/memcached       
    tcp        0      0 0.0.0.0:110             0.0.0.0:*               LISTEN      25658/dovecot       
    tcp        0      0 0.0.0.0:143             0.0.0.0:*               LISTEN      25658/dovecot       
    tcp        0      0 0.0.0.0:465             0.0.0.0:*               LISTEN      474442/master       
    tcp        0      0 94.23.7.166:53          0.0.0.0:*               LISTEN      25841/named         
    tcp        0      0 127.0.0.1:53            0.0.0.0:*               LISTEN      25841/named         
    tcp        0      0 0.0.0.0:21              0.0.0.0:*               LISTEN      25833/pure-ftpd (SE 
    tcp        0      0 127.0.0.53:53           0.0.0.0:*               LISTEN      701/systemd-resolve 
    tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      869/sshd: /usr/sbin 
    tcp        0      0 0.0.0.0:25              0.0.0.0:*               LISTEN      474442/master       
    tcp        0      0 127.0.0.1:953           0.0.0.0:*               LISTEN      25841/named         
    tcp6       0      0 :::443                  :::*                    LISTEN      25675/apache2       
    tcp6       0      0 :::993                  :::*                    LISTEN      25658/dovecot       
    tcp6       0      0 :::995                  :::*                    LISTEN      25658/dovecot       
    tcp6       0      0 ::1:10024               :::*                    LISTEN      25636/amavisd-new ( 
    tcp6       0      0 :::3306                 :::*                    LISTEN      24957/mysqld        
    tcp6       0      0 :::587                  :::*                    LISTEN      474442/master       
    tcp6       0      0 :::110                  :::*                    LISTEN      25658/dovecot       
    tcp6       0      0 :::143                  :::*                    LISTEN      25658/dovecot       
    tcp6       0      0 :::8080                 :::*                    LISTEN      25675/apache2       
    tcp6       0      0 :::80                   :::*                    LISTEN      25675/apache2       
    tcp6       0      0 :::465                  :::*                    LISTEN      474442/master       
    tcp6       0      0 :::8081                 :::*                    LISTEN      25675/apache2       
    tcp6       0      0 fe80::225:90ff:fe22::53 :::*                    LISTEN      25841/named         
    tcp6       0      0 2001:41d0:2:8a6::1:53   :::*                    LISTEN      25841/named         
    tcp6       0      0 ::1:53                  :::*                    LISTEN      25841/named         
    tcp6       0      0 :::21                   :::*                    LISTEN      25833/pure-ftpd (SE 
    tcp6       0      0 :::22                   :::*                    LISTEN      869/sshd: /usr/sbin 
    tcp6       0      0 :::25                   :::*                    LISTEN      474442/master       
    tcp6       0      0 ::1:953                 :::*                    LISTEN      25841/named         
    
    
     
  11. lolo

    lolo Member

    But I do not receive the email again between 2 domain on my server or on yahoo or gmail. Grrrrr
     
    Last edited: Jan 8, 2021
  12. lolo

    lolo Member

    Now the message I receive is quite different

    Code:
    This is the mail system at host ns320556.ip-94-23-7.eu.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to postmaster.
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                       The mail system
    
    <[email protected]>: host
        gmail-smtp-in.l.google.com[2a00:1450:4013:c01::1b] said: 550-5.7.1
        [2001:41d0:2:8a6::1] Our system has detected that this message does
        550-5.7.1 not meet IPv6 sending guidelines regarding PTR records and
        550-5.7.1 authentication. Please review 550-5.7.1
        https://support.google.com/mail/?p=IPv6AuthError for more information 550
        5.7.1 . w11si2018301ejc.533 - gsmtp (in reply to end of DATA command)
    
     
  13. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Looks like emails are sent using IPv6 addresses, and you have not set PTR for IPv6.
    Does your DNS answer with IPv6 addresses? You could remove IPv6 connectivity from your host and make sure DNS does not answer with IPv6.
     
  14. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Can you share your full master.cf?

    Please don't disable IPv6, create a reverse record for it. IPv6 is the future and all should have it working on their hosts.
     
    lolo likes this.
  15. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    No, set the reverse hostname (PTR record) with your network provider.

    EDIT: I see you have removed your comments. This still stands ^
     
  16. lolo

    lolo Member

    How tocreate a reverse record ? inside DNS, witch element ?
     
  17. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    You have to do this with your network provider.
     
  18. lolo

    lolo Member

    Ok tk

    Now I receive another email long time inside my server.
    It's complicated to find the good solution. I continue to look.

    Code:
    The mail system
    
    <[email protected]>: conversation with 127.0.0.1[127.0.0.1] timed out
        while receiving the initial server greeting
    
    
    Reporting-MTA: dns; nsddddddd-94-23-7.eu
    X-Postfix-Queue-ID: 4ADEB4C00EE2
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Sun,  3 Jan 2021 09:59:24 +0000 (UTC)
    
    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822; [email protected]
    Action: failed
    Status: 4.4.2
    Diagnostic-Code: X-Postfix; conversation with 127.0.0.1[127.0.0.1] timed out
        while receiving the initial server greeting
    
    
    test.eml
    Sujet : 
    test
    De : 
    [email protected]
    Date : 
    03/01/2021 à 10:59
    Pour : 
    [email protected]
    
    test 
    
     
  19. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Don't open 10026 in your firewall. Amavis binds to the localhost address, and all localhost connections are allowed by default.
     
  20. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    No that's not correct, now you have postfix listening on 10026, which means once you figure out your problem with amavis not trying to listen on 10026, it won't be able to anyways, because the port is now in use.
     

Share This Page