SMTP PROBLEM

Discussion in 'Installation/Configuration' started by avistar, Mar 6, 2019.

  1. avistar

    avistar New Member

    Hello,
    Im new here, and new using ispconfig,
    I have problem, i installed server with ISPconfig 3 (roundcube included) FROM OVH, i installed php7,let's encrypt cert, set domain and dns zone, and last thing i need i need to connect from my outlook client to domain - i need smtp addres and port number . Can u tell me how can i Get it?

    (i tried my server domain.. nothing) - roundcube are working!
    Thanks
    Dawid
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What do you mean by
    Setting up Outlook to connect to mail server, you enter mail server address, like hostname.domain.tld. The port to connect to depends on protocol used. If you choose IMAP Outlook knows which port to use.
    Do you have dovecot installed? Is it running? What shows
    Code:
    systemctl --state=failed
    Did you wait enough hours after setting up name service? What shows
    Code:
    host domain.tld
    when you enter your domain and tld?
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Using the default ports that outlook shows you should be ok, so try to just set the mail server to your server hostname.
     
  4. avistar

    avistar New Member

    [email protected]***4*1:~# host domain.tld
    domain.tld has address 54.**.***.21
    domain.tld mail is handled by 10 mail.domain.tld

    [email protected]***4*1:~# systemctl --state=failed
    0 loaded units listed. Pass --all to see loaded but inactive units, too.
    To show all installed unit files use 'systemctl list-unit-files'.
     
    Last edited: Mar 8, 2019
  5. avistar

    avistar New Member

    Hi,
    When im trying add my [email protected] domain. tld to gmail it's all OK
    i need to configure wordpress plugin using smtp server, when im writing all same like in gmail:
    "Could not connect to the SMTP host."
    mail. domain .tld port: 587
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Is that mail.domain.tld found in DNS?
    Code:
    host mail.domain.tld
    ping -c 3 mail.domain.tld
    Run those commands on the host where you have that Wordpress.
     
  7. avistar

    avistar New Member

    mail.domain.tld has address 54.36.173.**
    [email protected]**:~# ping -c 3 mail.domain.tld
    PING mail.domain.tld (54.36.173.**) 56(84) bytes of data.
    64 bytes from ns31004**.ip-54-36-***.tld (54.36.173.**): icmp_seq=1 ttl=64 time=0.047 ms
    64 bytes from ns3100461.ip-54-36-***.eu (54.36.173.**): icmp_seq=2 ttl=64 time=0.033 ms
    64 bytes from ns3100461.ip-54-36-***.eu (54.36.173.**): icmp_seq=3 ttl=64 time=0.031 ms
     
  8. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Is that last part of address the same in both host and ping?
    Do you know what operating system you have on that host? Does
    Code:
    lsb_release -a
    show useful info?
    Since I do not know what Operating System is used, this may not work but try something similar applicable to your operating system:
    Code:
    tail -f /var/log/mail.log
    
    Keep that running in terminal window, and try connection from your mail client to your server. What happens?
    And please, use CODE tags when pasting logs and listings.
     
  9. avistar

    avistar New Member

    Description: Debian GNU/Linux 9.8 (stretch)
    Release: 9

    and i tried to "send test email, using smtp server mail.domain.tld


    Mar 8 16:39:00 ns3100461 postfix/submission/smtpd[23072]: connect from ns3100461.ip-54-36-173.tld[54.36.173.21]
    Mar 8 16:39:00 ns3100461 postfix/submission/smtpd[23072]: SSL_accept error from ns3100461.ip-54-36-173.eu[54.36.173.21]: -1
    Mar 8 16:39:00 ns3100461 postfix/submission/smtpd[23072]: warning: TLS library problem: error:14094418:SSL routines:ssl3_read_bytes:tlsv1 alert unknown ca:../ssl/record/rec_layer_s3.c:1407:SSL alert number 48:
    Mar 8 16:39:00 ns3100461 postfix/submission/smtpd[23072]: lost connection after STARTTLS from ns3100461.ip-54-36-173.eu[54.36.173.21]
    Mar 8 16:39:00 ns3100461 postfix/submission/smtpd[23072]: disconnect from ns3100461.ip-54-36-173.eu[54.36.173.21] ehlo=1 starttls=0/1 commands=1/2
    Mar 8 16:39:15 ns3100461 dovecot: imap-login: Login: user=<[email protected] AAAAAAAB>
    Mar 8 16:39:15 ns3100461 dovecot: imap([email protected]): Logged out in=133 out=2520
     
  10. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Is that working now?
    What is the problem now?
     
  11. avistar

    avistar New Member

    gmail is working, but problem is when im trying connect stmp in plugin from wordpress (previously in old hosting it works) it's not working.. cuz can't connect using smtp server
     
  12. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    How are you doing this? What plugin? And why, since sending e-mails from Wordpress just works in an ISPConfig system installed following the Perfect Server Guide.
     
  13. avistar

    avistar New Member

    OK, sorry for my english, once again...

    I had to buy dedicated server for my website. I bought it in OVH and installed ISPCconfig3 based on email. Since begginning i got webmaill (roundcube) installed.

    I Added my Domain (DNS SERVER) and added (A post -> mail.specki.pl to my ip address). I added e-mail domain & created e-mail account. I can log in using roundcube (webmail) send emails, get emails everything is OK. Problem starts when i want to connect my SMTP WORDPRESS Plugin (WP Mail SMTP by WPForms) ( i need it because my website is selling access so they have to get e-mails w/o spam folder).

    So im writing:
    SMTP Host (mail.specki.pl)
    Encryption: TLS
    SMTP PORT: 587
    And Authentication (user/password), and it is not working! (
    Could not connect to the SMTP host. )

    BUT.. When i want to connect this domain to my gmail account, gmail is connecting w/o any problem and i can send emails using my domain without any problem (same configuration mail.specki.pl, port: 587 same authentication data and TLS).

    So can u help me?
     
  14. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Have you tried removing that plugin from Wordpress and sending e-mails? This should work.
    If using that plugin, try writing localhost to that SMTP Host.
     
  15. avistar

    avistar New Member

    Well, when i turn off plugin and trying resend email (woocommerce) nothing happend, when im set "localhost as smtp server and no ssl/tsl:
    Code:
    This is the mail system at host ns3100461.ip-54-36-173.eu.
    
    I'm sorry to have to inform you that your message could not
    be delivered to one or more recipients. It's attached below.
    
    For further assistance, please send mail to postmaster.
    
    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.
    
                       The mail system
    
    <@[email protected]$#@gmail.com>: host mail.specki.pl[54.36.173.21] said: 554 5.7.1
        <ns3100461.ip-54-36-173.eu[54.36.173.21]>: Client host rejected: Access
        denied (in reply to RCPT TO command)
    Reporting-MTA: dns; ns3100461.ip-54-36-173.eu
    X-Postfix-Queue-ID: ED17F2200073
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Mon, 11 Mar 2019 15:44:25 +0000 (UTC)
    
    Final-Recipient: rfc822;@[email protected]$#@gmail.com
    Original-Recipient: @[email protected]$#@gmail.com
    Action: failed
    Status: 5.7.1
    Remote-MTA: dns; mail.specki.pl
    Diagnostic-Code: smtp; 554 5.7.1 <ns3100461.ip-54-36-173.eu[54.36.173.21]>:
        Client host rejected: Access denied
     
  16. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    It is postfix that rejects your mail. Check the configuration for postfix. Compare to the Perfect Server Guide.
    You should have shown the error messages you get right away.
     

Share This Page