SMTP Issue with UBUNTU 8.10 setup.

Discussion in 'HOWTO-Related Questions' started by Jrob, Dec 31, 2008.

  1. Jrob

    Jrob New Member

    I used this HOWTO-- Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.10). I can send mail from the server to outside address but can not recieve mail, as such it will not automatically create mailboxes for virtual users. I have made one change and that is.

    postconf -e 'mydestination = localhost, localhost.localdomain'

    As I'm trying to use a real domain that I have also listed in the mysql domains table.

    When I attempt to send mail to a address @eoinscaislean.com I receive the following output in the mail log.


    Dec 31 10:34:39 eoins01 postfix/master[10738]: daemon started -- version 2.5.5, configuration /etc/postfix


    Dec 31 10:36:01 eoins01 imapd: LOGIN, [email protected], ip=[::ffff:127.0.0.1], port=[34108], protocol=IMAP

    Dec 31 10:36:01 eoins01 imapd: LOGOUT, [email protected], ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=30, sent=238, time=0

    Dec 31 10:36:01 eoins01 imapd: LOGIN, [email protected], ip=[::ffff:127.0.0.1], port=[34109], protocol=IMAP

    Dec 31 10:36:01 eoins01 imapd: LOGOUT, [email protected], ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=249, sent=1323, time=0

    Dec 31 10:36:01 eoins01 imapd: LOGIN, [email protected], ip=[::ffff:127.0.0.1], port=[34110], protocol=IMAP

    Dec 31 10:36:01 eoins01 imapd: LOGOUT, [email protected], ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=301, sent=1015, time=0

    Dec 31 10:36:43 eoins01 postfix/smtpd[10757]: connect from localhost.localdomain[127.0.0.1]

    Dec 31 10:36:43 eoins01 postfix/smtpd[10757]: 5D96822A211: client=localhost.localdomain[127.0.0.1]

    Dec 31 10:36:43 eoins01 postfix/cleanup[10761]: 5D96822A211: message-id=<[email protected]om>

    Dec 31 10:36:43 eoins01 postfix/qmgr[10743]: 5D96822A211: from=<[email protected]>, size=819, nrcpt=1 (queue active)

    Dec 31 10:36:43 eoins01 postfix/smtpd[10757]: disconnect from localhost.localdomain[127.0.0.1]

    Dec 31 10:36:43 eoins01 imapd: LOGIN, [email protected], ip=[::ffff:127.0.0.1], port=[34116], protocol=IMAP

    Dec 31 10:36:43 eoins01 imapd: LOGOUT, [email protected], ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=681, sent=204, time=0

    Dec 31 10:36:43 eoins01 imapd: LOGIN, [email protected], ip=[::ffff:127.0.0.1], port=[34118], protocol=IMAP

    Dec 31 10:36:43 eoins01 imapd: LOGOUT, [email protected], ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=119, sent=900, time=0

    Dec 31 10:36:54 eoins01 postfix/smtpd[10773]: connect from localhost.localdomain[127.0.0.1]

    Dec 31 10:36:54 eoins01 postfix/smtpd[10773]: 3512A22A213: client=localhost.localdomain[127.0.0.1]

    Dec 31 10:36:54 eoins01 postfix/cleanup[10761]: 3512A22A213: message-id=<[email protected]om>

    Dec 31 10:36:54 eoins01 postfix/qmgr[10743]: 3512A22A213: from=<[email protected]>, size=1326, nrcpt=1 (queue active)

    Dec 31 10:36:54 eoins01 postfix/smtpd[10773]: disconnect from localhost.localdomain[127.0.0.1]

    Dec 31 10:36:54 eoins01 amavis[7006]: (07006-02) Passed CLEAN, LOCAL [127.0.0.1] [127.0.0.1] <[email protected]> -> <[email protected]>, Message-ID: <[email protected]om>, mail_id: NX5sMkSILN0s, Hits: 1.506, size: 819, queued_as: 3512A22A213, 10796 ms

    Dec 31 10:36:54 eoins01 postfix/smtp[10763]: 5D96822A211: to=<[email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=11, delays=0.06/0.01/0/11, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=07006-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 3512A22A213)

    Dec 31 10:36:54 eoins01 postfix/qmgr[10743]: 5D96822A211: removed

    Dec 31 10:36:54 eoins01 postfix/smtp[10777]: connect to mail.eoinscaislean.com[24.223.106.205]:25: Connection refused

    Dec 31 10:36:54 eoins01 postfix/smtp[10777]: 3512A22A213: to=<[email protected]>, relay=none, delay=0.18, delays=0.01/0.01/0.16/0, dsn=4.4.1, status=deferred (connect to mail.eoinscaislean.com[24.223.106.205]:25: Connection refused)

    The Domain name is eoinscaislean.com. The name of the physical box under 8.10 server edition is eoins01.eoinscaislean.com. The hostname I have used in postfix main.cf is mail.eoinscaislean.com. I have created both a mx record

    ; <<>> DiG 9.5.0-P2 <<>> mx eoinscaislean.com

    ;; global options: printcmd

    ;; Got answer:

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 54368

    ;; flags: qr; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0



    ;; QUESTION SECTION:

    ;eoinscaislean.com. IN MX



    ;; ANSWER SECTION:

    eoinscaislean.com. 6725 IN MX 0 mail.eoinscaislean.com.



    ;; Query time: 437 msec

    ;; SERVER: 192.168.209.1#53(192.168.209.1)

    ;; WHEN: Wed Dec 31 10:44:38 2008

    ;; MSG SIZE rcvd: 56


    Also have created a A record for mail.eoinscaislean.com

    ; <<>> DiG 9.5.0-P2 <<>> mail.eoinscaislean.com

    ;; global options: printcmd

    ;; Got answer:

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24225

    ;; flags: qr; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0



    ;; QUESTION SECTION:

    ;mail.eoinscaislean.com. IN A



    ;; ANSWER SECTION:

    mail.eoinscaislean.com. 6657 IN A 24.223.106.205



    ;; Query time: 72 msec

    ;; SERVER: 192.168.209.1#53(192.168.209.1)

    ;; WHEN: Wed Dec 31 10:45:57 2008

    ;; MSG SIZE rcvd: 56
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    netstat -tap
    and
    Code:
    ifconfig
    ?
     
  3. Jrob

    Jrob New Member

    [email protected]:/# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:51234 *:* LISTEN 6637/teamspeak-serv
    tcp 0 0 *:14534 *:* LISTEN 6637/teamspeak-serv
    tcp 0 0 localhost.localdo:10024 *:* LISTEN 5656/amavisd (maste
    tcp 0 0 localhost.localdo:10025 *:* LISTEN 6527/master
    tcp 0 0 localhost.localdo:mysql *:* LISTEN 5735/mysqld
    tcp 0 0 *:netbios-ssn *:* LISTEN 6580/smbd
    tcp 0 0 *:www *:* LISTEN 7025/apache2
    tcp 0 0 *:ssh *:* LISTEN 5617/sshd
    tcp 0 0 *:ipp *:* LISTEN 6429/cupsd
    tcp 0 0 *:smtp *:* LISTEN 6527/master
    tcp 0 0 *:microsoft-ds *:* LISTEN 6580/smbd



    [email protected]:/# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:14:85:11:a7:d6
    inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
    inet6 addr: fe80::214:85ff:fe11:a7d6/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:5691 errors:0 dropped:0 overruns:0 frame:0
    TX packets:7969 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1347225 (1.3 MB) TX bytes:1646117 (1.6 MB)
    Interrupt:20

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:880 errors:0 dropped:0 overruns:0 frame:0
    TX packets:880 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:71748 (71.7 KB) TX bytes:71748 (71.7 KB)
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Does your router forward port 25 to 192.168.1.101?
    Also make sure that your ISP doesn't block port 25.
     
  5. Jrob

    Jrob New Member

    Port 25 is open in the router. While my ISP is not suppose to blocking any ports on my IP. I had them double check it. Then to try and verify that I could get mail through I changed the main.cf file to test it.

    After changing mydestination in main.cf to the following


    mydestination = localhost, localhost.localdomain, eoinscaislean.com

    I am able to receive mail but only for real system users and it dumps it into the /var/mail/ directory. Excerpt form mail log of mail sent to a real system user after changing the main.cf mydestinations

    Jan 2 16:47:18 eoins01 postfix/smtpd[12408]: warning: 209.85.198.246: address not listed for hostname rv-out-0708.google.com

    Jan 2 16:47:18 eoins01 postfix/smtpd[12408]: connect from unknown[209.85.198.246]

    Jan 2 16:47:19 eoins01 postfix/smtpd[12408]: 1B61D22A210: client=unknown[209.85.198.246]

    Jan 2 16:47:19 eoins01 postfix/cleanup[12414]: 1B61D22A210: message-id=<[email protected]>

    Jan 2 16:47:19 eoins01 postfix/qmgr[11392]: 1B61D22A210: from=<[email protected]>, size=2352, nrcpt=1 (queue active)

    Jan 2 16:47:29 eoins01 postfix/smtpd[12633]: connect from localhost.localdomain[127.0.0.1]

    Jan 2 16:47:29 eoins01 postfix/smtpd[12633]: 2B9DE22A297: client=localhost.localdomain[127.0.0.1]

    Jan 2 16:47:29 eoins01 postfix/cleanup[12414]: 2B9DE22A297: message-id=<[email protected]>

    Jan 2 16:47:29 eoins01 postfix/qmgr[11392]: 2B9DE22A297: from=<[email protected]>, size=2855, nrcpt=1 (queue active)

    Jan 2 16:47:29 eoins01 postfix/smtpd[12633]: disconnect from localhost.localdomain[127.0.0.1]

    Jan 2 16:47:29 eoins01 amavis[6923]: (06923-03) Passed CLEAN, [209.85.198.246] [24.223.106.205] <[email protected]> -> <REAL SYSTEM [email protected]>, Message-ID: <[email protected]>, mail_id: q1X3mgVDtPw7, Hits: 2.884, size: 2352, queued_as: 2B9DE22A297, [email protected],[email protected], 9790 ms

    Jan 2 16:47:29 eoins01 postfix/smtp[12416]: 1B61D22A210: to=<REAL SYSTEM [email protected]>, relay=127.0.0.1[127.0.0.1]:10024, delay=10, delays=0.52/0.01/0/9.8, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=06923-03, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 2B9DE22A297)

    Jan 2 16:47:29 eoins01 postfix/qmgr[11392]: 1B61D22A210: removed

    Jan 2 16:47:29 eoins01 postfix/local[12634]: 2B9DE22A297: to=<REAL SYSTEM [email protected]>, relay=local, delay=0.09, delays=0.04/0.02/0/0.03, dsn=2.0.0, status=sent (delivered to mailbox)

    Jan 2 16:47:29 eoins01 postfix/qmgr[11392]: 2B9DE22A297: removed

    Jan 2 16:47:49 eoins01 postfix/smtpd[12408]: disconnect from unknown[209.85.198.246]


    When I tried to CC a mail to a user listed only in the mysql database it returns

    Jan 2 16:42:35 eoins01 postfix/local[11733]: E3EBE22A298: to=<[email protected]>, relay=local, delay=0.04, delays=0.02/0/0/0.02, dsn=5.1.1, status=bounced (unknown user: "fdwalkergt")

    For the virtual user. But will relay the msg to the real system user that I had in the TO: field. To the /var/mail/ directory.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    Code:
    hostname
    and
    Code:
    hostname -f
    ?

    What's in /etc/postfix/main.cf?
     
  7. Jrob

    Jrob New Member

    Code:
    [email protected]:/# hostname
    eoins01
    [email protected]:/#
    Code:
    [email protected]:/# hostname -f
    eoins01.eoinscaislean.com
    [email protected]:/# 
    Contents of /etc/hosts


    127.0.0.1 localhost.localdomain localhost
    192.168.1.101 eoins01.eoinscaislean.com eoins01
    192.168.1.101 WWW.EOINSCAISLEAN.COM
    192.168.1.101 mail.eoinscaislean.com

    # The following lines are desirable for IPv6 capable hosts
    ::1 localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

    Contents of /etc/postfix/main.cf

    # See /usr/share/postfix/main.cf.dist for a commented, more complete version


    # Debian specific: Specifying a file name will cause the first
    # line of that file to be used as the name. The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname

    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no

    # appending .domain is the MUA's job.
    append_dot_mydomain = no

    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h

    readme_directory = /usr/share/doc/postfix

    # TLS parameters
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.

    myhostname = mail.eoinscaislean.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = localhost, localhost.localdomain
    relayhost =
    mynetworks = 127.0.0.0/8
    mailbox_size_limit = 0
    recipient_delimiter = +
    inet_interfaces = all
    html_directory = /usr/share/doc/postfix/html
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /home/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    virtual_create_maildirsize = yes
    virtual_mailbox_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings


    Contents of /etc/postfix/master.cf

    #
    # Postfix master process configuration file. For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    #
    # Do not forget to execute "postfix reload" after editing this file.
    #
    # ==========================================================================
    # service type private unpriv chroot wakeup maxproc command + args
    # (yes) (yes) (yes) (never) (100)
    # ==========================================================================
    smtp inet n - - - - smtpd
    #submission inet n - - - - smtpd
    # -o smtpd_tls_security_level=encrypt
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #smtps inet n - - - - smtpd
    # -o smtpd_tls_wrappermode=yes
    # -o smtpd_sasl_auth_enable=yes
    # -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    # -o milter_macro_daemon_name=ORIGINATING
    #628 inet n - - - - qmqpd
    pickup fifo n - - 60 1 pickup
    cleanup unix n - - - 0 cleanup
    qmgr fifo n - n 300 1 qmgr
    #qmgr fifo n - - 300 1 oqmgr
    tlsmgr unix - - - 1000? 1 tlsmgr
    rewrite unix - - - - - trivial-rewrite
    bounce unix - - - - 0 bounce
    defer unix - - - - 0 bounce
    trace unix - - - - 0 bounce
    verify unix - - - - 1 verify
    flush unix n - - 1000? 0 flush
    proxymap unix - - n - - proxymap
    proxywrite unix - - n - 1 proxymap
    smtp unix - - - - - smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay unix - - - - - smtp
    -o smtp_fallback_relay=
    # -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq unix n - - - - showq
    error unix - - - - - error
    retry unix - - - - - error
    discard unix - - - - - discard
    local unix - n n - - local
    virtual unix - n n - - virtual
    lmtp unix - - - - - lmtp
    anvil unix - - - - 1 anvil
    scache unix - - - - 1 scache
    #
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    #
    # Many of the following services use the Postfix pipe(8) delivery
    # agent. See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    #
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    #
    maildrop unix - n n - - pipe
    flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
    #
    # See the Postfix UUCP_README file for configuration details.
    #
    uucp unix - n n - - pipe
    flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    #
    # Other external delivery methods.
    #
    ifmail unix - n n - - pipe
    flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp unix - n n - - pipe
    flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix - n n - 2 pipe
    flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman unix - n n - - pipe
    flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
    ${nexthop} ${user}
    amavis unix - - - - 2 smtp
    -o smtp_data_done_timeout=1200
    -o smtp_send_xforward_command=yes

    127.0.0.1:10025 inet n - - - - smtpd
    -o content_filter=
    -o local_recipient_maps=
    -o relay_recipient_maps=
    -o smtpd_restriction_classes=
    -o smtpd_client_restrictions=
    -o smtpd_helo_restrictions=
    -o smtpd_sender_restrictions=
    -o smtpd_recipient_restrictions=permit_mynetworks,reject
    -o mynetworks=127.0.0.0/8
    -o strict_rfc821_envelopes=yes
    -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
    -o smtpd_bind_address=127.0.0.1
     
  8. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/mailname?
     
  9. Jrob

    Jrob New Member

    Code:
    [email protected]:/# cat /etc/mailname
    eoins01.eoinscaislean.com
    [email protected]:/# 
    
     
  10. falko

    falko Super Moderator ISPConfig Developer

    That looks ok. Did you compare your configuration with the one from the tutorial? Maybe there's something different on your system.

    Also, I'm always using a "technical" domain for naming my servers, i.e., I don't use that domain for web sites and email. You could try that as well.
     
  11. Jrob

    Jrob New Member

    I'm going to redo this whole thing one more time. but before I do I want to try and get some clarification on a few things.
    1. My real domain is eoinscaislean.com I want to be able to send and receive mail for "VirtualUser"@eoinscaislean.com. Inorder to do this I need to add eoinscaislean.com to the mysql virtual domains table? It currently is there?

    2. This is a home server running 8.10 server that Is setting right next to me. I can name the box itself whatever would be required to work correctly. So..... hostname -f should return something besides *.eoinscaislean.com ex.... *.fdlinux.net

    3. In postfix main.cf myhostname and mydestination should also be populated by the internal domain name given to the box itself? ex *.fdlinux.net


    4.If so how would the mx record be setup? Mailserver *.fdlinux.net handles mail for domain eoinscaislean.com? Then just have the IP (A) record for eoinscaislean.com?


    Thanks
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Yes.

    Yes.

    Yes.


    Something like
    Code:
    eoinscaislean.com. MX 0 server1.fdlinux.net.
    (or however you name the server). That's all you need for emails. If you also want to host web sites, you need to create an A or CNAME record as well.
     
  13. Jrob

    Jrob New Member


    This is where I am thinking my problem lies. I am not running bind. Im setting up mx record at zoneedit, as at one time before I changed providers I could not run a web server on the standard port of 80 and I was using Zoneedit to redirect it. I'm not exactly sure how to translate eoinscaislean.com. MX 0 server1.fdlinux.net. into the form that comes up when setting up a MX record at ZoneEdit.

    Would I be better off to setup bind inorder to correctly do this. At present my /etc/resolv.conf contains info form my ISP.

    Code:
    search rcom-ne.com
    nameserver 192.168.209.1
    nameserver 10.0.1.2
    And if I try to run a traceroute on on eoinscaislean.com from the server it returns
    Code:
    Hop	Hostname	IP	                  Time 1	                                Time 2
    1	eoins01.eoinscaislean.com	  192.168.1.101                  	0.646ms	
    1	192.168.1.1	                  192.168.1.1	                        3.225m
    1	192.168.1.1	                  192.168.1.1	                        1.068ms	
    2	192.168.209.1	                  192.168.209.1	                        908.102ms	
    3	10.14.0.1	                          10.14.0.1	                                 11.051ms	
    4	24-223-106-205.static.rcom-ne.com	24.223.106.205	         56.234ms
    
    I have created A records at ZoneEdit for
    eoinscaislean.com
    www.eoinscaislean.com
    ts.eoinscaislean.com
    eoins01.eoinscaislean.com

    and 1 mx record that states

    eoins01.eoinscaislean.com is the fisrt mail server for eoinscaislean.com

    Im wondering if the reason this is not working is because of broken DNS. Although if I add eoincaislean.com to the end of the mydestination line in the main.cf It will receive mail for acutal system users only, from either internal or external mail accounts, but dumps it into the /var/mail
     
  14. falko

    falko Super Moderator ISPConfig Developer

    That looks ok. In your new setup you'd replace eoins01.eoinscaislean.com in the MX record with server1.fdlinux.net.
     

Share This Page