Smtp greeting not received only from gmail

Discussion in 'Server Operation' started by jonk, Feb 7, 2013.

  1. jonk

    jonk New Member

    I have postfix running on Ubuntu 12.04 and mails are sent without issues but from past few days have issues only while sending mail to gmail mail servers

    telnet 25
    Connected to
    Escape character is '^]'.
    It just hangs there and connection closed by foreign host.

    But do not have any issues sending to yahoo, hotmail etc

    IP address is not listed in any of the blacklists.

    Pls help.
  2. fr0stsp1re

    fr0stsp1re New Member

    Not all SMTP servers will respond with a banner after you telnet into them. It is waiting for you to issue a command and the server is timing out waiting for it. At least that is what it seems like. Issue a HELO or EHLO command and see what happens.
  3. jonk

    jonk New Member

    Tried it. No luck.
  4. fr0stsp1re

    fr0stsp1re New Member

    Did you try 465 as well? Try some of the other ports. Is it possible your ISP is filtering port 25?

    I just tried telnet on that host you posted and it works fine for me.

    Last login: Fri Feb 8 11:31:10 on console
    Frosts-Mac-Pro:~ fr0stspire$ telnet
    telnet> open
    (to) 25
    Connected to
    Escape character is '^]'.
    220 ESMTP f9si43998037paw.256 - gsmtp
    EHLO [email protected] at your service, []
    250-SIZE 35882577

    If you have a firewall switch it off just for testing purposes. Try using telnet from a different host on your network. Seems like the issue is confined to your end. If you are on a DHCP assigned IP for your internet router, see if you can pick up a new ip by going to your mac address clone in your router, pick "use this mac address option" take any two or more numbers or letters and change them. hit save. Power cycle your router and you shall now have a new IP. Test again.

    FYI if you are on a DHCP assigned IP on the host you are testing from, you will automatically be blacklisted since DHCP assigned blocks are almost always on blacklists by default. And you cannot be removed from a blacklisted IP block as your ISP is the one who put it there to begin with in most cases. They are trying to stop spam from all angles these days.

Share This Page