SMTP Authentication Failure

Discussion in 'Server Operation' started by macmage2, Jan 21, 2011.

  1. macmage2

    macmage2 New Member

    I can't get SMTP authentication to work on my server. No matter what I try I get a password failure error message. Below are my main.cf and saslauthd config files. Any help would be greatly appreciated!

    main.cf
    Code:
    # See /usr/share/postfix/main.cf.dist for a commented, more complete version
    
    
    # Debian specific:  Specifying a file name will cause the first
    # line of that file to be used as the name.  The Debian default
    # is /etc/mailname.
    #myorigin = /etc/mailname
    
    smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
    biff = no
    
    # appending .domain is the MUA's job.
    append_dot_mydomain = no
    
    # Uncomment the next line to generate "delayed mail" warnings
    #delay_warning_time = 4h
    
    readme_directory = no
    
    # TLS parameters
    smtpd_tls_cert_file = /etc/ssl/certs/smtpd.crt
    smtpd_tls_key_file = /etc/ssl/private/smtpd.key
    smtpd_use_tls = yes
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    
    # See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
    # information on enabling SSL in the smtp client.
    
    mydomain = maccrafters.com
    myhostname = maccrafters.com
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    myorigin = /etc/mailname
    mydestination = maccrafters.com, localhost.com, fellowshipbook.org, localhost,charsysonline.com,buckeyeinfusion.org,toonalution.com
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
    mailbox_size_limit = 0
    recipient_delimiter = +
    smtpd_sasl_auth_enable = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_sasl_local_domain = 
    home_mailbox = mail/
    virtual_alias_maps = hash:/etc/postfix/virtual
    smtpd_tls_security_level = may
    broken_sasl_auth_clients = yes
    message_size_limit = 100240000
    saslauthd
    Code:
    # This needs to be uncommented before saslauthd will be run automatically
    START=yes
    
    PWDIR="/var/spool/postfix/var/run/saslauthd"
    PARAMS="-m ${PWDIR}"
    PIDFILE="${PWDIR}/saslauthd.pid"
    
    # You must specify the authentication mechanisms you wish to use.
    # This defaults to "pam" for PAM support, but may also include
    # "shadow" or "sasldb", like this:
    # MECHANISMS="pam shadow"
    
    MECHANISMS="pam"
    
    # Other options (default: -c)
    # See the saslauthd man page for information about these options.
    #
    # Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
    # Note: See /usr/share/doc/sasl2-bin/README.Debian
    #OPTIONS="-c"
    
    #make sure you set the options here otherwise it ignores params above and will not work
    OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd"
    
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Which distribution do you use? Any errors in your mail log?
     
  3. macmage2

    macmage2 New Member

    I am using Ubuntu 10.10. This is what I get after attempting to send mail:
    warning: SASL authentication failure: Password verification failed
    SASL PLAIN authentication failed: authentication failure
    lost connection after AUTH
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Which tutorial (URL) did you use to set up the server?
     

Share This Page