SMTP authentication failed

Discussion in 'HOWTO-Related Questions' started by hazelnut, May 26, 2014.

  1. hazelnut

    hazelnut New Member

    [solved] SMTP authentication failed

    Hello,

    i have installed the email server from this tut and i can't send emails because the authentication failed.

    The mail.info log says:

    Code:
    May 26 13:42:45 servernameimapd: LOGIN, user=xxx@example.com, ip=[::ffff:XX.XXX.XXX.XXX], port=[42455], protocol=IMAP
    May 26 13:42:46 servername imapd: DISCONNECTED, user=xxx@example.com, ip=[::ffff:XX.XXX.XXX.XXX], headers=0, body=0, rcvd=13, sent=111, time=1, starttls=1
    May 26 13:42:46 servernameimapd: LOGIN, user=xxx@example.com, ip=[::ffff:XX.XXX.XXX.XXX], port=[36789], protocol=IMAP
    May 26 13:43:13 servername postfix/smtpd[1424]: connect from sign-4db6add6.pool.mediaWays.net[XX.XXX.XXX.XXX]
    May 26 13:43:14 servername postfix/smtpd[1424]: setting up TLS connection from sign-4db6add6.pool.mediaWays.net[XX.XXX.XXX.XXX]
    May 26 13:43:14 servername postfix/smtpd[1424]: Anonymous TLS connection established from sign-4db6add6.pool.mediaWays.net[XX.XXX.XXX.XXX]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
    May 26 13:43:14 servername postfix/smtpd[1424]: warning: SASL authentication failure: Password verification failed
    May 26 13:43:14 servername postfix/smtpd[1424]: warning: sign-4db6add6.pool.mediaWays.net[XX.XXX.XXX.XXX]: SASL PLAIN authentication failed: authentication failure
    May 26 13:50:45 servername postfix/anvil[1417]: statistics: max connection rate 1/60s for (smtp:XX.XXX.XXX.XXX) at May 26 13:40:44
    May 26 13:50:45 servername postfix/anvil[1417]: statistics: max connection count 1 for (smtp:XX.XXX.XXX.XXX) at May 26 13:40:44
    May 26 13:50:45 servername postfix/anvil[1417]: statistics: max cache size 1 at May 26 13:40:44
    
    Shall i post the output of saslfinger -e?
     
    Last edited: May 27, 2014
  2. srijan

    srijan New Member HowtoForge Supporter

    Hi

    Please post your localhost telnet

     
  3. hazelnut

    hazelnut New Member

    Hi,

    i've got it in the last evening. :) Thread can be closed.
     
  4. srijan

    srijan New Member HowtoForge Supporter

    how did you resolved the issue?
     
  5. hazelnut

    hazelnut New Member

    i have installed it like the tutorial once again and it works now.
     
  6. kkimmell

    kkimmell New Member

    Similar problem

    Well I followed the same tutorial but the ubuntu version and am having a similar issue in that I can't send SMTP via the server from a desktop client. Pulling IMAP is no problem.

    Here is the output of my telnet session:

    Code:
    root@alerts:~# telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    220 mail.MYHOSTNAME.net ESMTP KlipschMail (Build 1749.1c)
    ehlo localhost
    250-mail.MYHOSTNAME.net
    250-PIPELINING
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-STARTTLS
    250-AUTH PLAIN LOGIN
    250-AUTH=PLAIN LOGIN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    quit
    221 2.0.0 Bye
    Connection closed by foreign host.
    
    Any ideas?

    Thanks,
    K

    p.s. Will add that sending and receiving via SquirrelMail is A-OKAY!
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of:

    netstat -tap

    and

    iptables -L
     
  8. kkimmell

    kkimmell New Member

    Code:
    root@alerts:~# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 localhost:10024         *:*                     LISTEN      966/amavisd (master
    tcp        0      0 localhost:10025         *:*                     LISTEN      2154/master
    tcp        0      0 localhost:mysql         *:*                     LISTEN      917/mysqld
    tcp        0      0 *:http                  *:*                     LISTEN      13652/apache2
    tcp        0      0 *:ssh                   *:*                     LISTEN      714/sshd
    tcp        0      0 *:smtp                  *:*                     LISTEN      2154/master
    tcp        0      0 *:https                 *:*                     LISTEN      13652/apache2
    tcp        0      0 *:12321                 *:*                     LISTEN      2282/perl
    tcp        0      0 alerts.MY_HOSTNAME:http c-50-142-120-28.h:52237 ESTABLISHED 13764/apache2
    tcp        0      0 alerts.MY_HOSTNAME:http 173-85-121-82.dr0:51689 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http cpe-76-181-73-57.:63020 FIN_WAIT2   -
    tcp        0      0 alerts.MY_HOSTNAME:http 46-120-234-196.st:53385 ESTABLISHED 13761/apache2
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49851 TIME_WAIT   -
    tcp        0      0 localhost:56091         localhost:https         TIME_WAIT   -
    tcp        0      0 localhost:56093         localhost:https         TIME_WAIT   -
    tcp        0      0 localhost:57242         localhost:mysql         TIME_WAIT   -
    tcp        0      0 localhost:56090         localhost:https         TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49826 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49845 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49840 TIME_WAIT   -
    tcp        0      0 localhost:56099         localhost:https         TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 173-85-121-82.dr0:51691 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http h134-215-208-30.p:49542 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49816 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49807 TIME_WAIT   -
    tcp        0    683 alerts.MY_HOSTNAME:http 46-120-234-196.st:53382 ESTABLISHED 14124/apache2
    tcp        0      1 alerts.MY_HOSTNAME:http host-92-3-139-92.:11822 LAST_ACK    -
    tcp        0      0 alerts.MY_HOSTNAME:http 205-156-36-62.ssm:25146 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 173-85-121-82.dr0:51680 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49838 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49820 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 199.19.70.71:26102      TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49824 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 107-132-173-103.l:51272 TIME_WAIT   -
    tcp        0      0 localhost:57225         localhost:mysql         TIME_WAIT   -
    tcp        0      0 localhost:56096         localhost:https         TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 205-156-36-62.ssmc:9559 FIN_WAIT2   -
    tcp        0      0 alerts.MY_HOSTNAME:http static-50-53-6-17:49622 ESTABLISHED 13652/apache2
    tcp        0      0 localhost:56092         localhost:https         TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:ssh 12.202.82.2:39682       ESTABLISHED 13807/0
    tcp        0      0 alerts.MY_HOSTNAME:http 107-132-173-103.l:51270 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 205-156-36-62.ssmc:9561 FIN_WAIT2   -
    tcp        0      0 localhost:56094         localhost:https         TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 205-156-36-62.ssmc:9560 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http h134-215-208-30.p:51580 ESTABLISHED 14132/apache2
    tcp        0      0 localhost:56098         localhost:https         TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 205-156-36-62.ssm:20381 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49833 TIME_WAIT   -
    tcp        0      0 localhost:57235         localhost:mysql         TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 199.19.70.71:25987      TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 173-85-121-82.dr0:51684 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49801 TIME_WAIT   -
    tcp        0      0 localhost:56097         localhost:https         TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 173-85-121-82.dr0:51683 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http c-174-52-160-229.:65035 ESTABLISHED 14060/apache2
    tcp        0      0 alerts.MY_HOSTNAME:http 173-85-121-82.dr0:51690 TIME_WAIT   -
    tcp        0      1 alerts.MY_HOSTNAME:http host-92-3-139-92.:11820 LAST_ACK    -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49853 ESTABLISHED -
    tcp        0      0 alerts.MY_HOSTNAME:http 46-120-234-196.st:53383 TIME_WAIT   -
    tcp        0      0 localhost:57227         localhost:mysql         TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 205-156-36-62.ssm:35296 FIN_WAIT2   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49847 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49831 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 205-156-36-62.ssm:14977 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49805 TIME_WAIT   -
    tcp        0      0 localhost:57224         localhost:mysql         TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49811 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49849 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49836 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49809 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 173-85-121-82.dr0:51692 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 205-156-36-62.ssm:51222 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49803 TIME_WAIT   -
    tcp        0      0 localhost:57226         localhost:mysql         TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49842 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 205-156-36-62.ssm:14978 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 46-120-234-196.st:53384 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 50-32-109-233.adr:60564 ESTABLISHED 14114/apache2
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49822 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 173-85-121-82.dr0:51693 TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49818 TIME_WAIT   -
    tcp        0      0 localhost:57234         localhost:mysql         TIME_WAIT   -
    tcp        0      0 alerts.MY_HOSTNAME:http 67-198-75-169.dyn:49813 TIME_WAIT   -
    tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      2018/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      1968/couriertcpd
    tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      714/sshd
    tcp6       0      0 [::]:smtp               [::]:*                  LISTEN      2154/master
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      1996/couriertcpd
    tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      2046/couriertcpd
    tcp6       0      0 alerts.MYHOSTNAME:imaps cpe-74-141-53-25.:65456 ESTABLISHED 31526/couriertls
    tcp6       0      0 alerts.MYHOSTNAME:imaps cpe-74-141-53-25.:65431 ESTABLISHED 31343/couriertls
    tcp6       0      0 alerts.MYHOSTNAME:imaps 12.202.82.2%31364:56890 ESTABLISHED 13242/couriertls
    tcp6       0      0 alerts.MYHOSTNAME:imaps 12.202.82.2%31364:25487 ESTABLISHED 14089/couriertls
    tcp6       0      0 alerts.MYHOSTNAME:imaps 12.202.82.2%31364:13964 ESTABLISHED 13074/couriertls
    tcp6       0      0 alerts.MYHOSTNAME:imaps 12.202.82.2%31364:16386 ESTABLISHED 13079/couriertls
    iptables is wide open.

    Thanks,
    K
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats ok. Did you enable smtp authentication in your mail client? Which errors do you get in the mail.log?
     
  10. kkimmell

    kkimmell New Member

    I have tried just about every iteration I can come up with in Thunderbird's settings. Is there any way within the config files that I can check to know what the server is expecting as the SMTP auth method?

    I'm confused as to which of the puzzle pieces actually hanldes client SMTP sending but was assuming that it's postfix. I didn't stray from this setup (http://www.howtoforge.com/virtual-u...urier-mysql-and-squirrelmail-ubuntu-12.04-lts) other than I left the quota patch off.

    What should the default SMTP send setting be?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The default thunderbird settings should work. But you sould check the userame again, thunderbird has a bug which strips away the domain part from the username. the crrect username for smtp and imap is the full email address.
     
  12. kkimmell

    kkimmell New Member

    Yeah... I caught that on setup... some samples from the log:

    Code:
    Jun 25 14:49:20 alerts postfix/smtpd[13255]: warning: unknown[12.202.82.2]: SASL PLAIN authentication failed: authentication failure
    Jun 25 14:49:20 alerts postfix/smtpd[13255]: warning: unknown[12.202.82.2]: SASL LOGIN authentication failed: authentication failure
    Jun 25 14:49:27 alerts postfix/smtpd[13255]: warning: unknown[12.202.82.2]: SASL PLAIN authentication failed: authentication failure
    Jun 25 14:49:28 alerts postfix/smtpd[13255]: warning: unknown[12.202.82.2]: SASL LOGIN authentication failed: authentication failure
    Jun 25 14:49:29 alerts postfix/smtpd[13255]: warning: unknown[12.202.82.2]: SASL PLAIN authentication failed: authentication failure
    Jun 25 14:49:29 alerts postfix/smtpd[13255]: warning: unknown[12.202.82.2]: SASL LOGIN authentication failed: authentication failure
    
     
  13. kkimmell

    kkimmell New Member

    And Thunderchicken's message:

    "Sending of message failed.
    The message could not be sent because connecting to SMTP server post.yurplebliss.com failed. The server may be unavailable or is refusing SMTP connections. Please verify that your SMTP server settings are correct and try again, or contact the server administrator."


    This is with SMTP set as:


    SSL/TSL: port 465
    AUTH: Normal Pass
    Username: user@domain.tld
     
  14. kkimmell

    kkimmell New Member

    Further testing of telnet attempts from my client show that I can only get a response from the server on port 25.

    If I set Thunderbawk to port 25 and clear text it asks me for the password from user@domain.tld (correctly) and the same password I used to login to IMAP is giving this error:

    "Login to server MYSERVER failed."

    and the log file shows:
    Code:
    Jun 25 16:30:46 alerts postfix/smtpd[15036]: warning: SASL authentication failure: Password verification failed
    Jun 25 16:30:46 alerts postfix/smtpd[15036]: warning: unknown[12.202.82.2]: SASL PLAIN authentication failed: authentication failure
    Jun 25 16:30:46 alerts postfix/smtpd[15036]: warning: unknown[12.202.82.2]: SASL LOGIN authentication failed: authentication failure
    
     

Share This Page