SMTP Auth problems in Debian Etch w/ISPConfig

Discussion in 'Installation/Configuration' started by fish3232, Mar 25, 2007.

  1. fish3232

    fish3232 New Member

    Hi guys,

    Maybe somebody could help me out with this issue.
    I followed the Perfect setup for Debian 3.1 (sarge) for my Debian 4.0 (Etch) Install. I then proceeded to install ISPConfig. Everything works perfect except authetication through smtp. I can send emails using the webmail, but if i try to send mail through my smtp server from somewhere else, authentication fails.
    The only problem that i have seen besides the smtp is this:



    Here is the error i get when i try to authenticate smtp:
    Thank you in advance for your help,

    Jeovani
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which errors do you get in your mail log? If you want to use TLS, enable TLS in the file /etc/postfix/master.cf.
     
  3. fish3232

    fish3232 New Member

    looks like sasl is having an issue. I tried several things and nothing worked. I also tried changing the path of smtpd_sasl_domain. That didnt work. Also theres a cert issue, i dont know why i would be getting that. I followed the how to to the T. Any thoughts? Heres the output of /var/log/mail.log

     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Do you get an error when you start the saslauthd server?
     
  5. fish3232

    fish3232 New Member

    nope. No errors, and when i ps aux shows five processes of sasl running.

    here's the exerpt of my /etc/postfix/main.cf:

     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's the output of
    Code:
    ps aux|grep saslauthd
    ?
    What's in /etc/default/saslauthd and /etc/init.d/saslauthd?
     
  7. fish3232

    fish3232 New Member

    ps aux | grep saslauthd:


    /etc/default/saslauthd:

    /etc/init.d/saslauthd:
     
  8. bschultz

    bschultz Member

    So by reading this, is it safe for me to assume that I can follow the Sarge How-To for Etch? Are the packages recommended for Sarge the same as those recommended for Etch?

    I want to re-install, but don't want to put Sarge back on this machine (since it won't be supported for much longer)...but i don't want to have to wait for Etch to become "stable".

    Thanks.
     
  9. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Most packages are the same, but not all. Also some of the config files have been changed. ISPConfig works generally well on Etch, butthe perefct setup instructions are not 100% the same for etch, we will release a new howto when etch is released. If you have some linux knowledge, you should be able to use the sarge howto with etch too.
     
  10. fish3232

    fish3232 New Member

    Like i said, the only problem s i had in following the sarge how to with ispconfig is only with SMTP auth. I am still not able to authenticate. Still trying to fix this problem myslef but no luck yet. Im not very familiar with saslauthd
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You should have taken a look at the original /etc/default/saslauthd file because it has some examples in it. PARAMS has changed to OPTIONS on Etch, so please replace
    Code:
    PARAMS="-m /var/spool/postfix/var/run/saslauthd -r"
    with
    Code:
    OPTIONS="-m /var/spool/postfix/var/run/saslauthd -r -c"
    in /etc/default/saslauthd and restart saslauthd.
     
  12. fish3232

    fish3232 New Member

    That was it!

    Thank you falko.

    Everything works smoothly now. So far thats the only major difference between the Sarge and Etch installs that i have noticed.

    You are great.

    Jeovani
     

Share This Page