SMTP Auth problem

Discussion in 'General' started by maxx, Aug 1, 2005.

  1. maxx

    maxx ISPConfig Developer

    Hi again :)

    Now I have SMTP auth problem. When I try to send mail via my own mail server. And put require auth for smtp it doesn't accept my password on thunderbird it's just keep asking it again and again, and it doesnt send my mail.

    Im using Suse 9.3 and did perfect setup.

    - Maxx
     
  2. falko

    falko Super Moderator

    Did you specify a user name and a password in Thunderbird under Tools -> Account Settings -> Outgonig Server (SMTP)?

    What does your maillog say?
     
  3. maxx

    maxx ISPConfig Developer

    Yes I did specify username and password for outgoing mail SMTP.

    Here is error log:

    Aug 1 14:32:32 fusion postfix/smtpd[15791]: warning: SASL authentication failure: Password verification failed
    Aug 1 14:32:32 fusion postfix/smtpd[15791]: warning: unknown[195.197.240.40]: SASL PLAIN authentication failed
    Aug 1 14:32:32 fusion postfix/smtpd[15791]: warning: unknown[195.197.240.40]: SASL LOGIN authentication failed
     
  4. falko

    falko Super Moderator

    And you're sure you provided the right username (webxx_..., not the email address) and password?
    Is saslauthd running on your SuSE system?
     
  5. maxx

    maxx ISPConfig Developer

    Im 100% precent sure that im using name username and password for sending and receiving mail.

    saslauthd is running.

    (I tested without any username and password and did manage to send email, under same network)

    Actually there is another problem too that i found in mailog:

    Aug 1 15:24:07 fusion imapd: Failed to create cache file: maildirwatch (web1_joakim)
    Aug 1 15:24:07 fusion imapd: Error: Input/output error

    This has something to do with FAM, fam service is running btw.

    - Maxx
     
    Last edited: Aug 1, 2005
  6. falko

    falko Super Moderator

    Can you check if the user in question has entries in /etc/passwd and /etc/shadow?
     
  7. maxx

    maxx ISPConfig Developer

    Yes they appear there.
     
  8. falko

    falko Super Moderator

    Does /etc/postfix/main.cf contain lines similar to these:

    Code:
    postconf -e 'mydomain = example.com'
    postconf -e 'myhostname = server1.$mydomain'
    postconf -e 'smtpd_sasl_local_domain ='
    postconf -e 'smtpd_sasl_auth_enable = yes'
    postconf -e 'smtpd_sasl_security_options = noanonymous'
    postconf -e 'broken_sasl_auth_clients = yes'
    postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains'
    postconf -e 'inet_interfaces = all'
    postconf -e 'alias_maps = hash:/etc/aliases'
    You should have an smtpd.conf somewhere on your system (run
    Code:
    updatedb
    locate smtpd.conf
    to find out) with the following contents:
    Code:
    pwcheck_method: saslauthd
    mech_list: plain login
     
  9. maxx

    maxx ISPConfig Developer

    I installed everything again.


    SMTP auth still not working (same problem, doent accept password, keeps asking it again and again). I installed everything again and still the same problem! This is getting weird.

    And I have this problem too (from mail log):

    Aug 3 01:13:21 fusion imapd-ssl: Failed to create cache file: maildirwatch (web1_joakim)
    Aug 3 01:13:21 fusion imapd-ssl: Error: Input/output error
    Aug 3 01:13:21 fusion imapd-ssl: Check for proper operation and configuration
    Aug 3 01:13:21 fusion imapd-ssl: of the File Access Monitor daemon (famd).



    BTW: few fixes to perfect suse 9.3

    1. If you install latest updates including latest kernel right after you have installed SuSe you have to do restart to your computer otherwise you get error while making quota at command quotaon -avug (something like kernel not supporting)

    2. Installing Proftpd do "make clean" and then "make install". Otherwise you could get errors. (time hasling)
     
  10. Kronos

    Kronos New Member

    Hi,

    I had a smiliar problem after following Falko's (excellent) guide. Got it to work after changing the auth method in /etc/sysconfig/saslauthd:

    SASLAUTHD_AUTHMECH = shadow

    (this was set to PAM before)

    Since the change everything works perfectly. You can verify your user/pass with 'testsaslauthd -u user -p passwd'
    I think this should also work with PAM, but then you have to provide an appropriate conf in /etc/pam.d for smtp (PAM ist the Suse standard for authentication)

    Good luck!
     
    Last edited: Aug 6, 2005
  11. maxx

    maxx ISPConfig Developer

    Thanks

    Now my smtp auth is working and I can send email thru my server. Special thanks to you sir!

    - Maxx
     
  12. Bedevere

    Bedevere New Member

    I was having similar but odd problems with postfix related to this. I am using SuSE 9.2 and followed the perfect setup instructions. I would get my mail when I opened the client and the web interface worked fine. But if I would hit send/recieve in my client I would get errors.

    My mail log shows the exact same errors as yours, but chainging from pam to shadow did not work for me.


    I noticed FAM was not loaded so I:

    chckconfig --add fam
    /etc/init.d/fam start
    /etc/init.d/postfix restart

    and viola no more errors!
     
  13. nitefox

    nitefox New Member

    Adding

    pwcheck_method: saslauthd

    to smtpd.conf solved problem for me. Thanks for the tip.
     

Share This Page