SMTP 465 not working, forced to use 25

Discussion in 'Server Operation' started by Heeter, Jun 18, 2014.

  1. Heeter

    Heeter Member

    Hi all,

    I have LAMP with postfix running smoothly. I did notice that upon configuring my Thunderbird on my Debian dektop, and K9 on my Android device, that I can configure port 993 for incoming, but it refuses to connect to port 465 for outgoing. I am being forced to use 25. Where can I look to get port 465 configured properly for my IMAPS setups?

    My router has ports 465 & 25 currently opened and pointed to my email server.

    Thanks

    Heeter
     
  2. srijan

    srijan New Member HowtoForge Supporter

    I think if your router have these ports open then you can use them for successful email server.
     
  3. Heeter

    Heeter Member

    Thanks Srijan

    I can email in/out out of the squirrelmail, no problem there.

    My problem is that I cannot configure port465 on my Thunderbird or my android K9 app.

    I can configure port 993 for incoming on my thunderbird and K9.

    But I cannot configure outgoing 465, only port 25.

    Thanks

    Heeter
     
  4. Heeter

    Heeter Member

    Well Update;

    Looks like my ISP is blocking those ports (465 & 587). I opened them in my router, but scanning those ports still show them as closed.

    Port 25 is open, but since I am using a DNS redirector, my dynamic IP is being blacklisted on a couple of spamhouse services.

    So I guess my next question is: Can I setup nonstandard ports for smtp so that my devices can still SSL/TLS with my server? Do I need an SMTP relayer for my server to email out without being blacklisted?

    Thanks

    Heeter
     
  5. srijan

    srijan New Member HowtoForge Supporter

    Yes generally ISP's uses to open the port 25 for all customers as this port in general used worldwide for the email communication.

    Yes you can.

    Yes, the best thing you can do.
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Check if the ports are enabled locally on the server, run:

    netstat -tap | grep smtp

    and

    netstat -tap | grep imap

    Then you better use a external relay server.

    Nonstandard ports would mean that you can not receive any emails as no external server would know the port numbers. I guess thats not what you want?
     
  7. Heeter

    Heeter Member

    This is what I am getting:

    Code:
    [email protected]:/home/adminpc# netstat -tap | grep smtp
    tcp        0      0 *:smtp                  *:*                     LISTEN      27547/master    
    [email protected]:/home/adminpc# netstat -tap | grep imap
    tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      2367/couriertcpd
    tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      2337/couriertcpd
    tcp6       0      0 mail.heldercarrei:imaps router.asus.com:52197   ESTABLISHED 29495/couriertls
    tcp6       0      0 mail.heldercarrei:imaps router.asus.com:53645   ESTABLISHED 29496/couriertls
    tcp6       0      0 mail.heldercarrei:imaps router.asus.com:43317   ESTABLISHED 29574/couriertls
    tcp6       0      0 mail.heldercarrei:imaps 174.90.223.234:34654    ESTABLISHED 28951/couriertls
    tcp6       0      0 mail.heldercarrei:imaps router.asus.com:43345   ESTABLISHED 29609/couriertls
    tcp6       0      0 mail.heldercarrei:imaps 174.90.223.234:49506    ESTABLISHED 28952/couriertls
    tcp6       0      0 mail.heldercarrei:imaps router.asus.com:43346   ESTABLISHED 29611/couriertls
    [email protected]:/home/adminpc# 
    
    I was thinking that the nonstandard ports would be the communication between my mailserver and the syncronized devices, but all the incoming/outgoing mail would go through the mailserver first before sync'ing with the devices.

    Maybe I am thinking about this all wrong......

    Is it just the /etc/mail/main.cf file that I add the smtp relayer to? Or is there other files that I have to edit?

    Thanks


    Heeter
     
    Last edited: Jun 19, 2014
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    imaps should be working. smtps is not enabled. Please edit /etc/postfix/master.cf and remove the # in front of the lines that start with "smtps" and "submission". Then restart postfix.

    If the relay server does not require a username / password, then thats all.
     
  9. Heeter

    Heeter Member

    Hi Till,

    this is my master.cf file now:
    Code:
    smtp      inet  n       -       -       -       -       smtpd
    #smtp      inet  n       -       -       -       1       postscreen
    #smtpd     pass  -       -       -       -       -       smtpd
    #dnsblog   unix  -       -       -       -       0       dnsblog
    #tlsproxy  unix  -       -       -       -       0       tlsproxy
    submission inet n       -       -       -       -       smtpd
    #  -o syslog_name=postfix/submission
    #  -o smtpd_tls_security_level=encrypt
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_reject_unlisted_recipient=no
    #  -o smtpd_client_restrictions=$mua_client_restrictions
    #  -o smtpd_helo_restrictions=$mua_helo_restrictions
    #  -o smtpd_sender_restrictions=$mua_sender_restrictions
    #  -o smtpd_recipient_restrictions=
    #  -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
    #  -o milter_macro_daemon_name=ORIGINATING
    smtps     inet  n       -       -       -       -       smtpd
    
    And this is what I am getting now:
    Code:
    [email protected]:/home/adminpc# netstat -tap | grep smtp
    tcp        0      0 *:smtp                  *:*                     LISTEN      6546/master     
    [email protected]:/home/adminpc#
    
    Is it enabled now?

    Looks like the relayer needs a user/pass.

    What would the other files be that I need to edit?

    Thank you

    Heeter
     
    Last edited: Jun 20, 2014

Share This Page