SMB1 after upgrade to DEBIAN 9

Discussion in 'Server Operation' started by muekno, Feb 23, 2020.

  1. muekno

    muekno Member HowtoForge Supporter

    Sorry to ask here but 1 hour Google research did not get a soltion
    Updated my DEBIAN 8 fileserver to DEBIAN 9, like to go to DEBIAN 9 soon. Now I have on client with as WIN7 starter (EEPC). useing SMB1 and not able to use SMB2. Is the any chance to tell DEBIAN 9, and hopefully DEBIAN 10 too, accept SMB1. On DEBIAN 8 everything worked fine
    Thanks for any help

    Rainer

    P.S: I know the security risk, but they are no problem in this enviorement.
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Has support for SMB1 been removed from Debian 9?
    If it still support SMB1, have you tested that setting
    Code:
    client min protocol = SMB1
    does not work?
     
  3. muekno

    muekno Member HowtoForge Supporter

    by google search I found <code>min protocol = SMB1</code> but smb fails to start tried <code>
    client min protocol = SMB1</code> smd fails starting too. I think I have to put it in the <code>[global]</code> section.
    Regards
    Rainer
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  5. muekno

    muekno Member HowtoForge Supporter

    No chance, found this article https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1697817 tried other options there, no chance. Thanks to VM ware I could go back to my snaptshot before the Upgrade, everything runs fine again.
    Samba says Samba version 4.2.14-Debian and funy ist shows SMB2_10 for the Win7 starter connection.
    Can not really find out what SMB version WIN 7 starter uses or supports, seeing the sambastatus it looks like a SMBv2 connection, but why does it work with jessie and not with stretch?
    Rainer
     
  6. muekno

    muekno Member HowtoForge Supporter

    To be shure I go back to stretch, Samba version 4.5.16-Debian tried again without any additional parameter no chance, no connection.
    Rainer
     
  7. Steini86

    Steini86 Active Member

    Are you sure it can't use SMBv2
    https://support.microsoft.com/en-gb...r-2008-r2,-windows-8,-and-windows-server-2012
    He should try in Powershell:
    Get-SMBServerConfiguration

    To disable SMBv1:
    Set-SMBServerConfiguration -EnableSMB1Protocol $False

    Do you get an error message / log entry?

    If you really want to use SMBv1 (bad idea), do it with:
    Code:
    min protocol = NT1
    You should carefully limit the clients that are able to connect to this server. SMBv1 is broken. https://blogs.technet.microsoft.com/filecab/2016/09/16/stop-using-smb1/
     

Share This Page