Small troubles after migrating from courier to dovecot

Discussion in 'Server Operation' started by Hirbod, Mar 19, 2014.

  1. Hirbod

    Hirbod New Member

    Dear community,

    i've killed courier and installed dovecot on my live system yesterday, running debian wheezy.

    I got trough all the steps from:


    (seems like it's the same script)

    The migration was quite easy and worked like a charme. Nonetheless that broke all the subscriptions and triggered a redownload of all the mails. Seems like the script has deleted all the uids. Maybe need to change the script to fit the official way of keeping all the file specs like described here:

    After opening the mail client the inbox started to redownload immediately but all the send files and other folders were gone. After doing some research I've found out, that I need to define a special namespace in the dovecot.conf (i've pasted this at the end of the file):

    mail_location = maildir:~/Maildir
    namespace {
    prefix = INBOX.
    separator = .
    inbox = yes
    I've changed to shell, triggered "dovecot reload" and openend "Mail" on bei MacBook. Et Voila, everything was there and started to redownload.

    After the next ISPConfig Update with "reconfigure" service, this setting will be gone and I will need to reconfigure all this type of stuff over and over again. Is there any way to make all the inboxes available without to use this snippet?

    By the way: junk mails don't be moved to "junk" anymore and beeing showed up in inbox (spamassassin still work, but my setting "moving spam to junk folder" seems not to work anymore with dovecot.

    Last edited: Mar 19, 2014
  2. Hirbod

    Hirbod New Member

    if ( /^X-Spam-Flag: YES$/ )
      exception {
        `test -e $SPAMDIRFULL`
        if ( $RETURNCODE != 0 )
          `maildirmake -f $SPAMDIR $DEFAULT`
          `chown vmail:vmail -R $SPAMDIRFULL`
          `chmod 0700 $SPAMDIRFULL`
          `echo INBOX.$SPAMDIR >> $DEFAULT/courierimapsubscribed`
        to "$SPAMDIRFULL/"
    why does ispconfig still use something like `echo INBOX.$SPAMDIR >> $DEFAULT/courierimapsubscribed`

    ? i use dovecot now?
  3. Hirbod

    Hirbod New Member

    Got it. There are 2 ways to fix this.


    Remove the IMAP Prefix e.g in Apple Mail under settings -> advanced -> imap prefix from "INBOX" to an empty input.

    create a file under /etc/docevot/conf.d/ with this content:

    namespace inbox {
      separator = /
      prefix =
      inbox = yes
    namespace compat {
      separator = .
      prefix = INBOX.
      inbox = no
      hidden = yes
      list = no
      alias_for =
    This is update safe and works fine!

Share This Page