Small Mail Query

Discussion in 'General' started by mphayesuk, Jan 9, 2007.

  1. mphayesuk

    mphayesuk Member

    I have a small mail problem, I have a custom backup script to backup all customer and ISPConfig specific data to a dvd and then I get an email with the log... over the past week I have not got this email. I have checked the log of the backup and everything works fine but there is an error in the mail log can someone take a look and see why this is happening. I have not made any changes to the system for 2 months so I am not sure what the problem is.


    server1:/var/log # vi mail
    Jan 9 00:51:14 server1 postfix/smtpd[5651]: warning: connect to private/tlsmgr: No such file or directory
    Jan 9 00:51:14 server1 postfix/smtpd[5651]: warning: problem talking to server private/tlsmgr: No such file or directory
    Jan 9 00:51:14 server1 postfix/smtpd[5651]: warning: no entropy for TLS key generation: disabling TLS support
    Jan 9 00:51:14 server1 postfix/smtpd[5653]: warning: connect to private/tlsmgr: No such file or directory
    Jan 9 00:51:14 server1 postfix/smtpd[5651]: connect from 203-73-254-77.adsl.dynamic.seed.net.tw[203.73.254.77]
    Jan 9 00:51:15 server1 postfix/smtpd[5653]: warning: connect to private/tlsmgr: No such file or directory
    Jan 9 00:51:15 server1 postfix/smtpd[5653]: warning: problem talking to server private/tlsmgr: No such file or directory
    Jan 9 00:51:15 server1 postfix/smtpd[5653]: warning: no entropy for TLS key generation: disabling TLS support
    Jan 9 00:51:15 server1 postfix/smtpd[5653]: connect from 203-73-254-77.adsl.dynamic.seed.net.tw[203.73.254.77]
    Jan 9 00:51:16 server1 postfix/smtpd[5651]: NOQUEUE: reject: RCPT from 203-73-254-77.adsl.dynamic.seed.net.tw[203.73.254.77]: 554 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=SMTP helo=<212.159.54.3>
    Jan 9 00:51:16 server1 postfix/smtpd[5651]: lost connection after RCPT from 203-73-254-77.adsl.dynamic.seed.net.tw[203.73.254.77]
    Jan 9 00:51:16 server1 postfix/smtpd[5651]: disconnect from 203-73-254-77.adsl.dynamic.seed.net.tw[203.73.254.77]
    Jan 9 00:51:16 server1 postfix/smtpd[5653]: NOQUEUE: reject: RCPT from 203-73-254-77.adsl.dynamic.seed.net.tw[203.73.254.77]: 554 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=SMTP helo=<212.159.54.4>
    Jan 9 00:51:17 server1 postfix/smtpd[5653]: lost connection after RCPT from 203-73-254-77.adsl.dynamic.seed.net.tw[203.73.254.77]
    Jan 9 00:51:17 server1 postfix/smtpd[5653]: disconnect from 203-73-254-77.adsl.dynamic.seed.net.tw[203.73.254.77]
    Jan 9 00:54:37 server1 postfix/anvil[5654]: statistics: max connection rate 2/60s for (smtp:203.73.254.77) at Jan 9 00:51:15
    Jan 9 00:54:37 server1 postfix/anvil[5654]: statistics: max connection count 2 for (smtp:203.73.254.77) at Jan 9 00:51:15
    Jan 9 00:54:37 server1 postfix/anvil[5654]: statistics: max cache size 1 at Jan 9 00:51:15
    Jan 9 04:04:07 server1 postfix/pickup[7751]: EF0CD34026F: uid=0 from=<root>
    Jan 9 04:04:08 server1 postfix/cleanup[8653]: EF0CD34026F: message-id=<[email protected]>
    Jan 9 04:04:08 server1 postfix/pickup[7751]: 0E04634026E: uid=0 from=<root>
    Jan 9 04:04:08 server1 postfix/qmgr[4541]: EF0CD34026F: from=<[email protected]>, size=5208, nrcpt=1 (queue active)
    Jan 9 04:04:08 server1 postfix/cleanup[8653]: 0E04634026E: message-id=<[email protected]>
    Jan 9 04:04:08 server1 postfix/qmgr[4541]: 0E04634026E: from=<[email protected]>, size=576, nrcpt=1 (queue active)
    Jan 9 04:04:08 server1 postfix/local[8657]: EF0CD34026F: to=<[email protected]>, relay=local, delay=1, status=bounced (unknown user: "backuplog")
    Jan 9 04:04:08 server1 postfix/local[8658]: 0E04634026E: to=<[email protected]>, orig_to=<root>, relay=local, delay=1, status=sent (delivered to mailbox)
    Jan 9 04:04:08 server1 postfix/qmgr[4541]: 0E04634026E: removed
    Jan 9 04:04:08 server1 postfix/cleanup[8655]: 43051340270: message-id=<[email protected]>
    "mail" 46L, 5631C 31,19 16%


    Thanks
     
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    As far as I can tell, you have no entropy left for your TLS manager. Google for "out of entropy" and you'll get a bunch of suggestions.

    The next problem is that the receiving mail server only seems to accept connection after authentication (over TLS), which for the above reason failed. Maybe you should add server1 to your list of trusted servers (if possible)?
     
  3. mphayesuk

    mphayesuk Member

    I think I know what the problem is, I have my main company site held at another hosting provider at the moment but what I did last week was to add the domain name into ispconfig so that I could host subdomains, and what I must have done is added the mx records in, so if I try and email out from my ispconfig server it will resolve this address internally and then find there is no email account for that domain.

    I think that is what must have happened so I will attempt to fix it and see what happens.

    Thanks
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Please set "External Mailserver" for that domain in ISPConfig.
     

Share This Page