Slow serving with FastCGI + php in Debian 64bit

Discussion in 'General' started by Norman, Feb 25, 2010.

  1. Norman

    Norman Member


    I've got a system with a 64bit install of Debian Lenny and latest ispconfig 3 .
    The problem I'm having is that when using fastcgi (php) with Ispconfig3 the site serving grinds to a halt after a while.

    I noticed this problem when configuring the server to use low keepalive for highpercormance.
    It seems fastcgi does not like this at all and causes more problems than what the keepalive usually helps with.

    Initial connection is fast (when apache is freshly started) then if you wait for a while and try to browse to other parts of the site it's very slow.

    Appearently this is due to apache gracefully shutting down processes (which fastcgi is attached to). While fastcgi can reconnect this causes a timeout and general slowdown.

    The problem is further described here:

    Has anyone found a workaround for this issue?
    I could see that this potential issue would show up for hightraffic sites even with higher keepalive values even if it might not be as apparant.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Norman

    Norman Member

    It's a bit unclear from the discussion.
    Do I edit the vhost master template in fastcgi section or do I change the fastcgi config in apache2?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You can either edit the master template or add it to the apache directives field of the website.

Share This Page