Slow POP3 with Dovecot and/or Courier

Discussion in 'Server Operation' started by makedo, Sep 6, 2006.

  1. makedo

    makedo New Member

    Hi everyone,

    I've got a problem with POP3 access on my server. The access to the mails is rather slow. I am using Outlook XP on Windows for retrieving the mails, and it seems to "pause" slightly after each email. All emails are downloaded fine, and there are no timeouts, however it takes up a lot of time.

    I have tried both Dovecot and Courier on the server. This is an issue with TLS or without TLS. I am authenticating against plain UNIX users (basically changed nothing in the configuration scripts, except the TLS cert). This is on a relatively unchanged Suse 9.3 system.

    No error or warning messages in the log.

    I am really at a loss here - what could possibly cause this problem? The server should be a lot faster than this (3 GHz, plenty of RAM, fast Internet connection).

    My previous server was less capable and worked fine, also with Outlook, same setup (also with courier, but on Debian). I just can't seem to find the relevant difference...

    Any ideas? Thanks a lot!
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Sounds like a firewall problem. What's the output of
    Code:
    iptables -L
    ? Might also be a problem with your desktop firewall, if you use one.
     
  3. makedo

    makedo New Member

    Thanks for your answer!

    iptables is set to accept anything:

    ---
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    ---

    I also do not have a desktop firewall.

    I tried using Thunderbird for a change, with the same result. I have also verified that the CLIENT seems to pause after each email, i.e. before sending the next "RCPT x" command to the POP server. (some 0.3 seconds to 1 second delay).

    I still have NO idea what's causing this...
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do you see any errors in your log files?
     
  5. makedo

    makedo New Member

    No related errors in any of the mail log files (in fact, no errors at all for pop3). /var/log/mail logs a typical session like this:

    Sep 7 11:20:20 servername pop3d: Connection, ip=[::ffff:xx.xx.xx.xx]
    Sep 7 11:20:20 servername pop3d: LOGIN, user=makedo, ip=[::ffff:xx.xx.xx.xx]
    Sep 7 11:20:24 servername pop3d: LOGOUT, user=makedo, ip=[::ffff:xx.xx.xx.xx], top=0, retr=10128, time=4

    Hm... any other ideas? :(
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Didn't you say you are using Courier? Your logs show another POP3 daemon. What's the output of
    Code:
    netstat -tap
    ?
     
  7. makedo

    makedo New Member

    Netstat coming up...:

    Code:
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 *:pop3                  *:*                     LISTEN      12369/couriertcpd
    
    The courier package is from Suse 9.3. Started with /etc/init.d/courier-pop3.
     
  8. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Ok, it's Courier then.
    What's the output of
    Code:
    ps aux
    ? What's the output of
    Code:
    updatedb
    locate courier
    ?
     
  9. makedo

    makedo New Member

    ps aux:
    Code:
    USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
    root     26128  0.0  0.0   1380   464 ?        S    Sep05   0:00 /usr/sbin/courierlogger -pid=/var/run/authdaemon.courier-imap/pid -start /usr/lib/courier-imap/authlib/authdaemond.plain
    root     26129  0.0  0.0   1728   508 ?        S    Sep05   0:00 /usr/lib/courier-imap/authlib/authdaemond.plain
    root     26130  0.0  0.0   1924   728 ?        S    Sep05   0:00 /usr/lib/courier-imap/authlib/authdaemond.plain
    root     26131  0.0  0.0   1924   728 ?        S    Sep05   0:00 /usr/lib/courier-imap/authlib/authdaemond.plain
    root     26141  0.0  0.0   1924   728 ?        S    Sep05   0:00 /usr/lib/courier-imap/authlib/authdaemond.plain
    root     26142  0.0  0.0   1924   728 ?        S    Sep05   0:00 /usr/lib/courier-imap/authlib/authdaemond.plain
    root     26177  0.0  0.0   1924   728 ?        S    Sep05   0:00 /usr/lib/courier-imap/authlib/authdaemond.plain
    root     23718  0.0  0.0   1480   520 ?        S    14:57   0:00 /usr/lib/courier-imap/couriertcpd -address=0 -stderrlogger=/usr/sbin/courierlogger -stderrloggername=pop3d -maxprocs=40 -maxperip=4 -pid=/var/run/pop3d.pid -nodnslookup -noidentlookup 110 /usr/sbin/pop3login /usr/lib/courier-imap/authlib/authdaemon /usr/sbin/pop3d Maildir
    root     23720  0.0  0.0   1252   296 ?        S    14:57   0:00 /usr/sbin/courierlogger pop3d
    
    
    locate courier

    Code:
    /etc/courier
    /etc/courier/authdaemonrc
    /etc/courier/authdaemonrc.dist
    /etc/courier/imapd
    /etc/courier/imapd-ssl
    /etc/courier/imapd-ssl.dist
    /etc/courier/imapd.cnf
    /etc/courier/imapd.dist
    /etc/courier/pop3d
    /etc/courier/pop3d-ssl
    /etc/courier/pop3d-ssl.dist
    /etc/courier/pop3d.cnf
    /etc/courier/pop3d.dist
    /etc/courier/quotawarnmsg.example
    /etc/init.d/courier-authdaemon
    /etc/init.d/courier-imap
    /etc/init.d/courier-imap-ssl
    /etc/init.d/courier-pop3
    /etc/init.d/courier-pop3-ssl
    /etc/init.d/rc3.d/K09courier-pop3-ssl
    /etc/init.d/rc3.d/K10courier-authdaemon
    /etc/init.d/rc3.d/S12courier-authdaemon
    /etc/init.d/rc3.d/S13courier-pop3-ssl
    /etc/init.d/rc5.d/K09courier-pop3-ssl
    /etc/init.d/rc5.d/K10courier-authdaemon
    /etc/init.d/rc5.d/S12courier-authdaemon
    /etc/init.d/rc5.d/S13courier-pop3-ssl
    /usr/lib/courier-imap
    /usr/lib/courier-imap/authlib
    /usr/lib/courier-imap/authlib/authdaemon
    /usr/lib/courier-imap/authlib/authdaemond
    /usr/lib/courier-imap/authlib/authdaemond.plain
    /usr/lib/courier-imap/couriertcpd
    /usr/lib/courier-imap/makedatprog
    /usr/sbin/courierlogger
    /usr/sbin/couriertls
    /usr/sbin/rccourier-authdaemon
    /usr/sbin/rccourier-imap
    /usr/sbin/rccourier-imap-ssl
    /usr/sbin/rccourier-pop3
    /usr/sbin/rccourier-pop3-ssl
    /usr/share/courier-imap
    /usr/share/courier-imap/configlist
    /usr/share/courier-imap/configlist.ldap
    /usr/share/courier-imap/makeuserdb
    /usr/share/courier-imap/mkimapdcert
    /usr/share/courier-imap/mkpop3dcert
    /usr/share/courier-imap/pop3d.pem
    /usr/share/courier-imap/pw2userdb
    /usr/share/courier-imap/sysconftool
    /usr/share/courier-imap/userdb
    /usr/share/courier-imap/vchkpw2userdb
    /usr/share/doc/packages/courier-imap
    /usr/share/doc/packages/courier-imap/AUTHORS
    /usr/share/doc/packages/courier-imap/BUGS
    /usr/share/doc/packages/courier-imap/COPYING
    /usr/share/doc/packages/courier-imap/README
    /usr/share/doc/packages/courier-imap/README.authdebug.html
    /usr/share/doc/packages/courier-imap/README.authdebug.html.in
    /usr/share/doc/packages/courier-imap/README.authmysql.html
    /usr/share/doc/packages/courier-imap/README.authmysql.myownquery
    /usr/share/doc/packages/courier-imap/README.authpostgres.html
    /usr/share/doc/packages/courier-imap/README.imap
    /usr/share/doc/packages/courier-imap/README.ldap
    /usr/share/doc/packages/courier-imap/README.maildirquota
    /usr/share/doc/packages/courier-imap/README.sharedfolders
    /usr/share/man/man1/courierlogger.1.gz
    /usr/share/man/man1/couriertcpd.1.gz
    /usr/share/man/man8/courier-imapd.8.gz
    /usr/share/munin/plugins/courier_
    /usr/share/munin/plugins/courier_mta_mailqueue
    /usr/share/munin/plugins/courier_mta_mailstats
    /usr/share/munin/plugins/courier_mta_mailvolume
    /var/adm/YaST/InstSrcManager/IS_CACHE_0x00000001/MEDIA/suse/i586/courier-imap-3.0.8-3.i586.rpm
    /var/run/authdaemon.courier-imap
    /var/run/authdaemon.courier-imap/pid
    /var/run/authdaemon.courier-imap/pid.lock
    /var/run/authdaemon.courier-imap/socket
    /var/run/couriersslcache
    
     
  10. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Did you check the settings in the configuration files in /etc/courier?
     

Share This Page