Slow plugins

Discussion in 'ISPConfig 3 Priority Support' started by Th0m, Feb 17, 2020.

  1. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    I installed a new ISPC server today, as master server. I did this according to the Perfect Server tutorial. After that, I installed the Automail plugin from @florian030 and the ISPC-Roundcube plugins to roundcube. Both the Automail and RC plugins run very slow - it takes around 30 seconds to load the autoconfig xml file of automail and when I open a settings panel of the RC plugins it will take 20-30 seconds to load the panel. My settings for all applications are the same as on a server I installed about a month ago, without any problem. I looked into the logs (syslog, mysql-slow, etc), but I can't find anything odd. Looked around the forum/internet, but I haven't found anything helpful. Anybody has an idea what this could be?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I have not used both plugins, so I can't say anything specific. In general, when a PHP script takes about 30 seconds to load, then in most cases a timeout to whatever kind of URL is involved. So if these plugins have settings for URL's, then check these. It might also be that the plugin tries to reach itself to test if its config works and this fails or a DNS resolving issue.
     
    Th0m likes this.
  3. Th0m

    Th0m ISPConfig Developer ISPConfig Developer

    It took some time to figure it out, but my provider changed the IPv6 adress and I had the old IP adress in my hosts file. I fixed that and now everything is working. Thanks Till!
     
    till likes this.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thank you for reporting back. So it was in the end a network timeout as I guessed, just a bit different cause than what I expected :)
     

Share This Page