slow connection with putty

Discussion in 'Server Operation' started by donbryan, Jun 1, 2009.

  1. donbryan

    donbryan New Member

    I have done a few different installations with debian lenny and ubuntu 8.04
    and notice one thing in common to both installions

    ssh login with putty to these systems are extremly slow, AFTER ENTERING THE USER NAME THERE IS A 15 - 20 SECONDS DELAY BEFORE THE PASSWORD PROMPT.

    I am stumped with this ,don't think it is normal.
    This is on the same network and in one specific case the same machine with
    two different harddrives but same perfect setup.
    These two harddrives works perfectly a 4GB ide and 20GB ide on a 2.6GHZ,
    2.4GHZ machine. 200GB sata, 160GB sata same machine same perfect setup Slow...

    At first i thought it had someting to do with 64 bit versions but
    32bit versions running on 3.2ghz boxes with sata drives does the same thing.

    This is getting too long .....

    Does anyone have any ideas on this
  2. edge

    edge Active Member Moderator

    Sounds like a resolve problem.

    Try to ping something from the server, and see if the response is fast/quick.
    If not, your nameserver(s) in /etc/resolv.conf are wrong.

    An other option is to make SSHD stop doing a reverse lookup.
    I've never tested this, but to do so add to the file "sshd_config" the following (at the end)
    After this restart SSHD, or your server to make it read the "sshd_config" file
    Last edited: Jun 1, 2009
  3. donbryan

    donbryan New Member

    adding UseDNS no to /etc/ssh/sshd_config takes care of that problem

    Thank you edge.

    you have saved me some trouble there


Share This Page