sll certificate

Discussion in 'Installation/Configuration' started by tellar, Jan 17, 2007.

  1. tellar

    tellar New Member

    Hi I just downloaded a trial certificate from versign, in the instructions I had to put 3 lines on text into the

    httpd.conf file

    SSLCertificateFile /usr/local/ssl/crt/public.crt
    SSLCertificateKeyFile /usr/local/ssl/private/private.key
    SSLCACertificateFile /usr/local/ssl/crt/intermediate.crt

    I did this and now i get the message

    httpd not running

    so i removed the lines but i still get the same message,

    ispconfig is running and accessable but the websites are not.

    help

    Thanks in advance

    Paul
     
  2. tellar

    tellar New Member

    got this message from the server logs

    [Wed Jan 17 17:57:26 2007] [error] Init: Unable to read server certificate from file /var/www/web5/ssl/MYSERVER.com.crt
    [Wed Jan 17 17:57:26 2007] [error] SSL Library Error: 218529960 error:0D0680A8:asn1 encoding routines:ASN1_CHECK_TLEN:wrong tag
    [Wed Jan 17 17:57:26 2007] [error] SSL Library Error: 218595386 error:0D07803A:asn1 encoding routines:ASN1_ITEM_EX_D2I:nested asn1 error
     
  3. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    You should place the certs where you tell apache you have installed them. In other words, the file names are important to match with YOUR apache install. That's more important than just following the general directives of Verisign, who just make a bunch of assumptions.

    After modification of your apache config files (/etc/apache2/apache2.conf, but more likely change it in your ISPConfig panel for the website in question), restart your web server. Something like
    Code:
    /etc/init.d/apache2 restart
    HTH
     
  4. tellar

    tellar New Member

    still not solved

    I have removed the directives the apache conf file but am still having the same problem after restart. I did install the key in ispconfig but have also removed that now but still the same problem.

    as far as i know the server is the same as it was before i changed it but its still not accessable

    any ideas?
     
  5. tellar

    tellar New Member

    apache wont start

    when i try ro reload apache no I get the message

    grep: /etc/apache2/vhosts/Vhosts_ispconfig.conf: No such file or directory

    FAIL

    help
     
  6. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    This file is created by ISPConfig when updating an entry. I'd suggest you go inside ISPConfig to a site, change e.g. the directives of a site, save, undo your change and restart. /etc/apache2/vhosts/Vhosts_ispconfig.conf will be recreated.

    Fortunately, ISPConfig comes with it's own webserver.:D
     
  7. tellar

    tellar New Member

    not yet

    so i made a change saved and made the change back tried to resrart apace and got the same error message that the file dosent exist, so i checked and there a 5 files in the directory all with a time date suffix

    Vhosts_ispconfig.conf_17-01-07_19-49-08
    Vhosts_ispconfig.conf_17-01-07_19-49-29
    Vhosts_ispconfig.conf_17-01-07_20-28-12
    Vhosts_ispconfig.conf_17-01-07_20-28-33
    Vhosts_ispconfig.conf_17-01-07_20-41-14
    Vhosts_ispconfig.conf_17-01-07_20-41-35

    apache still wont start
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

  9. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    You should have a file called Vhosts_ispconfig.conf. If it's not there, you could try to rename the latest file with a date/time extension to one without. See the link(s) till provided. Look at the error log of your main server (/var/log/apache2/error.log most likely) and fix the errors.
     

Share This Page