Slightly Confused (DNS & Server Help)

Discussion in 'Installation/Configuration' started by JohnnyBGoode, Oct 28, 2005.

  1. cortexx

    cortexx New Member

    im confused as hell too

    here is a whois on my domain

    Registry Whois
    Domain Name: ibcbrantford.com

    Status: clientTransferProhibited

    Registrar: NETWORK SOLUTIONS, LLC.
    Whois Server: whois.networksolutions.com
    Referral URL: http://www.networksolutions.com

    Expiration Date: 2009-03-12
    Creation Date: 2002-03-12
    Last Update Date: 2007-02-27

    Name Servers:
    ns1.ibcbrantford.com
    ns2.golden.net


    my question is do i duplicate the 2 name servers here in ispconfig where it asks for name servers ?

    here is my problem , after installing fedora 7 perfect server and ispconfig , i cant get my mail to work , it works on the lan ( server is behind a router and firewall , the associated ports have been opened and mapped to the servers lan ip ( 192.168.1.73 ).

    when i am at home here is the error from outlook express ...

    The host 'ibcbrantford.com' could not be found. Please verify that you have entered the server name correctly. Account: 'test', Server: 'ibcbrantford.com', Protocol: POP3, Port: 110, Secure(SSL): No, Socket Error: 11004, Error Number: 0x800CCC0D

    if i change the server address to the static ip number we use i get this

    message :-

    The connection to the server has failed. Account: 'test', Server: '209.239.7.238', Protocol: POP3, Port: 110, Secure(SSL): No, Socket Error: 10060, Error Number: 0x800CCC0E



    any help would be appreciated thanks

    another person that would be happy with " the idiots guide to dns servers and domain networking " hint hint !!!!! :D
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    For DNS records you will have to use always the external IP. When primary and secondary DNS server are on the same server, you will pnly have to create a promary dNS record and not a primary and secondary record.

    Have a look at the mail log for your email error.
     
  3. cortexx

    cortexx New Member

    so in management>settings>server>dns , i have webservice.ibcbrantford.com enetered twice , should they not be :-

    ns1.ibcbrantford.com
    ns2.golden.net

    that is the nameservers pointing to our domain from network solutions.

    Or should I edit one of the network solutions settings to point to webservice.ibcbrantford.com ?

    also , in management>settings>server , the ip of the server is 192.168.1.73 , shouldnt this be our outside ip which i think is 209.239.7.238 ?

    thanks for helping out a dumb dumb ;)
     
  4. jtheed

    jtheed Member HowtoForge Supporter

    I'm no expert, but if Network Solutions is also doing DNS for you then something is wrong because I cannot find your IP when doing an NSLOOKUP of your domain. So even if your DNS server is wrong, Network Solutions should be telling me the address.

    I tried ibcbrantford.com , mail.ibcbrantford.com & www.ibcbrantford.com

    None of them return an address.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    As far as I see, your nameservers are ns.execulink.com and ns1.ibcbrantford.com:

    Code:
    dig ns ibcbrantford.com
    
    ; <<>> DiG 9.3.4 <<>> ns ibcbrantford.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19539
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 2
    
    ;; QUESTION SECTION:
    ;ibcbrantford.com.              IN      NS
    
    ;; ANSWER SECTION:
    ibcbrantford.com.       172800  IN      NS      ns.execulink.com.
    ibcbrantford.com.       172800  IN      NS      ns1.ibcbrantford.com.
    
    ;; ADDITIONAL SECTION:
    ns1.ibcbrantford.com.   172800  IN      A       209.239.7.238
    ns.execulink.com.       172800  IN      A       199.166.6.2
    
    ;; Query time: 217 msec
    ;; SERVER: 213.191.92.84#53(213.191.92.84)
    ;; WHEN: Mon Aug 13 20:36:58 2007
    ;; MSG SIZE  rcvd: 111
    No, the IP address that you see in the output of
    Code:
    ifconfig
    is correct.
     
  6. cortexx

    cortexx New Member

    OK after some playing it seems that we can send and recieve emails internally on our new server BUT, when out of the local network (at home) we cannot authenticate to login and use the email system.

    We have it setup that we have to log into the mail server before using it with the same login and password that is associated with the mail account in outlook , so why does the server not let us do this ? ..
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Any errors in the mail log? Did you configure SASL exactly as described in the perfect setup guide?
     

Share This Page