Slightly Confused (DNS & Server Help)

Discussion in 'Installation/Configuration' started by JohnnyBGoode, Oct 28, 2005.

  1. JohnnyBGoode

    JohnnyBGoode New Member

    Hi, I've been trying to figure this out for a couple of hours now. I know it's probably a stupid question, but I haven't been able to find any results by searching the forums.

    Anyhow, I have everything setup. I installed Ubunutu, got ISPConfig running. I thought everything would be perfect, however, I must have skipped the whole "DNS education" part when I learned how to use the internet throughout my life, so far.

    Is it possible to have ISPConfig be both the DNS and the webserver? It appears as though it is running as both, but I lack the understanding as to how to configure the domain to properly serve as both. I have a domain registered through GoDaddy, and I originally assigned the domain to that IP.

    It's statically assigned using the DNS tool they offer. I just maid it @ and www = my servers IP. However, I can't see that as being correct. Or is it? If so, will my server be able to act as a nameserver for its own domain? Could I specifiy my own DNS instead of just pointing directly to the server IP within GoDaddy's DNS setup?

    Or is that an illogical loop, and will only newly registered domains be able to use my nameserver? I'm completely confused, and in desperate need of help here. Also, this relates to the whole hostname/domainname issue. Currently I have my servers hostname setup as www.domain.com, which I assume is correct. Within the ISPConfig settings, I have two nameservers setup ns1.domain.com and ns2, both pointing to my server's IP. I have yet to actually setup a website yet, even though Apache is running correctly and such.

    Any advice/help would be greatly appreciated. Thanks in advance, and hopefully this is the right forum :)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Yes.

    Yes; otherwise it would be the chicken/egg problem.
     
  3. Lil'Brudder

    Lil'Brudder New Member

    I'm attempting the same thing.

    I'm glad to hear I'm not the only one trying this out. If you've read the boards over the last 2 weeks, I've been working on this same problem and I think I'm about to solve the problem. If I do, I'll be sure to post it, but I'm actually typing this to ask that, if you find the solution, to post it as well. :) Any time saved solving this would be greatly welcomed.

    In this post by Sapient

    http://www.howtoforge.com/forums/showthread.php?t=859

    it sounds like he had the same problem and solved it... but, sadly, that made no sense to me. Maybe if he reads this, he'll have some 'idiot-proof' steps we might take?

    As to my attempt at solving this, in some of the posts I've read, some suggestions were made that I want to incorporate which might end up working to my benefit.

    In particular, this post:

    http://www.howtoforge.com/forums/showthread.php?t=203

    Which says that on a multi-homed server, browsing to http://ipaddress, you get a generic 'Sorry, you cannot browse this IP address, please type in the domain name' message (similar to ie. http://www.server274.com/ ) This way, browsing to the IP address gives you an error message instead of the first website created.

    There may be a different way to do this, but I set up the server before with the mindset that the first domain was the 'admin' domain or root, and I think this creates part of the problem.

    I'm thinking that if I set up the server, keeping in mind that 'admin' will be the IP address, not a domain name, then creating a domain name to use to host the Name Server, might work better? I guess the problem is having the domain that's acting as the DNS pointing to itself. If this doesn't work, then I'll probably register another domain name to use strictly for resolving my new ns.domain.com, point it to zoneedit and then point all the other domains to that domain name...

    That may have been completely confusing... but, hopefully that will work. If not, I'm back to square one.

    By the way, if anyone else has any other ideas or solutions to this problem, please post it for both of us. ;)
     
  4. JohnnyBGoode

    JohnnyBGoode New Member

    Right now, my issue is that the nameservers I have created, don't really exist. The two hostnames ns1.mysite.com and ns2.mysite.com are not resolving. mysite.com, does, however resolve to the default apache directory.

    All that means, is that apache is running, and that the IP is being pointed to directly from GoDaddy. I really think the issue lies within the correct settings in the GoDaddy manager.

    I have tried using my domain name, my IP, and both nameserver domains as the nameserver choices for a second domain I have registered, and neither one is accepted by GoDaddy or Namecheap.

    My thoughts were, it isn't an issue with either one of the registrars, but rather a setting I (you, and possibly others) have misconfigured. So, below is the setup of names I have working... hopefully it helps.

    ISPConfig
    DNS Manager Settings:

    Title: MySite
    Server: MyServer
    Domain: mysite.com
    IP Address: xxx.xxx.xxx.xxx

    Options:

    Nameserver 1: ns1.mysite.com
    Nameserver 2: ns2.mysite.com

    Records:

    A-Records
    ns1 and ns2 are both xxx.xxx.xxx.xxx


    GoDaddy.com DNS Settings
    Originally, before they added the DNS Manager, I had my IP's forwarded to, but now they allow the manager... and the settings are as follows.

    @ and WWW are both xxx.xxx.xxx.xxx

    That's essentially it. I just removed the few site examples I had been playing around with so that I could start from a clean slate. If anything above looks incorrect, please let me know... or if you need any conf files, etc, please reply. Hopefully this "problem," if it really is a problem, not just a misunderstanding (or lack of knowledge) can get resolved. :)
     
    Last edited: Oct 28, 2005
  5. Lil'Brudder

    Lil'Brudder New Member

    Thanks JohnnyBGoode

    I didn't know about the Domain Host Utility at GoDaddy. This looks promising... I'll give it a try soon and let you know if I get any results.
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Again this is the chicken/egg problem. You are using ns1.mysite.com and ns2.mysite.com to resolve mysite.com. You can use ns1.mysite.com and ns2.mysite.com to resolve any other domain, but not mysite.com.

    Use your GoDaddy DNS Manager to create ns1.mysite.com and ns2.mysite.com, and then you can use these nameservers in ISPConfig.
     
  7. JohnnyBGoode

    JohnnyBGoode New Member

    Ok, I have done that, I created a sample site and put in those settings.

    Mysite2 has the nameservers ns1.mysite.com and ns2.mysite.com (within ISPConfig), however, GoDaddy won't allow this. It gives me the "Unavailable error in field Host name" message, which seems to mean that the nameserver doesn't exist... but, again, with MySite1, GoDaddy is correctly pointing ns1 and ns2 to MySite1's IP address, and they both resolve correctly when browsing to them.

    Within GoDaddy, for Mysite2, I'm assuming I should be putting in ns1.mysite.com, and ns2... as the nameservers, because if I have to point MySite2 to my actual server IP, then it will be doing the same thing as MySite1, and will become an identical clone, but with a different URL.

    Thanks for your help so far, I appreciate it greatly :)
     
  8. Lil'Brudder

    Lil'Brudder New Member

    GoDaddy

    Hey JohnnyBGoode

    It works! Here's what I did:

    In my ISPConfig settings for the server, I created 2 Co-Domains. ns1.domain.com and ns2.domain.com.

    In the DNS Manager, I made sure that I had A Records for ns1 and ns2 that pointed to my server's internal LAN IP address (ie. 192.168.x.x)

    Then I went to GoDaddy, selected my domain name, scrolled down to 'Domain Host Summary' (don't worry about the Nameserver Summary yet) and added only the first host, ns1, that points to my external IP Address. Than I clicked Save Changes. I waited about a minute for the changes to take place then clicked on the '+' next to Domain Host Summary to make sure the changes took, then I did the same process again for ns2.

    Now, once both ns hosts were entered, I clicked on the '+' next to name server summary, then on 'see details or modify' link, and added 2 nameservers. I was using zone edit, and wanted to keep those ns entries in as backups (during testing), so I moved them to Name Server 3 and Name Server 4, and added my ns1.domain.com in Name Server 1 and ns2.domain.com in Name Server 2.

    The 'unavailable' error you were getting (and I was getting before) was because our Nameservers aren't fully qualified and GoDaddy won't allow it. But, if you put the info in the Domain Host Summary, GoDaddy will allow your own DNS.

    Once I got all the info entered... I had to wait about 3 hours before the changed took effect and browsing to mydomain.com picked up the new NS info... it wasn't instant. (I guess 3 hours is good, GoDaddy said it could take up to 2 days.)

    Hope this helps.
     
  9. JohnnyBGoode

    JohnnyBGoode New Member

    Sounds pretty good to me, it allowed the DNS to work at least :)

    Did you end up using your own nameserver for your site with the same domain? Even though it's supposed to be impossible...

    Example:

    ns1.mydomain.com is the nameserver for domain.com
    (within godaddy's DNS settings)

    And one other thing, what do you mean by co-domain? Do you mean actual "sites" from the ISP manager, or just two A records for one added domain (ns1 and ns2)? OR, did you create domain1.com, domain2.com, and then assign domain2.com the two nameservers from domain1.com with both godaddy and ISPConfig?

    I'm still confused, and this is making me feel like an idiot... :eek:

    Edit: Ok, does the first actual site you create become the main site (ie. the server IP's actual website)? Because the first site I created is showing up as the domain I plugged ns1 and ns2 into... I guess I need a third domain to test it.
     
    Last edited: Oct 28, 2005
  10. Lil'Brudder

    Lil'Brudder New Member

    Yes, that's exactly what I did. I thought you weren't supposed to do that either, however, after reading falko's post again:
    I think using the NS definitions at GoDaddy instead of on our server is what falco was saying... since they point to the IP address of where the resolution will happen. I think that this is fine. You just can't have domain.com be the Name Server and have ns1 and ns2 point to themselves. We get around this by having them initially defined at the registrar. The problem I had a hard time explaining was the fact that GoDaddy didn't allow non-authoritative Name Servers (whatever that means) but, they let us bypass that by entering the Host info, thereby kind of giving them the 'authority' of where it's resolved... or whatever. It works. lol
    Yes, this is what I did.
    Trust me... I feel the same way. Slowly, I think we'll get it. ;)

    Yes, the first site you create is going to be the 'default' website. If you browse to http://xxx.xxx.xxx.xxx (instead of a domain name)you'll get the first site you create. This is why I'm thinking of redoing the server one last time and using my IP address as the host instead of the domain. (I know this is probably the hard way to do it, but for me, for now, it's actually easier.)
     
  11. wvsailor

    wvsailor New Member

    Aaaack! I'm confused

    I WAS able to get to my "main" site (mysite.com) until I added two other FQDNs (mysite2.com & mysite3.com) to my ispConfig, so I don't know if this issue is related to this or not, but now I can't get to mysite.com, mysite2.com, or mysite3.com.

    I'm using ZoneEdit to "host" my name servers for my "main" ispConfig Site, since I have a dynamic ip. I do need to do this right? mysite.com's name servers can't point to itself? I've added in ZoneEdit.coms ip address table the following:
    mysite.com
    www.mysite.com
    mail.mysite.com
    ftp.mysite.com
    ns1.mysite.com
    ns2.mysite.com
    Someone needs to write one of those "For Dummies" (I would definately qualify!!) books, or is there a step by step guide after install for adding a site in the forums somewhere? and then adding additional sites?
    I have a netgear router with port forwarding and have "forwarded" the following ports:
    21,25,42,80,81,110
    to my server (192.168.0.XX1) on my lan. I'm running a dns updater "service" on one of my windows machines to update my dynamic ip address in the ZoneEdit ip address entries.

    On my "main" site (mysite.com) in ispConfig, I have co-domains for:
    mail
    ftp
    ns1
    ns2

    Now, with any other site that I "host" on my server , the DNS entries will be NS1.MYSITE.COM & NS2.MYSITE.COM, correct? or do I need to use ZoneEdit.com for those also? I'm such a NOOB! :D and I'm sooo confused! Do the name servers in ispConfig "communicate" with the web and let them know where ALL of the sites that I'm hosting on my server are?

    So, in summary, I took the following steps:
    1) Added "client" in ispConfig
    2) Added "mysite.com" in ispConfig
    After a couple of hours, I could actually get to mysite.com from the net AND ispConfig Admin.
    3) Added "mysite2.com" in ispConfig
    4) Added "mysite3.com" in ispConfig
    Now, I can't even get to "mysite.com", "mysite2.com", "mysite3.com", or ispConfig Admin via the net. I know that I screwed up somewhere, the software is wonderful.
    I tried updating the DNS records in my registrar to ns1.mysite.com and ns2.mysite.com for mysite2.com and mysite3.com, but they say that ns1&ns2.mysite.com don't exist? AAaack! :p
     
  12. falko

    falko Super Moderator ISPConfig Developer

    What's in Vhosts_ispconfig.conf (please don't replace the real domain names!)?
    What's the output of
    Code:
    ifconfig
    ?
     
  13. wvsailor

    wvsailor New Member

    ifconfig

    Here's the output of ifconfig:

    [root@localhost ~]# ifconfig
    eth0 Link encap:Ethernet HWaddr 00:30:BD:B7:22:ED
    inet addr:192.168.0.30 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::230:bdff:feb7:22ed/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:45094 errors:0 dropped:0 overruns:0 frame:0
    TX packets:45402 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:12040418 (11.4 MiB) TX bytes:17834241 (17.0 MiB)
    Interrupt:3 Base address:0xcc00

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:13885 errors:0 dropped:0 overruns:0 frame:0
    TX packets:13885 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:6166333 (5.8 MiB) TX bytes:6166333 (5.8 MiB)

    and where can I locate Vhosts_ispconfig.conf ? I've tried searching via the "find" command and in the "File Manager", but they can't locate it. I'll continue searching, but I wanted to get this up.
     
  14. wvsailor

    wvsailor New Member

    content of Vhosts_ispconfig.conf (part 1)

    ###################################
    #
    # ISPConfig vHost Configuration File
    # Version 1.0
    #
    ###################################
    #
    NameVirtualHost 192.168.0.30:80
    <VirtualHost 192.168.0.30:80>
    ServerName localhost
    ServerAdmin root@localhost
    DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.wvsllc.com:80
    ######################################
    SPConfig vHost Configuration File
    # Version 1.0
    #
    ###################################
    #
    NameVirtualHost 192.168.0.30:80
    <VirtualHost 192.168.0.30:80>
    ServerName localhost
    ServerAdmin root@localhost
    DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.wvsllc.com:80
    ######################################
    #
    #
    <VirtualHost 192.168.0.30:80>
    php_admin_flag register_globals on
    php_admin_flag register_long_arrays on
    ServerName www.wvsllc.com:80
    ServerAdmin webmaster@wvsllc.com
    DocumentRoot /var/www/web1/web
    ServerAlias wvsllc.com ftp.wvsllc.com ns1.wvsllc.com ns2.wvsllc.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /var/www/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/error_400.html
    ErrorDocument 401 /error/error_401.html
    ErrorDocument 403 /error/error_403.html
    ErrorDocument 404 /error/error_404.html
    ErrorDocument 405 /error/error_405.html
    ErrorDocument 500 /error/error_500.html
    ErrorDocument 503 /error/error_503.html
    #
    #
    <VirtualHost 192.168.0.30:80>
    php_admin_flag register_globals on
    php_admin_flag register_long_arrays on
    ServerName www.wvsllc.com:80
    ServerAdmin webmaster@wvsllc.com
    DocumentRoot /var/www/web1/web
    ServerAlias wvsllc.com ftp.wvsllc.com ns1.wvsllc.com ns2.wvsllc.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /var/www/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/error_400.html
    ErrorDocument 401 /error/error_401.html
    ErrorDocument 403 /error/error_403.html
    ErrorDocument 404 /error/error_404.html
    ErrorDocument 405 /error/error_405.html
    ErrorDocument 500 /error/error_500.html
    ErrorDocument 503 /error/error_503.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    </VirtualHost>
    #
    #
    #
    ######################################
    # Vhost: www.sailorcam.com:80
    #
    #
    <VirtualHost 192.168.0.30:80>
    php_admin_flag register_globals on
    php_admin_flag register_long_arrays on
    ServerName www.wvsllc.com:80
    ServerAdmin webmaster@wvsllc.com
    DocumentRoot /var/www/web1/web
    ServerAlias wvsllc.com ftp.wvsllc.com ns1.wvsllc.com ns2.wvsllc.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /var/www/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/error_400.html
    ErrorDocument 401 /error/error_401.html
    ErrorDocument 403 /error/error_403.html
    ErrorDocument 404 /error/error_404.html
    ErrorDocument 405 /error/error_405.html
    ErrorDocument 500 /error/error_500.html
    ErrorDocument 503 /error/error_503.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    </VirtualHost>
    #
    #
    #
    ######################################
    # Vhost: www.sailorcam.com:80
    ######################################
    ######################################
    #
    #
    <VirtualHost 192.168.0.30:80>
    ServerName www.sailorcam.com:80
    ServerAdmin webmaster@sailorcam.com
    DocumentRoot /var/www/web2/web
    ServerAlias sailorcam.com mail.sailorcam.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /var/www/web2/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web2/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode On
    php_admin_value open_basedir /var/www/web2/
    php_admin_value file_uploads 1
    php_admin_value upload_tmp_dir /var/www/web2/phptmp/
    php_admin_value session.save_path /var/www/web2/phptmp/
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web2/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDoclHost>
    #
    #
    #
    ######################################
    # Vhost: www.wvstuds.com:80
    ######################################
    #
    #
    #
    #
    <VirtualHost 192.168.0.30:80>
    ServerName www.sailorcam.com:80
    ServerAdmin webmaster@sailorcam.com
    DocumentRoot /var/www/web2/web
    ServerAlias sailorcam.com mail.sailorcam.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /var/www/web2/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web2/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode On
    php_admin_value open_basedir /var/www/web2/
    php_admin_value file_uploads 1
    php_admin_value upload_tmp_dir /var/www/web2/phptmp/
    php_admin_value session.save_path /var/www/web2/phptmp/
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web2/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    </VirtualHost><VirtualHost 192.168.0.30:80>
    ServerName www.wvstuds.com:80
    ServerAdmin webmaster@wvstuds.com
    DocumentRoot /var/www/web4/web
    ServerAlias wvstuds.com mail.wvstuds.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /var/www/web4/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web4/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web4/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web4/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web4/user/$1/web/$3
    </VirtualHost>
    #
    #
    #ument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    </VirtualHost>
     
  15. wvsailor

    wvsailor New Member

    Vhosts_ispconfig.conf (part 2)

    #
    #
    #
    ######################################
    # Vhost: www.wvstuds.com:80
    ######################################
    #
    #
    #
    #
    <VirtualHost 192.168.0.30:80>
    ServerName www.sailorcam.com:80
    ServerAdmin webmaster@sailorcam.com
    DocumentRoot /var/www/web2/web
    ServerAlias sailorcam.com mail.sailorcam.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /var/www/web2/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web2/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode On
    php_admin_value open_basedir /var/www/web2/
    php_admin_value file_uploads 1
    php_admin_value upload_tmp_dir /var/www/web2/phptmp/
    php_admin_value session.save_path /var/www/web2/phptmp/
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web2/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web2/user/$1/web/$3
    </VirtualHost><VirtualHost 192.168.0.30:80>
    ServerName www.wvstuds.com:80
    ServerAdmin webmaster@wvstuds.com
    DocumentRoot /var/www/web4/web
    ServerAlias wvstuds.com mail.wvstuds.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /var/www/web4/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web4/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web4/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web4/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web4/user/$1/web/$3
    </VirtualHost>

    Sorry, but I don't know how to get those "scrolly" things in here so I can post it all in one reply.
    Thanks in advance for your help!
     
  16. falko

    falko Super Moderator ISPConfig Developer

    www.wvsllc.com is existing three times in your Vhosts_ispconfig.conf, as well as your other webs! :eek: How did that happen? Did you modify the ISPConfig sources or the ISPConfig database?
     
  17. wvsailor

    wvsailor New Member

    Hmmmmm....

    No, I don't think I modified anything, I did try and delete the other two websites, albiet unsuccessfully, and then re-added them. Hmmmm... should I just try a re-install? I honest don't know how to modify the databases as i'm very unfamiliar with mySQL, as for the ispConfig sources, it's the same. I don't know how they work. I've obviously screwed up something somewhere! LOL!
     
  18. falko

    falko Super Moderator ISPConfig Developer

    If you have phpMyAdmin installed, you can browse to your isp_isp_web table in the ISPConfig database. Do you see all your web sites three times in it?
     
  19. wvsailor

    wvsailor New Member

    phpMyAdmin

    No, I don't have phpMyAdmin installed.... and since a power outage, I can't even access my main website. I think I'm just going to do a fresh install and Start from scratch.
     
  20. falko

    falko Super Moderator ISPConfig Developer

Share This Page