Slight problem with Squirrelmail

Discussion in 'Server Operation' started by DaleHutch, May 11, 2010.

  1. DaleHutch

    DaleHutch Member


    I've got a slight problem accessing squirrelmail from outside. From within the network I can access it fine...

    But when I try to access it from it get the infamous ERROR 404 message from ISPconfig... I can view the website fine but squirrelmail does not.

    phpmyadmin works though....

    Any suggestions?

  2. KZeeSoft

    KZeeSoft New Member

    Try this, I found it on the web for you, but you may have to tweak it for your server settings:

    Edit the /etc/apache2/sites-available/configfile.conf (this file name may vary from person to person) Apache configuration file and add the following block:

    ServerAlias mail.*
    ServerAdmin [email protected]
    DocumentRoot /home/www/webmail

    Here's a breakdown of what's above:

    <VirtualHost> - This indicates I'm setting up my mail interface as a virtual host, rather than IP based. Obviously, you're going to want to replace with the IP address of your web server. Additionally, what you have here may vary from server to server and is dependent on how you have your Apache configured. Be cautious!

    ServerName - The official name of the webmail server virtual host.

    ServerAlias mail.* - This line establishes a wildcard serveralias called mail.*. With this setup, any domain that is pointed to your server and that has an A record called "mail", will be able to get to the webmail interface by simply going to This is a pretty cool little feature and makes accessing the webmail interface easy for all of your users.

    ServerAdmin [email protected] - The server administrative contact. This is not required, but I like to include it.

    DocumentRoot /home/www/webmail - The document root of your webmail interface. This will vary, depending on where you chose to install Squirrelmai. In this example, you can see that I installed it at /home/www/webmail

    </VirtualHost> - The closing tag to the virtualhost.

    Make sure you restart Apache after making the above changes.
  3. DaleHutch

    DaleHutch Member


    I'll try it!

Share This Page