Slave with Mysql5.5 cannot connect to the Master

Discussion in 'General' started by holykim, Sep 20, 2011.

  1. holykim

    holykim New Member

    Hi,

    Recently I installed MySQL 5.5 to one of the slaves and found that it cannot connect to the master server anymore. I created a new db on the slave from the master server but nothing created.

    I tried to reconfigure permission in the master database but got an error as below.
    Unable to connect to mysql server Lost connection to MySQL server at 'reading initial communication packet', system error: 110

    All other slaves which installed MySQL 5.0 are working fine. I installed MySQL 5.5 to the test server and had a same result.

    I cannot figure out how to resolve this issue and need your advise. ISPConfig version is 3.0.3.3.

    Thanks in advance.

    Harry
     
  2. till

    till Super Moderator

    Are you able to connect to the master server as root user from the shell of the slave with the mysql command. Example:

    mysql -h master.yourdomain.tld -u root -p dbispconfig

    the command should ask you then for the root password of the master server.
     
  3. holykim

    holykim New Member

    Thanks Till

    I was unable to have the connection to the master server. It wasn't mysql problem.

    I added the master IP in the hosts file and it works.

    Thanks again.

    Harry
     

Share This Page