Skip SpamAssassin check from local domains

Discussion in 'Installation/Configuration' started by clixclix, Feb 27, 2014.

  1. clixclix

    clixclix ISPConfig Developer ISPConfig Developer

    Hi everybody,

    SpamAssassin checks on my ISPConfig3 server are taking up to 10 seconds and more.
    If I change "$sa_local_tests_only = 0;" to "$sa_local_tests_only = 1;" on "/etc/amavis/conf.d/20-debian_defaults", the problem goes away. Anyway, this is not a solution.

    Until I find the solution for the above problem, I'd like to skip SpamAssassin check when emails are sent from "mynetworks" as configured in /etc/postfix/

    Does anybody know a way to do that?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not unusual, amavis can check several emails at the same time so this will not limit the number of emails checked by your server, it will just slow down mail delivery fro a few seconds. But you should try to use other dns servers in /etc/resolv.conf, e.g. the free servers from google: and
  3. clixclix

    clixclix ISPConfig Developer ISPConfig Developer

    Thanks Till.
    Anyway, I checked the /var/log/mail.log file with "$log_level = 5;" in /etc/amavis/conf.d/50-user": the bottleneck is the "SA check" (spamassassin check) step and the emails are SA-checked one at a time.
    The problem seems to persist even if I add "-o disable_dns_lookups=yes" on "/etc/postfix/" file, at the amavis service.
    Perhaps I shoud find out which of the remote spam databases is slowing down SA, and exclude it...

    For now, it would be good just to be able to "whitelist" emails sent from my network.
    The ISPConfig3 built-in "Whitelist" options don't allow this.

    Thanks again in advance for any hint.

Share This Page