sites_web_domain_add.php Error

Discussion in 'Developers' Forum' started by mrkhoros, Dec 8, 2013.

  1. mrkhoros

    mrkhoros New Member

    I get this error from sites_web_domain_add.php

    Logged successfull. Session ID:6820b8c48085103c012408e6dbfed581
    data_processing_errorpm_process_idle_timeout_error_regex<br />
    pm_max_requests_error_regex<br />
    SOAP Error: pm_process_idle_timeout_error_regex
    pm_max_requests_error_regex

    The regard inside the php file that I am running is :

    <?php

    require('soap_config.php');


    $client = new SoapClient(null, array('location' => $soap_location,
    'uri' => $soap_uri,
    'trace' => 1,
    'exceptions' => 1));


    try {
    if($session_id = $client->login($username,$password)) {
    echo 'Logged successfull. Session ID:'.$session_id.'<br />';
    }

    //* Set the function parameters.
    $client_id = 2;

    $params = array(
    'server_id' => 1,
    'ip_address' => '',
    'domain' => 'test2asd.int',
    'type' => 'vhost',
    'parent_domain_id' => 1,
    'vhost_type' => 'name',
    'hd_quota' => 1000,
    'traffic_quota' => -1,
    'cgi' => 'y',
    'ssi' => 'y',
    'suexec' => 'y',
    'errordocs' => 1,
    'is_subdomainwww' => 1,
    'subdomain' => '',
    'php' => 'y',
    'ruby' => 'n',
    'redirect_type' => '',
    'redirect_path' => '',
    'ssl' => 'n',
    'ssl_state' => '',
    'ssl_locality' => '',
    'ssl_organisation' => '',
    'ssl_organisation_unit' => '',
    'ssl_country' => '',
    'ssl_domain' => '',
    'ssl_request' => '',
    'ssl_cert' => '',
    'ssl_bundle' => '',
    'ssl_action' => '',
    'stats_password' => '',
    'stats_type' => 'webalizer',
    'allow_override' => 'All',
    'apache_directives' => '',
    'php_open_basedir' => '/',
    'custom_php_ini' => '',
    'backup_interval' => '',
    'backup_copies' => 1,
    'active' => 'y',
    'traffic_quota_lock' => 'n'
    );

    $affected_rows = $client->sites_web_domain_add($session_id, $client_id, $params, $readonly = false);

    echo "Web Domain ID: ".$affected_rows."<br>";


    if($client->logout($session_id)) {
    echo 'Logged out.<br />';
    }


    } catch (SoapFault $e) {
    echo $client->__getLastResponse();
    die('SOAP Error: '.$e->getMessage());
    }

    ?>

    Server ID was 0 by default I made to 1 which is actual.
    some assistance please.
    Thanks
     
  2. mrkhoros

    mrkhoros New Member

    I have over come this issue by adding

    'pm_process_idle_timeout' => 10,
    'pm_max_requests' => 0,

    to sites_web_domain_add.php

    For some reasons the parameters are missing . Is there any newer versions of remoting_client / examples / I can use maybe ?
     
  3. mrkhoros

    mrkhoros New Member

    Ok the problem is much more severe than that
    Using those without adding these before 'traffic_quota_lock' => 'n'

    'pm' => 'dynamic',
    'pm.min_spare_servers' => 1,
    'pm.max_spare_servers' => 5,
    'pm.start_servers' => 2,

    and you will end up getting Error 502 gateway error so make sure you add these 4 parameters to that file too.
     

Share This Page