Sites unreachable (dns or bind problem)

Discussion in 'ISPConfig 3 Priority Support' started by tonytroy, May 28, 2014.

  1. tonytroy

    tonytroy Member

    Hi there,

    Because of a stupid mistake, i had to reset my debian and install a fresh ISP Config 3, that is now done following the perfect server tutorial.

    I've created a DNS record with the wizard for a website, let's say called mydomain.tld, but i'm not able to join it by it's URL.

    So i took a look at intodns.net and found this :

    named-checkzone mydomain.tld pri.mydomain.tld => returns OK

    dig @localhost mydomain.tld => returns the good answer

    dig mydomain.tld => returns no answer

    I did not install any firewall (nor anything else except what is said in the tutorial).

    I'm really lost...

    Does someone have any idea ? :confused:
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Does the ip address that intodns shows as IP of your dns server match with the ip address of the server were you created the dns records?
     
  3. tonytroy

    tonytroy Member

    the first ip adress is the secondary dns' ip adress, and the second is the server's ip address.

    the dns returned by intodns.net are also correct.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Does it work when you run:

    dig @localhost mydomain.tld

    but replace localhost with the external ip address?
     
  5. tonytroy

    tonytroy Member

    nope, i have a connection timed out : no servers could be reached
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    check with "netstat -tap" if bind is listening on all interfaces and not just localhost and check with "iptables -L" that there is really no firewall rule blocking bind.
     
  7. tonytroy

    tonytroy Member

    I didn't find bind, this is what "netstat -tap" returned :

    And this is what "iptables -L" returned :

     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The process of the bind server is "named", so you find it under that name. Sorry that I did not mention that. according to the output, bind is listening only on localhost and that explains why your named do not resolve externally. Please post the named.conf and named.conf.options configuration files.
     
  9. tonytroy

    tonytroy Member

    named.conf :

    named.conf.options :

     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Change the line:

    listen-on { 127.0.0.1; };

    to:

    listen-on { any; };

    and restart bind.
     
  11. tonytroy

    tonytroy Member

    thx till, you saved me again :)
     

Share This Page