Sites not working

Discussion in 'Server Operation' started by YamiHoshi, Jul 29, 2010.

  1. YamiHoshi

    YamiHoshi New Member

    I've installed my Server using this: http://www.howtoforge.com/installing-lighttpd-with-php5-and-mysql-on-centos-5.2
    I'm using CentOS 5.5, thought.
    Next, I've configured /etc/httpd/conf/httpd.conf, so I could host multiple sites (aka, VirtualHost), nothing else has been changed.
    Code:
    ### Section 3: Virtual Hosts
    #
    # VirtualHost: If you want to maintain multiple domains/hostnames on your
    # machine you can setup VirtualHost containers for them. Most configurations
    # use only name-based virtual hosts so the server doesn't need to worry about
    # IP addresses. This is indicated by the asterisks in the directives below.
    #
    # Please see the documentation at
    # <URL:http://httpd.apache.org/docs/2.2/vhosts/>
    # for further details before you try to setup virtual hosts.
    #
    # You may use the command line option '-S' to verify your virtual host
    # configuration.
    
    #
    # Use name-based virtual hosting.
    #
    NameVirtualHost *:80
    #
    # NOTE: NameVirtualHost cannot be used without a port specifier
    # (e.g. :80) if mod_ssl is being used, due to the nature of the
    # SSL protocol.
    #
    
    #
    # VirtualHost example:
    # Almost any Apache directive may go into a VirtualHost container.
    # The first VirtualHost section is used for requests without a known
    # server name.
    #
    <VirtualHost *:80>
        ServerName www.yamihoshi.nl
        ServerAlias yamihoshi.nl
        DocumentRoot /home/yamihoshi.nl
        Options MultiViews FollowSymLinks
        Options MultiViews IncludesNoExec FollowSymLinks
        Options +Includes
    </VirtualHost>
    
    <VirtualHost *:80>
        ServerName www.mariokartcw.org
        ServerAlias mariokartcw.org
        DocumentRoot /home/mariokartcw.org
        Options MultiViews FollowSymLinks
        Options MultiViews IncludesNoExec FollowSymLinks
        Options +Includes
    </VirtualHost>
    
    <VirtualHost *:80>
        ServerName www.woondroomgoes.nl
        ServerAlias woondroomgoes.nl
        DocumentRoot /home/woondroomgoes.nl
        Options MultiViews FollowSymLinks
        Options MultiViews IncludesNoExec FollowSymLinks
        Options +Includes
    </VirtualHost>
    But if I go to one of these sites, I can get either a "404 - Not Found", or a dead link.
    At the first few minutes, it seemed that one of them could view "index.html", but nothing else.
    So, what am I doing wrong?
    And, how to solve it?

    Update1:
    The vHost part is solved, using lighttpd.conf.
    Now I get 403 - Forbidden messages.

    Update2:
    403 errours solved.
    Just done this in the /home directory:
    chown -R lighttpd:lighttpd *

    Update3:
    Problem not solved.
     
    Last edited: Jul 30, 2010
  2. YamiHoshi

    YamiHoshi New Member

    Now I see, if I go back to the original hoster, the sites also don't work.
    If I go to my other VPS, they also don't work.

    Now I'm totally lost.
    Could someone help me?

    Update1:
    After "ps aux | less", I see Lighttpd isn't running at all.
    However though I've started it successfully for a billion times already.
    So, how to start it, so it's really started?

    Update2:
    After the command "lighttpd -f /etc/lighttpd/lighttpd.conf", no errours showed up.
    Now what?
     
    Last edited: Jul 30, 2010
  3. falko

    falko Super Moderator ISPConfig Developer

    /etc/httpd/conf/httpd.conf belongs to Apache, not Lighttpd, so I guess you have Apache running. What's the output of
    Code:
    netstat -tap
    ?
     
  4. YamiHoshi

    YamiHoshi New Member

    I already said I found that out already.
    I'm now trying Debian on that VPS, so this thread is no longer usable.
    But it will be, if Debian fails on MySQL, again.
     

Share This Page