Sites mixing

Discussion in 'General' started by Janfi, May 8, 2020.

  1. Janfi

    Janfi New Member

    Hello,
    On my ispconfig3 / debian server I have a strange problem :
    recently I added a new wordpress site with it's own domain name (Let say A-site).
    after few days we notices that when we go to another site (B-site) on the same server, the browser display the site A-site with the url of B-site.
    Si I have to unactivate the new siteA-site to make work again the other one B-site.

    I really don't understand what append.

    Can somebody help please ?

    Thanks
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Maybe half toungue-in-cheek, what if we added the feature in ISPConfig to configure the always default website (http and https) and use that to explain to folks seeing it why they see it rather than what they expect to see? Maybe cut down a little on the faq posts.

    For that matter, we should make an actual faqforge.com faq entry, with lots of threads here linking to it, perhaps it would get found more in searches.

    Also thumbs up https://git.ispconfig.org/ispconfig/ispconfig3/-/issues/3952 (request to prohibit selection of ip addrs for websites) which would help eliminate one common scenario which causes this (mixing ip and '*' in website settings).
     
    Taleman and ahrasis like this.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    My Idea for this issue is to go even further and remove the IP address fields from website by default and show it only in case this option has been manually activated by the admin after install and to not add the IP address of the server under System > server IP by the installer anymore.
     
    ahrasis and nhybgtvfr like this.
  5. Janfi

    Janfi New Member

    Thank you very much, sometimes I used * and other times the ip address.

    It's not always easy to read forums and faqs in english for me.

    Thank you very much, it works fine.
     

Share This Page