sites gone

Discussion in 'General' started by Savvy, Feb 22, 2014.

  1. Savvy

    Savvy New Member

    help i was trying to add a SSL cert to ispconfig tonight and eveythings gone wrong sites down as is ispconfig this is errors i can find
    [Fri Feb 21 17:54:02 2014] [error] Unable to configure verify locations for client authentication
    [Fri Feb 21 17:54:10 2014] [error] Unable to configure RSA server private key
    [Fri Feb 21 17:54:10 2014] [error] SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch

    what do i need to do to fix mysite and get it back up and running???? please help thanks
     
  2. neutrino

    neutrino Member

    If everything was fine before you started, remove all the certificates from the SSL page, to do that, go to the SSL page, choose "delete certificate" in the SSL action and save.

    Once done, uncheck SSL in the domain page.

    This should at least bring your website up again, concerning your problem what did you do exacly, generating a new private certificate ? Trying to import one ? Playing with the vhost files on your server ?
     
  3. Savvy

    Savvy New Member

    everything has gone

    i cant get into control panel or phpmyadmin or site just FTP using winscp :( i was going to try reinstalling ISPconfig again using putty to see if that helps,

    i was in the proccess of doing the SSL i had got email to the [email protected] with the parts i need and was filling the details into ISPconfig then clicked create and then all went off the page refreshed then i got the unable to connect to server when going to my site and then tryed phpmyadmin that was down onnly thing i can get into is FTP and Putty ive rebooted server a few times that didnt work either im really at a loss as to what to do :(

    i ran this command in putty and this is what i got

    [email protected]:~# wget -O- http://trans-alliancecafe.info

    --2014-02-22 00:24:41-- http://mydomain.info/
    Resolving mydomain.info (/mydomain.info)... IP*.**.*.**.
    Connecting to P*.**.*.**.info (mydomain.info)|P*.**.*.**.|:**... failed: Connection refused.
     
    Last edited: Feb 22, 2014
  4. sjau

    sjau Local Meanie Moderator

    hmmm, is that a new server? because you say to isntall ISPC again. If so, do you use debian wheezy?
     
  5. Savvy

    Savvy New Member

    yes debian 52 CET 2013 x86_64 Debian GNU/Linux 7.4

    installed ISPConfig-Version: 3.0.5.3

    ive had my site up and running for a week and today started with SSL and its all gone wrong :(
     
  6. sjau

    sjau Local Meanie Moderator

    well, in case you want to make a re-install, I have a little script that automate the installation when you have a basic debian wheezy installed... but fixing things owuld be better :)
     
  7. Savvy

    Savvy New Member

    reply

    reinstall of ISPconfig??? only
     
  8. sjau

    sjau Local Meanie Moderator

    not with my script.. .it's aimed at a vanilla debian installation. sorry.
     
  9. Savvy

    Savvy New Member

    reply

    i meant should i try reinstall of ISPconfig see if that fixes the pproblem???
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    No need for a reinstall. all you have to do is to disable the website were you installed the broken ssl cert by deleting the symlink eith the name of the domain in /etc/apache2/sites-enabled/ folder. Then restart apache and you will be able to login to ispconfig again. then go to the website settings, disable ssl and create a new ssl cert and enable ssl again.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    you should have selected save certificate and not create cetifcate when yozu want to save a certificate that you received from a ssl authority.
     
  12. Savvy

    Savvy New Member

    reply

    thank you will try that now :) i really hope this works as my last resort plan z lol is a total reinstall of OS and start again reinstalling my site :(

    oops i knew ihad done something wrong as ive got the files needed but was unsure as to what went where and in what order
     
    Last edited: Feb 22, 2014
  13. sjau

    sjau Local Meanie Moderator

    if till says it works, it'll work :)
     
  14. Savvy

    Savvy New Member

    file found

    ive found said file in apache2 folder but am unsure what to do with it tryed turning SSl bit to off and deleted 2 lines where path to ssl cert is and that hasnt worked can you give me a little more info please sorry for being such a noob lol
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    Its not a file, its a symlink. looks similar when you try to pen it with an editr. do not delete anything inside, delete the whole symlink (file).
     
  16. Savvy

    Savvy New Member

    done that now ive got this on my webpage
    It works!

    This is the default web page for this server.

    The web server software is running but no content has been added, yet.

    how do i get my site back?? please

    scrap that im back :) wow you guys are amazing thanks so much your help is so much appreciated and ive learned loads :) now to find page on adding SSL again lol and not just charging ahead :)
     
    Last edited: Feb 22, 2014
  17. Savvy

    Savvy New Member

    Ssl

    Now im back on in ISPconfig in the SSL Tab the first 3 boxes have got info in
    SSL Key, SSL Request and SSL Certificate my website with https://mydomain.info has the apache message it works what do i do now to complete?? dont want to mess this up again thanks again
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    I posted it in #10 of this thread:

    "then go to the website settings, disable ssl and create a new ssl cert and enable ssl again."
     
  19. Savvy

    Savvy New Member

    reply

    yes thanks i got it installed problem now is images from other places that arent https:// dont make me 100 Secure and SSL isnt verifyed ive attached a pic to show you more what i mean this is all new to me :)
     
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats a probem with your website, not with the server setup. ensure that you load images only locally from a path and not from a url starting with http:// and do not load images form external servers.
     

Share This Page