sites dont get created / problem with cron

Discussion in 'General' started by weezul, Sep 19, 2009.

  1. weezul

    weezul New Member


    i noticed that if i create a new domain / site in ispconfig the site doesnt get created, so what i've figured out already is that /usr/local/ispconfig/server/ is making troubles.

    cat cron.log tail
    shows me
    /bin/sh: /usr/local/ispconfig/server/ /bin/bash^Mbad interpreterNo such file or directory
    i vied the file and executed

    /usr/bin/php -/usr/local/ispconfig/server/server.php
    that worked.. but how can i fix my cron?
    i googled how to remove those ^M tags but nothings working, still getting those error line and my cronjob fails.
  2. weezul

    weezul New Member

    whoooppss... ok solved...

    installed and ran

    apt-get install tofrodos
    that fixed those ^M error...
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The file delivered with ispconfig does not contain any dos linebreaks on my system. So I guess you must have edited it and saved it with wrong linebreaks or uploaded it with a FTP client with wrong settings.

Share This Page