Sites are up, but none show in ispconfig

Discussion in 'Installation/Configuration' started by Check, Jan 30, 2008.

  1. Check

    Check New Member

    During my attempt to upgrade to .19 i ran into all the error that other people were getting. Then i tried the solution and that did not fix the issue.

    I ended up installing .18 and unlike what i wanted instead of doing the upgrade (when it recognizes something is installed) it did a clean install. Afterword I tested all the site and ftp's and everything works fine, But when i log into ispc now no sites or resellers or anything is set up. Is there something i can do to have it detect this? There is nothing in there and it looks like a clean install. If I were to re set everything up would it get into error since the folders and file enteries already exist?

    Does anyone have any tips to get everything working again.

    Man i wish i knew more linux...im getting there...
     
  2. Hans

    Hans Moderator

    Which Linux distribution do you use?
     
  3. Check

    Check New Member

    Sorry,

    Im running ubuntu lts 6.06, using the perfect ubuntu server setup from howtoforge
     
  4. falko

    falko Super Moderator

    What's at the end of /etc/apache2/apache2.conf? What's in /etc/apache2/vhosts/Vhosts_ispconfig.conf?
    Any errors in Apache's error log?
     
  5. Check

    Check New Member

    Code:
    NameVirtualHost *
    <VirtualHost *>
            ServerName remote.snippetcreator.com
            DocumentRoot /var/www/
            ProxyRequests Off
    
            <Proxy *>
              Order deny,allow
              Allow from all
            </Proxy>
    
            ProxyPass / http://remote.snippetcreator.com:81/
            ProxyPassReverse / http://remote.snippetcreator.com:81/
    </VirtualHost>
    
    # Include the virtual host configurations:
    Include /etc/apache2/sites-enabled/
    
    <Directory /var/www/sharedip>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    ###############ispconfig_log###############
    LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_
    %d" combined_ispconfig
    
    <Directory /var/www/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/user/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/cgi-bin>
        Options ExecCGI -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
    
    
    <Directory /var/www/sharedip>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    ###############ispconfig_log###############
    LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_
    %d" combined_ispconfig
    
    <Directory /var/www/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/user/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/cgi-bin>
        Options ExecCGI -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
    
     
  6. Check

    Check New Member

    The last file you asked about has what looks like all the domains listed...i can post it in sections if needed, but its pretty long. This seems to be correct.

    Should i look in /root/ispconfig/httpd/log for the errors or is there a different log file?
     
    Last edited: Jan 31, 2008
  7. falko

    falko Super Moderator

    You have this section:

    Code:
    <Directory /var/www/sharedip>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    ###############ispconfig_log###############
    LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_
    %d" combined_ispconfig
    
    <Directory /var/www/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/user/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/cgi-bin>
        Options ExecCGI -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
    twice in your /etc/apache2/apache2.conf. Please remove one of them and restart Apache.

    I think a part from the beginning is ok.

    Apache's error log is in /var/log/apache2.
     
  8. Check

    Check New Member

    Ok i made the change and got these warnings when restarting apache. Nothing big i dont think... ***EDIT*** I removed the dupe vars. They were for ispconfig.

    I logged into the web app and everything works fine (or so it seems) but still none of my sites are listed. They were also orginized into folders and those folders are there either. So, that change didnt seem to make a difference, at least with this problem.


    Code:
    root@server1:/etc/apache2#  /etc/init.d/apache2 restart
     * Forcing reload of apache 2.0 web server...                                                                                [Mon Feb 04 09:07:11 2008] [warn] The Alias directive in /etc/apache2/apache2.conf at line 136 will probably never match because it overlaps an earlier Alias.
    [Mon Feb 04 09:07:11 2008] [warn] The Alias directive in /etc/apache2/apache2.conf at line 140 will probably never match because it overlaps an earlier Alias.
    [Mon Feb 04 09:07:12 2008] [warn] The Alias directive in /etc/apache2/apache2.conf at line 136 will probably never match because it overlaps an earlier Alias.
    [Mon Feb 04 09:07:12 2008] [warn] The Alias directive in /etc/apache2/apache2.conf at line 140 will probably never match because it overlaps an earlier Alias.
    
    Here is the first part of
    Code:
    ###################################
    #
    # ISPConfig vHost Configuration File
    #         Version 1.0
    #
    ###################################
    #
    NameVirtualHost 192.168.1.70:80
    <VirtualHost 192.168.1.70:80>
      ServerName localhost
      ServerAdmin root@localhost
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.snippetcreator.com:80
    ######################################
    #
    #
    <VirtualHost 192.168.1.70:80>
    ServerName www.snippetcreator.com:80
    ServerAdmin webmaster@snippetcreator.com
    DocumentRoot /var/www/web1/web
    ServerAlias snippetcreator.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Defau
    lt.htm default.htm
    ScriptAlias  /cgi-bin/ /var/www/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    </VirtualHost>
    #
    #
    #
    ######################################
    # Vhost: beta.snippetcreator.com:80
    ######################################
    #
    #
    <VirtualHost 192.168.1.70:80>
    ServerName beta.snippetcreator.com:80
    ServerAdmin webmaster@snippetcreator.com
    DocumentRoot /var/www/web8/web
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Defau
    lt.htm default.htm
    ScriptAlias  /cgi-bin/ /var/www/web8/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web8/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
    
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    Alias /error/ "/var/www/web8/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web8/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web8/user/$1/web/$3
    </VirtualHost>
    #
    #
    #
    ######################################
    # Vhost: monitor.snippetcreator.com:80
    ######################################
    #
    #
    <VirtualHost 192.168.1.70:80>
    ServerName monitor.snippetcreator.com:80
    ServerAdmin webmaster@snippetcreator.com
    DocumentRoot /var/www/web7/web
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Defau
    lt.htm default.htm
    ScriptAlias  /cgi-bin/ /var/www/web7/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web7/log/error.log
    
    
    If you need more i can get it but this is the first 25%

    Lastly, about the logs...There were a bunch labeled with numbers (error.log1-32) so i just took error.log and viewed that

    It was mostly filled with
    Code:
    [Sun Feb 03 19:57:49 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:50 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:50 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:50 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:50 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:51 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:51 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:51 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:51 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:51 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:51 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:52 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:52 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:52 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:52 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:53 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:53 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:53 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:53 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:53 2008] [error] an unknown filter was not added: PHP
    [Sun Feb 03 19:57:53 2008] [error] an unknown filter was not added: PHP
    
    There were hundreds of these. Besides that there were these errors...
    Code:
    [Mon Feb 04 09:07:11 2008] [notice] caught SIGTERM, shutting down
    [Mon Feb 04 09:07:12 2008] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec2)
    [Mon Feb 04 09:07:12 2008] [notice] Apache/2.0.55 (Ubuntu) PHP/5.1.2 mod_ssl/2.0.55 OpenSSL/0.9.8a configured -- resuming nor
    mal operations
    
    And

    Code:
    [error] [client 61.97.55.59] client sent HTTP/1.1 request without hostname (see RFC2616 section 14
    .23): /w00tw00t.at.ISC.SANS.DFind:)
    
    Thanks for your continued support!
     
    Last edited: Feb 4, 2008
  9. wr19026

    wr19026 New Member

    I had to roll back to a previous version as well (as documented in another thread). My version of choice was 2.2.17 on an Ubuntu 6.06.2 server and I do not experience the problem that you describe. Everything (including phpmyadmin and roundcubemail) are still there and functional.
     
  10. Check

    Check New Member

    oh oh, I may have found it.
    In checking to see if my phpMyAdmin still works correctly i notice there are 2 dbs related to ispc.

    Im guessing i chose the wrong name when i did the install and it created a new database instead of using the existing one.

    Is there a way to point it to the correct database?
     
  11. till

    till Super Moderator

    You can change the name of the database in the file /home/admispconfig/ispconfig/lib/config.inc.php
     

Share This Page