Sites are no longer adding

Discussion in 'General' started by spuppy, Sep 27, 2007.

  1. spuppy

    spuppy New Member

    I just tried to add a site, but when I go to the domain, it goes to the "this IP is shared" error.

    Furthermore, when I restart Apache, I get the following messages:

    Code:
    shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    Stopping httpd:     [  OK  ]
    Starting httpd: [Wed Sep 26 21:27:34 2007] [warn] NameVirtualHost 64.40.112.130:80 has no VirtualHosts      [  OK  ]
     
  2. till

    till Super Moderator

  3. spuppy

    spuppy New Member

    OK the site is now showing up. However, how to I prevent this from happening in the future? Is it related to an incorrect Apache Directive? I tried enabling output_buffering on one of the sites, but it gives a syntax error.

    I still get this message when I start apache:

    Starting httpd: [Wed Sep 26 23:16:27 2007] [warn] NameVirtualHost 64.40.112.130:80 has no VirtualHosts
     
  4. till

    till Super Moderator

    Did you add output buffering in a file or in the apache directives field in ISPConfig?
     
  5. spuppy

    spuppy New Member

    First I edited one (or two?) of the php.ini files, and enabled it there. I restarted apache and nothing happened. So then I tried putting it into ISPConfig for that site. Again, nothing happened. It wasn't until now that I found the syntax error (even after restarting apache several times)
     
  6. till

    till Super Moderator

    If you change a setting in any apache config file, run:

    httpd -t

    to test if your manual changes are correct. If you do the changes in ISPConfig, ISPConfig will check for correct syntax before it saves the file.
     
  7. spuppy

    spuppy New Member

    Which php.ini is the correct one to edit?
     
  8. till

    till Super Moderator

    /etc/php5/apache2/php.ini
     
  9. spuppy

    spuppy New Member

    That file does not exist on my installation.

    I have:

    /etc/php.ini
    /root/ispconfig/php/php.ini

    It seems to be working, but for some reason my software wasn't detecting it. I'll have to look elsewhere for help though, since it is unrelated to ISPConfig.

    Also, are you sure you don't know what is causing the error:

    [warn] NameVirtualHost 64.40.112.130:80 has no VirtualHosts

    ?

    Thanks!
     
    Last edited: Sep 28, 2007
  10. falko

    falko Super Moderator

    It's just a warning that can be ignored. IT means that you have a NameVirtualHost 64.40.112.130:80 directive in your configuration, but no vhost for 64.40.112.130.
     

Share This Page