Site is down and cant figure out how to get it back up

Discussion in 'General' started by rrhode, Dec 10, 2008.

  1. rrhode

    rrhode New Member

    Hi there,

    I installed ISPConfig on a dedicated system. It has one domain on it. I followed the guide here to setup the system.

    It is a CentOS 5.2 system and so I used the Perfect CentOS 5.2 guide of course. Everything was working great until yesterday when I can no longer access the domain. I can still get into ISPConfig if I go to the IP:81 but not the websites domain which should be a normal website.

    Can anyone help me figure out what is wrong and how to fix it? I suspect it has something to do with my BIND setup since I can add the IP and domain to my windows hosts file and browse to the domain fine.

    Thank you!

    Ryan
     
  2. Norman

    Norman Member HowtoForge Supporter

    What errors do you get when you try to visit the site?
    What happens when you ping the domain does it go to the correct ip?

    If you try to browse locally on your ispconfig machine, does the site display?

    Use lynx or links2 etc to browse through a terminal.
     
  3. rrhode

    rrhode New Member

    Hi Norman!

    Thank you for responding to me =)

    And you won't believe this but I was just typing a reply in another window to say I think I kind of fixed it. Just then Thunderbird dinged and I saw that you had responded to me.

    But it still seems fishy because of the fact that it was working before. Maybe it just took some time for it to update or something I am not sure.

    Anyway, I fixed it by deleting the DNS entries inside of the DNS Management area because I had manually created these entries. I realized that I can just check the boxes that say Create DNS and Create DNS MX which is much better because it actually works. I restart BIND and it works right away.

    If I don't restart bind does it take time to refresh by itself?

    I have another question but I will put it in a different thread because it is kind of its own topic.

    Again thank you for responding =) Take care!

    Ryan
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Bind is restarted automatically after configuration changes.
     
  5. rrhode

    rrhode New Member

    Ok, I thought that it was. Maybe it was just that I found out that I just have to setup a Glue record and I emailed the domain registrar about that. Hopefully they can do that.

    Thank you for your responses =) I really appreciate it!
     
  6. rrhode

    rrhode New Member

    Hello again,

    I seem to be still having some troubles with this.

    I emailed the registrar but they haven't gotten back to me. I don't exactly know what to do.

    I have a problem where the domain won't work but when I restart BIND it will work again. When I check intodns.com it will give errors saying the nameservers aren't responding but after I restart BIND these errors go away. The only thing I get is NO GLUE on the ns2 record. Which would make sense because the registrar doesn't seem to add one.

    Is a GLUE record actually required? And is there some way to find out why this will work when I restart BIND and then eventually I check and its not working until I restart bind?

    Thank you =)

    Ryan
     
  7. falko

    falko Super Moderator ISPConfig Developer

  8. rrhode

    rrhode New Member

    Well I went into ISPConfig and added ns1.domain.com as an A record because that is what it showed in the example I found here.

    I have 6 ips on this system or something but I didn't configure them like in The Perfect guide to installing centos 5.2. So I only put ns1 to the same ip as the domain as in the example.

    Then I emailed the registrar (networksolutions.com) on the 10th and again today to see if they can make a GLUE record and sent them my domain, my ns1 and ns2 hostnames and my domains ip address and another ip address that points to the same server. I am not sure if this is right or not.

    The domain sometimes doesn't work until I restart BIND and then it will work again.
     
  9. falko

    falko Super Moderator ISPConfig Developer

  10. rrhode

    rrhode New Member

    Yes I have checked intodns.com. The errors on there disappear when I restart bind except for the one that says it has NO GLUE for ns2.

    However when I checked it just now I am getting the Same Glue error which is a yellow ! where the ns1 server is being reported to have the same ip as what I told them for the ns2 server, and I don't even know if this should be an ip of the ns2 server. It is just a different ip that points at the server.

    Here is that error:
    There are some other blue ! in various places but it seems most sites have these, even google.com. The only one that is different which is related is one that says:
    At this point there is nothing in the red but I am guessing it will go back to that soon so I can show you those errors. They go away when I restart BIND for some reason or other.
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Can you post the domain name and your zone file?
     
  12. rrhode

    rrhode New Member

    Well I was trying to not do that because it isn't my site but it has to work so if you can help me that would make my day/week/month =)

    The red errors show up right now on intodns: http://www.intodns.com/greenimagesofcanada.com

    I won't restart BIND this time just so you can see them.

    I am not sure which zone file you would need. I am guessing the one for the domain. I attached it I hope that is ok. This basically will tell you my settings in ISPConfig for the domain I suppose. If you want the other files I can add them as well.

    Thank you again for your time and help. I appreciate it a great deal. I hope we can figure it out somehow because I don't understand why its doing this.

    On a sitenote I can't get verification from networksolutions that they actually made a Glue record and maybe they won't make one for me but maybe they already did. I don't know because they won't respond to me. But for some reason I don't think that should cause it to do what it is doing but then again I really don't know.
     

    Attached Files:

  13. falko

    falko Super Moderator ISPConfig Developer

    You need A records for ns1 and ns2 in your zone file. Please change that and then try intodns again.
     
  14. rrhode

    rrhode New Member

    Thanks. I have tried that before actually but eventually it gave me errors again. I will see what it does this time. I had to restart BIND in order for the errors to go away again. There was no change after just adding the A record for ns2.
     
  15. rrhode

    rrhode New Member

    Well the domain doesn't work again. It shows the errors at intodns.com again as well.

    http://www.intodns.com/greenimagesofcanada.com

    Here is something I found in the messages log which looks like maybe BIND restarting, perhaps it might be useful somehow.

    When my firewall (APF) restarts it seems to mention my DNS:

    These are in my resolv.conf

    My /etc/named.conf links to /var/named/chroot//etc/named.conf

    It contains:

    Which is mostly the default of ISPConfig except for the recursion part which used to show an error at intodns until I added that. Is it wrong?

    Any other ideas?

    Thanks =)
     
  16. falko

    falko Super Moderator ISPConfig Developer

    Does the zone file look identical on both ns1.greenimagesofcanada.com and ns2.greenimagesofcanada.com?
     
  17. rrhode

    rrhode New Member

    Well I tried to explain these two IPs are pointing to the same server, although I am not sure if the ns2 is setup properly or if I am even supposed to be using that as my ns2. I only have one server. So I am guessing they are using the same file. Wouldn't ISPConfig set these up when I add them as A records?
     
  18. falko

    falko Super Moderator ISPConfig Developer

    Code:
    mh1:~# dig @ns1.greenimagesofcanada.com greenimagesofcanada.com
    mh1:~# dig @ns2.greenimagesofcanada.com greenimagesofcanada.com
    
    ; <<>> DiG 9.3.4 <<>> @ns2.greenimagesofcanada.com greenimagesofcanada.com
    ; (1 server found)
    ;; global options:  printcmd
    ;; connection timed out; no servers could be reached
    mh1:~# telnet ns1.greenimagesofcanada.com 53
    
    mh1:~#
    I can't connect to your nameserver. Make sure port 53 is not blocked by a firewall, and that named is running.
     
  19. rrhode

    rrhode New Member

    It seems like port 53 is open and named is running. I have just restarted the DNS server in ISPconfig and now things appear to work again. When I restart the DNS server in ISPConfig everything is now running with no errors.

    I am using APF firewall. Maybe there is something in there causing the problem but I am not really sure. I have now added port 53 to a couple of areas and when I do nmap -sS -O 72.55.164.45 it shows it as open.
     
  20. falko

    falko Super Moderator ISPConfig Developer

    Still not working for me. I'd switch off the firewall to see if it's the reason.
     

Share This Page