Site Gone !!

Discussion in 'General' started by learning, Mar 26, 2008.

  1. learning

    learning New Member

    After deleting users from a Site, the whole site disappeared !! After checking the server, noticed the whole directory was gone as well. All files, pages etc.. I checked the recycle bin and was able to restore the users. But when I checked the site again, all files were still gone. All work on the site is gone and I did not have a backup. Can someone please help.. :( Thank you
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in /home/admispconfig/ispconfig/ispconfig.log?
    Did you modify the ISPConfig sources or the ISPConfig database?
     
  3. learning

    learning New Member

    No Errors?

    Hello Falko,

    Thank you for responding. I checked the log file and didn't see any "Errors". Only thing I saw were "Warns" and one "Debug". I didn't touch the database or anything else associatred with Ispconfig. The users were restored from the recycle bin but the whole site including Gigs worth of unique (unbacked) files are did not come back. So before I do anything worse, I wanted to try the forum for a solution.

    Thank you,

    Learning
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you post the warnings and debugs from the log?
     
  5. learning

    learning New Member

    Logfile

    Hello Falko,

    Below are the Warns and Debugs I found in the file. Some were duplicated so I didn't include them. Please advise.

    Thanks again,

    Henry


    17.03.2008 - 11:23:55 => DEBUG - The name www.propaddles.com is already in use by another site or domain.<br><br><br> <a href='../../isp_manager/frame_start.php?'>Next &gt;&gt;</a>

    17.03.2008 - 11:59:36 => DEBUG - The recycle bin cannot be accessed because the system is currently being updated. Please try again in a few minutes.<br><br> <a href='../frame_start.php?'>Next &gt;&gt;</a>

    17.03.2008 - 12:01:05 => WARN - maildirmake /var/www/web2/user/web2_postmaster/Maildir &> /dev/null, Line 106: WARNING: could not maildirmake /var/www/web2/user/web2_postmaster/Maildir &> /dev/null

    17.03.2008 - 12:10:20 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 966: WARNING: could not setquota -u web3_postmaster 0 0 0 0 -a &> /dev/null

    17.03.2008 - 12:58:59 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 966: WARNING: could not setquota -u web1_postmaster 0 0 0 0 -a &> /dev/null

    18.03.2008 - 23:59:03 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: WARNING: could not /etc/rc.d/init.d/postfix stop &> /dev/null

    19.03.2008 - 14:23:40 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1923: WARNING: could not groupadd -g 12001 web1_anonftp &> /dev/null
    19.03.2008 - 14:23:40 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1924: WARNING: could not useradd -d /var/www/web1/ftp -g web1_anonftp -M -s /bin/false -u 12001 web1_anonftp &> /dev/null


    FYI: I have disabled Postfix and all mail services on the server because the server had been comprimised. I am now using third party Email hosting (personal preference).
     
  6. falko

    falko Super Moderator ISPConfig Developer

    What's the path and the domain of the web site that was deleted? Which distribution are you using? And which ISPConfig version?
     
  7. learning

    learning New Member

    Path

    Hello Falko,

    Here is the path which is similar for all the other sites. Difference being web1, web3 etc..

    /var/www/web2/web

    Domain is uspaddleballassociation.org

    ISPCnfig version is,

    ISPConfig
    Version: 2.2.8
    (c) ISPConfig 2008

    Hope this helps. This all happened after I had deleted users for the site. Somehow, deleting the users also deleted the whole site. But the restore only bright back the users. It also provided a generic index.html. So it must be a bug or something. At this point I am willing to pay for support as I have done in the past. Please advise asap.

    Thank you,

    Henry
     
  8. learning

    learning New Member

    Distribution

    Oh Forgot,

    Distribution is Fedora Core 5

    Thanks,

    Henry
     
  9. falko

    falko Super Moderator ISPConfig Developer

    I suggest that you upgrade to ISPConfig 2.2.21. There might be some bugs in 2.2.8 that might have caused your problem.
     
  10. learning

    learning New Member

    Upgrade?

    Hello Falko,

    Will I get my Site back after I upgrade???

    Rgds, Henry
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    No. A update can not restore files that have been deleted from your harddisk. But updating might prevent that this happens again.
     

Share This Page