Site creation IPv4-Address *

Discussion in 'General' started by Jeremy88, Mar 6, 2022.

  1. Jeremy88

    Jeremy88 New Member

    Hello everybody
    sorry for my english, but above all sorry for my ignorance on the subject, i'm a novice user and i'm trying to learn. the problem I present to you is the following: when I create a new site, and I go to choose IPv4-Address, no ip address appears, but only a * to premise that I am running ispconfig on a virtual machine on debian 11.2

    if I can I insert an attachment to make you understand hello and thank you very much for your replies
    [​IMG]
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Do you have a reason you want to select a specific IP address? That is a common source of misconfigured servers, it is almost always the wrong thing to do, though there are some use cases for it.
     
  3. Jeremy88

    Jeremy88 New Member

    Thanks a lot for the answer,
    so you are telling me that it is normal that the symbol * comes out in that field, following the guides, even on youtube, the ip address of the server appears there, but I think that the network configuration I have made is the right one.

    / etc / hosts:
    127.0.0.1 localhost.localdomain localhost
    # This line should be changed to the correct servername:
    192.168.188.200 server1.example.com server1

    # The following lines are desirable for IPv6 capable hosts
    :: 1 localhost ip6-localhost ip6-loopback
    ff02 :: 1 ip6-allnodes
    ff02 :: 2 ip6-allrouters
    where, 192.168.188.200 is the ip address of the server

    / etc / hostname
    server1

    can you make me understand where I'm wrong?, I tried to create a new site by leaving * in the IPv4-Address field and also adding a dns, but I can't reach the site by entering the server's ip address in the dns of my computer

    I apologize in advance for my ignorance on the subject, but from what I said I am learning.
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, this field must show * as @Jesse Norell told you.
     
  6. Jeremy88

    Jeremy88 New Member

    as I wrote in the first post, I'm using a virtual machine on my pc using virtual box, I don't have ipsconfig on an external server and I repeat I'm at first experiences, I'm not an expert. To install ispconfig I used a guide on the forum, which installs everything automatically, thank you for answering me, the problem is that I still can't reach the site. I created the site by setting everything, I also created the dns for the aforementioned, but when I set the dns on my pc (ip address of the server) and I try to reach the site it does not work, where I'm wrong thanks a lot
     
  7. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    To test your dns setup, if you ping the website name you are trying to contact, does it display the correct address for your ispconfig system? (I imagine that is a private ip address that exists only in your virtualbox setup.) It sounds like you are accessing ISPConfig there (port 8080), so it should be that same ip address.

    Just a note to understand the website ip selection choice better, that selects the ip address on which the webserver will answer requests for the website - using '*' means it should answer requests using any ip address on your ISPConfig server, and that is normally what you want. If your ISPConfig server had multiple ip addresses and there were some reason you really wanted it to only serve requests when the connection is using one ip address and not any others, you would select the ip address for that site. But it has other implications in the order of vhost selection for requests and generally complicates things => leads to frequent misconfigurations.
     

Share This Page