simplesamlphp site access

Discussion in 'Installation/Configuration' started by Dvelopin, Sep 14, 2016.

  1. Dvelopin

    Dvelopin New Member

    I have installed and successfully configured SimpleSAMLphp on my test server, but am now trying to use this within a web application.

    The code requires a file:

    require_once ('/usr/share/simplesamlphp/lib/_autoload.php');
    But I get the following error:

    Fatal error: require_once(): Failed opening required '/usr/share/simplesamlphp/lib/_autoload.php' (include_path='.:/usr/share/php') in /var/www/clients/client0/web3/web/index.php on line 9
    I tried adding /usr/share/simplesamlphp/ to the include_path, but this didn't work. How can I provide access to the simplesamlphp files needed by my application with an ISPConfig setup?

    The file being required is definitely I am assuming a permissions issue...but how to fix it?

    I'd appreciate anybodies help on this.
  2. Jesse Norell

    Jesse Norell Active Member

    you probably need to add that directory to open_basedir in your website's php settings
  3. Dvelopin

    Dvelopin New Member

    That makes sense. I needed to add several folders but finally for it to work! That was the issue..

    However there is a new appears that because of how SimpleSAMLphp gets installed, it uses a different PHP configuration which means a different session path to what the actual site has. /simplesamlphp is an alias for all sites.

    Testing authentication with an active directory federation service, works great now as long as I remain within the /simplesamlphp alias. When I go back to my domain and use a custom script, I get pushed to the login screen but back with an error due to session data being lost. I believe this is a result of the alias and my domain being technically two different sites.

    So how can I get at least my 1 site to share the same session data as the main, general, apache sites?
  4. Dvelopin

    Dvelopin New Member

    I got my issue fixed by removing the alias and adding a symlink to the same folder. Now everything is sharing the same cookie domain and sessions.

Share This Page