Simple updating question...

Discussion in 'General' started by PAN_SCN_SUX, Jan 24, 2011.


    PAN_SCN_SUX New Member

    Sorry, I am and have been having a hard time finding this in the forums or in the ISPCONFIG 3 documentation; I know I have seen it listed here before, so hopefully, it'll be easily answered...

    I know how to run th - BUT, isn't there a script that can be run in terminal (or any way for that matter) to run back through the installer, even though there are no updates available for ISPCONFIG

    I've looked in all of the suspect places, (like /local/ispconfig/...) yet cannot find anything that will just re-run the ISPCONFIG 3 script WITHOUT it being for an update. (I am running the current version and DON'T want to move to the SVN...)

    Reading this, it sounds hard to understand; I hope it is not. Simply put some configuration changes made to my IP's and such make me think I should run the script through again for virtual addresses and such to get "noticed" and to set everything "straight" with ISPCONFIG.

    Can anyone provide this for me; I am exhausted from searching!

    Thanks in advance.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please see manual update instructions in the release notes:

    PAN_SCN_SUX New Member

    OK, I guess...

    So, what, --> as lead dev. you are telling me I should write my own script then aren't you as all that one will find in that post is:

    1) How to UPGRADE to a higher version or to the SVN.
    2) How to perform a manual OVERWRITE install by downloading the SAME VERSION that is currently installed to the "tmp" folder and re-running that install script???

    OK, I vote for an "UPDATE" script. I thought I had read it being done in one of the endless posts here. I'll write my own I suppose; although it is pure insanity it is not included...

    BTW ---> What is the deal with the vBulletin "quote error" - big gap added into a quote tag until there is a reply?
    EDIT I guess editing one's post, fixes the quote gap too...
    EDIT 2 No, it only fixes it if your edit is in the "non advanced" editor; the advanced editor still has the bug; see, it's (the unneeded gap in the quote tag) still here, waiting on a post.
    Last edited: Jan 24, 2011
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so you have prooven with your post now that havent read the page that I sent you the link for. Of course you can write our own scripts if you dont want to use the existing scripts from ispconfig ;)

    1) Login as root user and run:

    2) See the link that I posted you above:

    cd /tmp
    tar xvfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install
    php -q update.php
    Last edited: Jan 24, 2011

    PAN_SCN_SUX New Member

    OK, show me the light...

    What am I missing??? I am not that inept man; I posted in the OP what "" does, do you not know how your own script behaves, or is there truly something I am missing here??? See attached picture please...


    PAN_SCN_SUX New Member

    At any rate...

    Besides Till, how does Step 1 in the post you just made relate to downloading the same version and reinstalling it anyway??? ---> "2) See the link I posted you above."

  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You do not seem to read the complete posts.

    You asked 2 questions for two different update scenarios. 1) How a normal ispconfig update works. 2) How to update a system which is already up to date and I posted you two differnt instructions for these two kind of updates.

    Of course the normal update script does not allow you to update a already up to date install to protect a stable installation. If you select SVN, then you can update to SVN versions without version check, but thats for developers only. In case that you need to reconfigure a existing install, I posted you the commands for that under 2).

    PAN_SCN_SUX New Member


    No, Till you are the one not reading and/or comprehending here. I STATED that all one can do is:


    Why in the World the "" REQUIRES there to be an update, even if you need have it (the script) download the same binary to run a reconfigure is beyond me and certainly a flaw in logic.

    I had the right answer for reconfiguring an install of the same version when I replied to your first reply. All that can be done is to completely re-download the same binary manually to the tmp folder, unzip and run the "php -q update.php" command from the install folder; just as you posted which I think is silly.

    Can we not have the have a third option then that simply allows it to proceed WITHOUT the version check/update requirement?
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    So you want a option in the script for something that you normally should not do and something which is normally not nescessary. I really dont think that we will add this as it will cause more problems then it will help somebody. I think you have not fully understand when this script is needed.

    Rerunning the update script is only a nescessary step if you deleted files in /etc like the /etc/dovecot/dovecot.conf file and you dont have a backup of them. Everything else is done trough the ispconfig interface, so you never run the update script manually except if there is a new ispconfig update available, and thats what this script ensures. E.g. if you cahnged a IP address, then go to system > server IP in ispconfig and change it there. Thats all. Nobody wants to run a update for that again.

    PAN_SCN_SUX New Member


    OK, apologies all around. The silliness is to protect one from oneself.

    My bad...

    PAN_SCN_SUX New Member

    I understand; you hit the nail on the head though for me; the reason I planned to re-run it. I DID change some IP's and they are not there in ISPCONFIG to change - the only way I presume it would properly accept the changes is to delete the domain(s) and all their contents and that seemed not only counter-intuitive, but as well a heck of a lot more hassle than having ispconfig supposedly pull the IP's during the config. Honestly, I have no idea if it would "fix" the issue or not; since it (the regular ISPCONFIG web interface) does not allow me to change the IP to the proper one, I guess it may be asking too much to have the configuration script do so for me properly as well.

    Can I ask, why is it that a domain is limited to either "*" or the webserver's IP? This is causing some issues for me. (I know perhaps it shouldn't...)

    Is there any instance where a domain's IP drop-down would have more than just ispconfig's IP and "*"?

    BTW, I would not even be asking this if all of this were in production as the issue arises more out of DNS issues than anything else. I guess I should just set up a local DNS here on the LAN to finalize this setup before deploying it...
    Last edited: Jan 24, 2011
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    You can add as many ip addresses as you like under system > server ip. All ip addresses that you added there and that have the namevirtualhost checkbox enabled will get listed in the website settings.
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    When I setup a server without having the domains pointing to the correct IP's already, I modify the hosts file on my workstation instead:

    thats easier then setting up a local dns server and works well for me on Windoes and Linux.

    PAN_SCN_SUX New Member


    Yes, I did that. I think, I "may" have resolved what I was trying to by totally changing the IP of ISPCONFIG itself; that was essentially the issue and all I was trying to accomplish by the re-configure - it's last two octets were completely out in left field in comparison to the domains; this caused all kinds of Hell trying to deal with just what you mention (host files - as I was using that method rather than a local DNS server, as surely setting up DNS on the LAN just for testing is silly...) :)

    I suppose my fear was that ispconfig would be unreachable, or would "choke" when I changed the system IP since it was installed on a weird address. I am unsure why it did not create a problem simply changing the IP's for the ispconfig install under Admin>System>Server Config, but hey, I'm not complaining, for it seems to have worked!

    Thanks. Suppose I did not need re-run the installer after all (or delete the domains either! whew!)

Share This Page