simple Postfix question

Discussion in 'Server Operation' started by timaaarrreee, Sep 21, 2008.

  1. timaaarrreee

    timaaarrreee ISPConfig Developer ISPConfig Developer

  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Are there any errors in your mail log?
     
  3. timaaarrreee

    timaaarrreee ISPConfig Developer ISPConfig Developer

    um i am not sure how to check the postfix error log but in webmin, i lookin the mail que and here are the messages i try to send to the outsite world.

    it says:


    Mail ID Sent From To Size Status
    2B65310847 Sun Sep 21 22:03:37 admispconfig@internet.khost.co.nz timsullivan@ihug.co.nz 897 bytes Host or domain name not found. Name service error for name=ihug.co.nz type=MX: Host not found, try again
    4F93F108EC Wed Sep 17 17:20:09 admispconfig@internet.khost.co.nz timsullivan@ihug.co.nz 3.45 kB Host or domain name not found. Name service error for name=ihug.co.nz type=MX: Host not found, try again
    AD87510840 Sun Sep 21 12:21:06 admispconfig@internet.khost.co.nz timsullivan@ihug.co.nz 1.30 kB Host or domain name not found. Name service error for name=ihug.co.nz type=MX: Host not found, try again

    Hope that helps show the problem :)
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    What's in /etc/resolv.conf?
     
  5. timaaarrreee

    timaaarrreee ISPConfig Developer ISPConfig Developer

    all it says is :
    Code:
      GNU nano 2.0.7            File: /etc/resolv.conf
    
    nameserver 10.1.1.1
    
    
    
    10.1.1.1 is my routers IP
     
  6. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Can you try
    Code:
    nameserver 145.253.2.75
    instead?
     
  7. timaaarrreee

    timaaarrreee ISPConfig Developer ISPConfig Developer

    Ok i have changes it but it still isnt sending mail to the outside of my server in Telaen Webmail.

    There may be a possibility that my ISP blocks port 25.

    And they have tild me that they do not allow mail relaying due to SPAM.

    But they did say i could use their smtp server.

    Is there a way i can change my config files to use an external smtp server?
     
  8. timaaarrreee

    timaaarrreee ISPConfig Developer ISPConfig Developer

    ok i just tried to send to my gmail account and it worked!

    But when i send to my isp email i get the nasty messgae. I almost looks perosnel

    In webmin the mail que status message:

    host zuul.ihug.co.nz[203.109.135.49] refused to talk to me: 554-mx.mailfilter1.ihug.co.nz 554 BLOCKED: The SenderBase reputation of your ISP or corporate mail server is extremely bad.

    It looks like my isp has blocked my domain :eek:
     
  9. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    I'd talk to your ISP and ask why this happens.
    Make sure you have proper SPF and reverse records.
     
  10. timaaarrreee

    timaaarrreee ISPConfig Developer ISPConfig Developer

    ok how would i get SPF records to work to that ISP's will accept my mail that I am sending?
     
  11. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

Share This Page