simple file server

Discussion in 'HOWTO-Related Questions' started by vvlonghorn, May 30, 2008.

  1. vvlonghorn

    vvlonghorn New Member

    I just finished setting up my Ubuntu file server with samba, and i'm running into a wall. The server is running fine, but I can't access it from my windows machine. It shows up in the "my network", but whenever I try to access the computer to view the shared directories, it says that access is denied. Also, I can't access it from internet explorer.

    And I have already changed the samba config file to:

    force group = nogroup
    guest ok = yes

    any help would be much appreciated
  2. sjau

    sjau Local Meanie Moderator

    Hmmm, nevern done sharing without credentials...

    With winxp (and probably vista) you could mounte a shared folder as drive letter and have the login credential saved... if you're willing to do that it's easy :)
  3. vvlonghorn

    vvlonghorn New Member

    thats the problem, I tried to mount the disk, but i can't even see the folders on my media server. It says i don't have access
  4. edge

    edge Active Member Moderator

    Maybe a bit off topic for you, but why did you use Ubuntu?

    Some time ago I needed to setup a file server for a friend, and used this howto:
    It's called SME, and it was so easy to setup.
    Windows users are having no problems access it. They even have access with a VPN if they want.
  5. vvlonghorn

    vvlonghorn New Member

    Well, I chose ubuntu because it has native support for NTFS (which is what my hard drive that has over 100gb of data is formatted in) and also, because SME prefers either a single drive or multiple identical ones. My setup is a small older drive for the OS and a giant new drive for the data.

    But just trying to trouble shoot here, do i have to create a samba username that is the same as the windows box's username?

    Sidenote: if you like SME, you might check out freeDNS, i set one up for my brother and he said its running like a charm
  6. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your logs?
  7. sjau

    sjau Local Meanie Moderator

    what's the content of your samba config?
  8. vvlonghorn

    vvlonghorn New Member

    wow so this is definitely an embarassing moment, but it turns out that the problem was with my windows machine. Evidentally my firewall chose block access from windows explorer without asking if the program was allowed to. Thanks for all the help... it works like a charm now.

Share This Page