shortcuts in var/www pointing to wrong directory

Discussion in 'Technical' started by cruz, May 7, 2008.

  1. cruz

    cruz New Member

    I reloaded a few websites, but now when I go into the var/www, the domain directory shortcuts are pointing to the old site. like one is web1 when it is now web5. How do I redirect these to the correct directory? Thank you for having this site.
    New info- I went into var/www with winSCP and clicked on the shortcut of the dir that Is in question. It took me to the var/www/web1 dir. but that is the old dir that I do not have any more. There are no files in it. The same with the other sites shortcut. It is pointing to the old dir.
     
    Last edited: May 7, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    You can change the symlinks like this:

    Code:
    ln -sf /var/www/web1 /var/www/www.example.com
    where /var/www/www.example.com is a symlink and /var/www/web1 is the new target directory.
     
  3. cruz

    cruz New Member

    Still not corect.

    I ran the commands and changes to match my files. I still get errors. I use winSCP to enter the server. when I get to var/www/ I can see the 3 webistes domain names. when I dubble click on the site I get
    HTML:
    No such file or directory.
    Error code: 2
    Error message from server: No such file
    Request code: 11
    It is looking for web1. There is no web 1 any more. But when I right click the domain shortcut and go to property, it tells me that the group is web19 and the and the owner is www-data. these are both correct.
    Why is it not fixing the redirect after I run the commands you gave me ? Is this a big deal in the the running of the websites? because I am having trubble when people try to register, they are getting a 404 error page comes up.
     
    Last edited: May 9, 2008
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /var/www/
    ?
     
  5. cruz

    cruz New Member

    I fixed it

    I just ran. ln -sf /var/www/www.apostolichearts.com /var/www/web26 and it fixed it
     

Share This Page