ShellUser Directory Rights to start apps via ssh -X

Discussion in 'Installation/Configuration' started by h2fpirate, Mar 2, 2014.

  1. h2fpirate

    h2fpirate New Member

    Set ShellUser Directory Rights to start apps via ssh -X

    Hello,
    I'm relatively new to ispconfig and I really like it ... everything installed and works fine for me (quad server installation WEB/MAIL/NS1/NS2). Thanks to the manual I bought :)
    Now I'd like to do some customizations. I tried a few days and now I decided to get help, because I do not get anywhere besides into troubles :(

    The thought: How cool would be that if I can start emacs via ssh -X on my local machine and it would feel like having the complete Programming environment handy and setup -> no ftp, no mounts no syncronisation issues. just working and turning off my local machine. next time start from where you left. :) , this can become true if....this final problem can be solved. (of course there are other possible solution, but I'd like to start off with that easy one)

    A shelluser is created and of course now we need a little bit more customized directory structure, at least for emacs environment (.emacs.d Directory). I could only set it up by logging in as root and removing the i attrib via chattr -i
    from the web directory. Now I could start the commandline version. Still not enough... (additional folders and create rights in $HOME of the shelluser would be cool as well and the next step is the automated creation of Dirstructure on Shelluser which leads me to the next question (what do I have to modify or do I have to write an addon? how do I do this).

    The main thing now is to redirect .Xauthority to be created in
    ~/tmp directory if I start apps like ssh -X isp-server emacs, or at least
    allow it to be created in $HOME, where the user can not do anything
    by default.


    I tried to create ~/.profile and added an export for the XAUTTHORITY to be located in ~/tmp, but it will be used too late in the load chain, somehow it needs to be set a step before, probably at the time of ssh connect. (It should only used for users which are in the group of shellusers). Thats basically it. any Ideas or workflows would be really helpful.

    Thanks a lot and I will be looking forward to suggestions or even solutions.
     
    Last edited: Mar 2, 2014
  2. h2fpirate

    h2fpirate New Member

    How is the shelluser doing what he does

    What is being configured to have the shelluser work in his private and web directory only?

    My guesses/research:

    I found that the shell user directory has the attribute i, so not even root can create nor delete files or directories (permission denied)

    The web directory has shelluser ownership and can be used as wanted.

    Question:
    How is that accomplished that the shelluser is logging in into his directory, where is it configured?
    Where can I set additional directories to be created on website creation?
     

Share This Page