shell-users no more working

Discussion in 'Installation/Configuration' started by aldo, Sep 2, 2011.

  1. aldo

    aldo New Member HowtoForge Supporter

    Until yesterday shell users worked fine. Then I had to rename a user and the problems started.

    Using Webmin I noticed that renaming a user with ISPConfig 3, the old one is not deleted so I deleted via Webmin, what a mess.

    Now, even creating new shell-users, no longer work.

    The situation is this:
    a client with multiple sites
    for each site I create a shell-user to allow access to the site folder through SFTP.

    Can anyone help me to solve?
     
    Last edited: Sep 2, 2011
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Using webmin on a ispconfig server can break the system as webmin does not fully support the configuration ispconfig uses. For that reason i always recommend to not install webmin. I guss webmin accidently deleted the web main user instead of a shell user. There are two options, either you delete the whole website with all shell users and crate a new one or you restore paswd, shadow and group files from a backup.
     
  3. aldo

    aldo New Member HowtoForge Supporter

    I tried deleting and recreating site and shell-user with a new name, it works. Thank you.

    However I can not reuse the old names, I think there is a small bug.

    Deleting a shell-user in ISPConfig 3 this is not actually deleted.

    Thus, creating a new shell-user in ISPConfig 3, re-using the old name does not change the ID.

    For example:
    web1 id 5009
    shelluserweb1 id 5008

    How do I actually delete a shell-user no longer used in ISPConfig 3 without making a mess?

    Thanks.
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which ISPConfig version do you use? When I delete a shell user on a ispconfig 3.0.3.3 server, then it gets removed correctly and I can reuse the same shell user name.

    Thats the intended behaviour. All shellusers of a website share the same ID, otherwise the shell user wont be able to edit any files of the website.

    I guess your problem might be that webmin is not showing ispconfig shell users correctly. If you like to know if a shell user has been deleted, take look in the shell user list in isponfig and dont use webmin.
     
  5. aldo

    aldo New Member HowtoForge Supporter

    I'm using ISPConfig 3.0.3.3.

    The current behavior is just that the IDs are different.

    For example, working only in ISPConfig 3:
    Create siteX, and so the user web1 with 5008.
    Create shelluser1 linked to siteX (with assigned ID 5008).
    shelluser1 works.

    Delete Shelluser1.
    Delete siteX

    Recreate siteX, and so the user web2 with ID 5009.
    Recreate shelluser1 linked to siteX (but this keeps ID 5008).
    shelluser1 no longer works.

    I hope that I explained.
     
    Last edited: Sep 2, 2011
  6. aldo

    aldo New Member HowtoForge Supporter

    [IGNORE] shell-users no longer working

    I tried to reproduce the behavior described, without success.

    May be that the problem was related to users modified with Webmin.

    Sorry! ... (but a little more quiet)
     

Share This Page