Shell users cannot log in

Discussion in 'Installation/Configuration' started by dfumagalli, Jul 22, 2016.

  1. dfumagalli

    dfumagalli New Member


    Here are my specs:
    Ubuntu 14.04.4 LTS (64 bit)
    ISPConfig Version:

    I have an issue: when I create shell users (no Jailkit, no RSA key), they get properly created in the /etc/passwd file and their home directory gets created too.

    i.e. if I have a website whose root is:
    and whose associated user name is: "prefix" and create 2-3 users, I see:

    Created homes
    However if I try and SSH them in (using prefix before their name, as listed on ISPConfig), I always get "access denied".

    Searching the 'net I have read there would be some "enable logins" option to set in the website's preferences but, since the tutorial I have found is about an old ISPConfig version, I can't find such a switch in my screens.

    Any idea about what could be the issue?

    Best regards,
    Dario Fumagalli
    Last edited: Jul 22, 2016
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no such option in ISPConfig 3.

    The setup of the SSH users looks fine in the passwd file, so the should work. Check the syslog file for the exact login error message.
  3. dfumagalli

    dfumagalli New Member

    syslog shows me FTP / mail / DNS operations but no SSH activity whatsoever. I get no log even for users I had created before installing ISPConfig and who may log on with no issue.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    And nothing in the uath.log too? are you sure that you connect to the right server, maybe the ssh port is directed to another system?
    dfumagalli likes this.
  5. dfumagalli

    dfumagalli New Member

    I have found out I had an Allowusers clause in /etc/ssh/sshd_config. The affected user names were not added by ISPConfig (assuming it's supposed to do that, not sure), therefore they were force rejected.

    I have added them and now everything works well.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPconfig has not added this AllowUsers clause there and it does not manage the sshd_config file.
    dfumagalli likes this.
  7. dfumagalli

    dfumagalli New Member

    Ok thank you, for pointing me out to the correct log file where I found out the issue. :)

Share This Page